summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorAdrian Schröter <adrian@suse.de>2013-05-14 09:18:00 +0200
committerAdrian Schröter <adrian@suse.de>2013-05-14 09:18:00 +0200
commita5e9d1c5c5e986273d2c4dcda790c8e25dc394ca (patch)
tree036d319d90de70bc62d73be6215549a1666e613b /Makefile
parenteb11d95da584eabb1bf8798e9230b6b88c5b5580 (diff)
- map i686 to i586 architecture for initvm
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index af8e9b3..5bd4bf9 100644
--- a/Makefile
+++ b/Makefile
@@ -3,6 +3,8 @@ SCM=$(shell if test -d .svn; then echo svn; elif test -d .git; then echo git; fi
DATE=$(shell date +%Y%m%d%H%M)
BUILD=build
+INITVM_ARCH=$(shell bash detect_architecture.sh)
+
ifeq ($(SCM),svn)
SVNVER=_SVN$(shell LANG=C svnversion .)
endif
@@ -77,7 +79,7 @@ install:
# build-initvm-static) whereas the build scripts package is noarch.
initvm: initvm.c
- $(CC) -o $@.$(shell uname -m) -static $(CFLAGS) initvm.c
+ $(CC) -o $@.$(INITVM_ARCH) -static $(CFLAGS) initvm.c
initvm-all: initvm
@@ -85,7 +87,7 @@ initvm-build: initvm
initvm-install: initvm
install -m755 -d $(DESTDIR)$(pkglibdir)
- install -m755 initvm.$(shell uname -m) $(DESTDIR)$(pkglibdir)/initvm.$(shell uname -m)
+ install -m755 initvm.$(INITVM_ARCH) $(DESTDIR)$(pkglibdir)/initvm.$(INITVM_ARCH)
dist: