summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Puydt <jpuydt@debian.org>2023-07-04 08:57:32 +0200
committerJulien Puydt <jpuydt@debian.org>2023-07-04 08:57:32 +0200
commit0181e173edf23f7a86b5bdba091b483fa6549e92 (patch)
tree4bfd353672e26d6dad0e011c1262737738158994
parent18c291e6dddf5d5917e9bdff661fbbde36d67636 (diff)
parent817de2867995881a9e527b4f1eeb083558d142fd (diff)
Record obus (1.2.4-2) in archive suite sid
-rw-r--r--debian/changelog17
-rw-r--r--debian/control4
-rw-r--r--debian/patches/fix_newer_ppxlib.patch15
-rw-r--r--debian/patches/series1
-rwxr-xr-xdebian/rules2
-rw-r--r--debian/watch2
-rw-r--r--src/ppx/ppx_obus.ml2
-rw-r--r--src/protocol/oBus_address.ml6
-rw-r--r--tools/tools_util/utils.ml2
-rw-r--r--tools/transformers/obus_gen_client.ml2
10 files changed, 42 insertions, 11 deletions
diff --git a/debian/changelog b/debian/changelog
index 60d5e13..9fa5dda 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,20 @@
+obus (1.2.4-2) unstable; urgency=medium
+
+ * Team upload.
+ * Bump standards-version to 4.6.2.
+ * Fix compilation with recent dune (Closes: #1040233).
+
+ -- Julien Puydt <jpuydt@debian.org> Tue, 04 Jul 2023 08:57:32 +0200
+
+obus (1.2.4-1) unstable; urgency=medium
+
+ * Add patch to support newer ppxlib.
+ * Bump standards-version to 4.6.1.
+ * Fix d/watch.
+ * New upstream.
+
+ -- Julien Puydt <jpuydt@debian.org> Fri, 14 Oct 2022 09:02:49 +0200
+
obus (1.2.3-1) unstable; urgency=medium
* New upstream release
diff --git a/debian/control b/debian/control
index 7fa7352..3abb3f0 100644
--- a/debian/control
+++ b/debian/control
@@ -8,11 +8,11 @@ Build-Depends:
libxmlm-ocaml-dev,
liblwt-ocaml-dev (>= 4.3.0),
liblwt-log-ocaml-dev,
- libppxlib-ocaml-dev (>= 0.14.0),
+ libppxlib-ocaml-dev (>= 0.25.0),
ocaml-dune,
menhir,
ocaml-nox
-Standards-Version: 4.5.0
+Standards-Version: 4.6.2
Rules-Requires-Root: no
Section: ocaml
Homepage: https://github.com/ocaml-community/obus
diff --git a/debian/patches/fix_newer_ppxlib.patch b/debian/patches/fix_newer_ppxlib.patch
new file mode 100644
index 0000000..469dff7
--- /dev/null
+++ b/debian/patches/fix_newer_ppxlib.patch
@@ -0,0 +1,15 @@
+Description: compile with a newer ppxlib
+Author: Sonja Heinze
+Forwarded: upstream 77e1be9f4ec630908a339fd614e416d0dbd77cf5
+
+--- obus.orig/src/ppx/ppx_obus.ml
++++ obus/src/ppx/ppx_obus.ml
+@@ -42,7 +42,7 @@
+ in ()
+ ] in
+ (match exn.ptyexn_constructor.pext_kind with
+- | Pext_decl (Pcstr_tuple [typ], None) ->
++ | Pext_decl (_, Pcstr_tuple [typ], None) ->
+ Some (registerer typ)
+ | _ ->
+ Location.raise_errorf ~loc:pstr_loc
diff --git a/debian/patches/series b/debian/patches/series
index 0b1b594..02118df 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1 +1,2 @@
0001-Disable-the-tests-that-need-a-working-dbus-daemon.patch
+fix_newer_ppxlib.patch
diff --git a/debian/rules b/debian/rules
index f4e380c..f098ac8 100755
--- a/debian/rules
+++ b/debian/rules
@@ -11,7 +11,7 @@ override_dh_auto_build:
dune build -p obus
override_dh_auto_install:
- dune install --destdir=$(DESTDIR) --prefix=/usr --libdir=..$(OCAML_STDLIB_DIR)
+ dune install --destdir=$(DESTDIR) --prefix=/usr --libdir=$(OCAML_STDLIB_DIR)
rm -f $(DESTDIR)/usr/doc/obus/LICENSE
override_dh_auto_test:
diff --git a/debian/watch b/debian/watch
index 9fda10a..6f775c3 100644
--- a/debian/watch
+++ b/debian/watch
@@ -1,3 +1,3 @@
version=3
opts="uversionmangle=s/rc/~rc/" \
-https://github.com/ocaml-community/obus/releases .*/archive/(.*)\.tar\.gz
+https://github.com/ocaml-community/obus/tags .*/(.*)\.tar\.gz
diff --git a/src/ppx/ppx_obus.ml b/src/ppx/ppx_obus.ml
index e07c3e3..8e08744 100644
--- a/src/ppx/ppx_obus.ml
+++ b/src/ppx/ppx_obus.ml
@@ -42,7 +42,7 @@ let register_obus_exception = function
in ()
] in
(match exn.ptyexn_constructor.pext_kind with
- | Pext_decl (Pcstr_tuple [typ], None) ->
+ | Pext_decl (_, Pcstr_tuple [typ], None) ->
Some (registerer typ)
| _ ->
Location.raise_errorf ~loc:pstr_loc
diff --git a/src/protocol/oBus_address.ml b/src/protocol/oBus_address.ml
index 4a9296f..4d9f526 100644
--- a/src/protocol/oBus_address.ml
+++ b/src/protocol/oBus_address.ml
@@ -108,10 +108,8 @@ let xdg_fallback_session () =
Lwt.catch (fun () ->
let sock_path = Filename.concat path "bus" in
let%lwt stat = Lwt_unix.stat sock_path in
- let%lwt login = Lwt_unix.getlogin () in
- let%lwt user = Lwt_unix.getpwnam login in
- if stat.st_uid = user.pw_uid
- && stat.st_kind = Lwt_unix.S_SOCK
+ let uid = Unix.getuid () in
+ if stat.st_uid = uid && stat.st_kind = Lwt_unix.S_SOCK
then Lwt.return_some [{ name = "unix"; args = [("path", sock_path)] }]
else Lwt.return_none)
(fun _ -> Lwt.return_none)
diff --git a/tools/tools_util/utils.ml b/tools/tools_util/utils.ml
index 0025fc4..96b02fc 100644
--- a/tools/tools_util/utils.ml
+++ b/tools/tools_util/utils.ml
@@ -130,7 +130,7 @@ let convertor_recv top typ =
(fun top t ->
match t with
| "int32" | "uint32" -> Some "Int32.to_int"
- | "object_path" -> Some(paren top ("OBus_proxy.make (OBus_context.sender context)"))
+ | "object_path" -> Some(paren top ("(fun x -> OBus_proxy.make ~peer:(OBus_context.sender context) ~path:x)"))
| name when List.mem name dbus_symbols -> None
| name -> Some("make_" ^ name))
top typ
diff --git a/tools/transformers/obus_gen_client.ml b/tools/transformers/obus_gen_client.ml
index d00f013..f63ad54 100644
--- a/tools/transformers/obus_gen_client.ml
+++ b/tools/transformers/obus_gen_client.ml
@@ -141,7 +141,7 @@ let print_impl oc name members symbols annotations =
output_string oc " ";
print_names oc names;
output_string oc ")\n";
- fprintf oc " (OBus_signal.connect s_%s proxy)\n" name
+ fprintf oc " (OBus_signal.make s_%s proxy)\n" name
end
| Property(name, typ, access, annotations) ->
fprintf oc "\n let %s proxy =\n" (OBus_name.ocaml_lid name);