summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Puydt <jpuydt@debian.org>2022-08-15 22:33:44 +0200
committerJulien Puydt <jpuydt@debian.org>2022-08-15 22:34:28 +0200
commit1cc48b0ea8cfe325b5bfa6fb8833139419b9bae6 (patch)
tree23d163f12ade36bf2af1de69cd5bc01dfb6a020d
parent604dcbafc5e9248dfa202b851982a7b46b9ee227 (diff)
Add patch to support newer ppxlib
-rw-r--r--debian/changelog6
-rw-r--r--debian/control2
-rw-r--r--debian/patches/fix_newer_ppxlib.patch15
-rw-r--r--debian/patches/series1
4 files changed, 23 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 60d5e13..6f102c8 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+obus (1.2.3-1.1) UNRELEASED; urgency=medium
+
+ * Add patch to support newer ppxlib.
+
+ -- Julien Puydt <jpuydt@debian.org> Mon, 15 Aug 2022 22:33:18 +0200
+
obus (1.2.3-1) unstable; urgency=medium
* New upstream release
diff --git a/debian/control b/debian/control
index 7fa7352..ac58b2a 100644
--- a/debian/control
+++ b/debian/control
@@ -8,7 +8,7 @@ Build-Depends:
libxmlm-ocaml-dev,
liblwt-ocaml-dev (>= 4.3.0),
liblwt-log-ocaml-dev,
- libppxlib-ocaml-dev (>= 0.14.0),
+ libppxlib-ocaml-dev (>= 0.25.0),
ocaml-dune,
menhir,
ocaml-nox
diff --git a/debian/patches/fix_newer_ppxlib.patch b/debian/patches/fix_newer_ppxlib.patch
new file mode 100644
index 0000000..469dff7
--- /dev/null
+++ b/debian/patches/fix_newer_ppxlib.patch
@@ -0,0 +1,15 @@
+Description: compile with a newer ppxlib
+Author: Sonja Heinze
+Forwarded: upstream 77e1be9f4ec630908a339fd614e416d0dbd77cf5
+
+--- obus.orig/src/ppx/ppx_obus.ml
++++ obus/src/ppx/ppx_obus.ml
+@@ -42,7 +42,7 @@
+ in ()
+ ] in
+ (match exn.ptyexn_constructor.pext_kind with
+- | Pext_decl (Pcstr_tuple [typ], None) ->
++ | Pext_decl (_, Pcstr_tuple [typ], None) ->
+ Some (registerer typ)
+ | _ ->
+ Location.raise_errorf ~loc:pstr_loc
diff --git a/debian/patches/series b/debian/patches/series
index 0b1b594..02118df 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1 +1,2 @@
0001-Disable-the-tests-that-need-a-working-dbus-daemon.patch
+fix_newer_ppxlib.patch