summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephane Glondu <steph@glondu.net>2011-04-18 17:32:20 +0200
committerStephane Glondu <steph@glondu.net>2011-04-18 17:32:20 +0200
commit176d8fc3e9315d45e8e441eb3a2383662f0814f7 (patch)
treed9262f6e39c04432cd0090954b3d03aa2f5fcc2a
parent5e9f413bca4ecfd8dd88062d267bc8d5ee437025 (diff)
Switch patches to dom-*-patches scheme
-rw-r--r--debian/patches/0001-Fix-camlp4of.opt-detection-in-configure.patch (renamed from debian/patches/update-configure.patch)42
-rw-r--r--debian/patches/0002-Allow-byte-only-compilation.patch (renamed from debian/patches/01-byte-compilation.dpatch)29
-rw-r--r--debian/patches/0003-Fix-META-file-for-bitstring.syntax.patch (renamed from debian/patches/fix_META.patch)15
-rw-r--r--debian/patches/no-camlp4of-opt.patch20
-rw-r--r--debian/patches/series7
5 files changed, 68 insertions, 45 deletions
diff --git a/debian/patches/update-configure.patch b/debian/patches/0001-Fix-camlp4of.opt-detection-in-configure.patch
index 99ea36e..d4afd4a 100644
--- a/debian/patches/update-configure.patch
+++ b/debian/patches/0001-Fix-camlp4of.opt-detection-in-configure.patch
@@ -1,7 +1,17 @@
-Index: ocaml-bitstring/configure
-===================================================================
---- ocaml-bitstring.orig/configure 2009-07-04 20:52:47.000000000 +0000
-+++ ocaml-bitstring/configure 2009-07-04 20:57:41.000000000 +0000
+From: Sylvain Le Gall <gildor@debian.org>
+Date: Sat, 4 Jul 2009 21:05:17 +0000
+Subject: Fix camlp4of.opt detection in configure
+
+Signed-off-by: Sylvain Le Gall <gildor@debian.org>
+---
+ configure | 50 ++++++++++++++++++++++++++++++++++++++++++++++----
+ configure.ac | 6 +++++-
+ 2 files changed, 51 insertions(+), 5 deletions(-)
+
+diff --git a/configure b/configure
+index 7f5fa37..9587336 100755
+--- a/configure
++++ b/configure
@@ -643,6 +643,7 @@ DIFF
TIME
OCAML_PKG_cil
@@ -10,7 +20,7 @@ Index: ocaml-bitstring/configure
CAMLP4OF
OCAMLFIND
OCAMLBUILD
-@@ -5295,8 +5296,8 @@
+@@ -5295,8 +5296,8 @@ $as_echo "$as_me: error: You must have ocaml and findlib installed" >&2;}
{ (exit 1); exit 1; }; }
fi
@@ -21,7 +31,7 @@ Index: ocaml-bitstring/configure
{ $as_echo "$as_me:$LINENO: checking for $ac_word" >&5
$as_echo_n "checking for $ac_word... " >&6; }
if test "${ac_cv_prog_CAMLP4OF+set}" = set; then
-@@ -5312,7 +5313,7 @@
+@@ -5312,7 +5313,7 @@ do
test -z "$as_dir" && as_dir=.
for ac_exec_ext in '' $ac_executable_extensions; do
if { test -f "$as_dir/$ac_word$ac_exec_ext" && $as_test_x "$as_dir/$ac_word$ac_exec_ext"; }; then
@@ -30,7 +40,7 @@ Index: ocaml-bitstring/configure
$as_echo "$as_me:$LINENO: found $as_dir/$ac_word$ac_exec_ext" >&5
break 2
fi
-@@ -5333,8 +5334,49 @@
+@@ -5333,8 +5334,49 @@ $as_echo "no" >&6; }
fi
@@ -81,3 +91,21 @@ Index: ocaml-bitstring/configure
$as_echo "$as_me: error: You must have camlp4 installed" >&2;}
{ (exit 1); exit 1; }; }
fi
+diff --git a/configure.ac b/configure.ac
+index 174ed8c..c72bdb5 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -59,7 +59,11 @@ if test "x$OCAMLFIND" = "x"; then
+ fi
+
+ dnl Check for camlp4
+-AC_CHECK_PROG(CAMLP4OF,camlp4of.opt,camlp4of.opt,no)
++AC_CHECK_PROG(CAMLP4OF,camlp4of,camlp4of,no)
++AC_CHECK_PROG(CAMLP4OFOPT,camlp4of.opt,camlp4of.opt,no)
++if ! test "x$CAMLP4OFOPT" = "xno"; then
++ CAMLP4OF=$CAMLP4OFOPT
++fi
+ if test "x$CAMLP4OF" = "xno"; then
+ AC_MSG_ERROR([You must have camlp4 installed])
+ fi
+--
diff --git a/debian/patches/01-byte-compilation.dpatch b/debian/patches/0002-Allow-byte-only-compilation.patch
index 5aa1735..916d541 100644
--- a/debian/patches/01-byte-compilation.dpatch
+++ b/debian/patches/0002-Allow-byte-only-compilation.patch
@@ -1,15 +1,17 @@
-#! /bin/sh /usr/share/dpatch/dpatch-run
-## 01-byte-compilation.dpatch by Sylvain Le Gall <gildor@debian.org>
-##
-## All lines beginning with `## DP:' are a description of the patch.
-## DP: Allow byte only compilation.
+From: Sylvain Le Gall <gildor@debian.org>
+Date: Sat, 9 Aug 2008 21:35:35 +0000
+Subject: Allow byte only compilation
-@DPATCH@
-Index: ocaml-bitstring/Makefile.in
-===================================================================
---- ocaml-bitstring.orig/Makefile.in 2009-06-26 22:18:38.000000000 +0200
-+++ ocaml-bitstring/Makefile.in 2009-06-26 22:39:14.000000000 +0200
-@@ -33,6 +33,8 @@
+Signed-off-by: Sylvain Le Gall <gildor@debian.org>
+---
+ Makefile.in | 10 ++++++++--
+ 1 files changed, 8 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile.in b/Makefile.in
+index d64750d..aebdaa7 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -33,6 +33,8 @@ BYTESWAP_H = @BYTESWAP_H@
OCAMLLIB = @OCAMLLIB@
top_srcdir = @top_srcdir@
@@ -18,7 +20,7 @@ Index: ocaml-bitstring/Makefile.in
pkg_cil = @OCAML_PKG_cil@
pkg_extlib = @OCAML_PKG_extlib@
-@@ -77,11 +79,15 @@
+@@ -77,11 +79,15 @@ BENCHMARKS = $(patsubst %.ml,%,$(wildcard benchmarks/*.ml))
all: $(BYTESWAP_H) \
bitstring.cma bitstring_persistent.cma \
@@ -35,7 +37,7 @@ Index: ocaml-bitstring/Makefile.in
bitstring.cma: bitstring_types.cmo bitstring_config.cmo \
bitstring_c.o bitstring.cmo bitmatch.cmo
$(OCAMLMKLIB) -o bitstring $^
-@@ -268,7 +274,7 @@
+@@ -268,7 +274,7 @@ endif
# Install.
install:
@@ -44,3 +46,4 @@ Index: ocaml-bitstring/Makefile.in
bitstring.cmi \
bitstring_persistent.cmi \
pa_bitstring.cmo
+--
diff --git a/debian/patches/fix_META.patch b/debian/patches/0003-Fix-META-file-for-bitstring.syntax.patch
index 5732189..f4fe152 100644
--- a/debian/patches/fix_META.patch
+++ b/debian/patches/0003-Fix-META-file-for-bitstring.syntax.patch
@@ -1,6 +1,18 @@
+From: Mehdi Dogguy <mehdi@debian.org>
+Date: Fri, 8 Oct 2010 22:03:07 +0200
+Subject: Fix META file for bitstring.syntax
+
+Bug-Debian: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=599552
+Signed-off-by: Mehdi Dogguy <mehdi@debian.org>
+---
+ META.in | 5 +++--
+ 1 files changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/META.in b/META.in
+index 6e99669..699ba44 100644
--- a/META.in
+++ b/META.in
-@@ -16,7 +16,8 @@
+@@ -16,7 +16,8 @@ package "persistent" (
package "syntax" (
version = "@PACKAGE_VERSION@"
description = "Syntax extension: bitstring operators"
@@ -11,3 +23,4 @@
+ archive(syntax,toploop) = "pa_bitstring.cmo"
preprocessor = "camlp4of"
)
+--
diff --git a/debian/patches/no-camlp4of-opt.patch b/debian/patches/no-camlp4of-opt.patch
deleted file mode 100644
index 377a008..0000000
--- a/debian/patches/no-camlp4of-opt.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-Index: ocaml-bitstring/configure.ac
-===================================================================
---- ocaml-bitstring.orig/configure.ac 2009-07-04 20:52:47.000000000 +0000
-+++ ocaml-bitstring/configure.ac 2009-07-04 20:56:45.000000000 +0000
-@@ -59,9 +59,13 @@
- fi
-
- dnl Check for camlp4
--AC_CHECK_PROG(CAMLP4OF,camlp4of.opt,camlp4of.opt,no)
-+AC_CHECK_PROG(CAMLP4OF,camlp4of,camlp4of,no)
-+AC_CHECK_PROG(CAMLP4OFOPT,camlp4of.opt,camlp4of.opt,no)
-+if ! test "x$CAMLP4OFOPT" = "xno"; then
-+ CAMLP4OF=$CAMLP4OFOPT
-+fi
- if test "x$CAMLP4OF" = "xno"; then
-- AC_MSG_ERROR([You must have camlp4 installed])
-+ AC_MSG_ERROR([You must have camlp4 installed])
- fi
-
- dnl Check for Extlib (optional)
diff --git a/debian/patches/series b/debian/patches/series
index 01101d7..36d495b 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,4 +1,3 @@
-no-camlp4of-opt.patch
-01-byte-compilation.dpatch
-update-configure.patch
-fix_META.patch
+0001-Fix-camlp4of.opt-detection-in-configure.patch
+0002-Allow-byte-only-compilation.patch
+0003-Fix-META-file-for-bitstring.syntax.patch