summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMehdi Dogguy <mehdi@debian.org>2010-01-09 11:32:36 +0100
committerMehdi Dogguy <mehdi@debian.org>2010-01-09 11:32:36 +0100
commit3b080a7fdfb5653f6a36a123b4e9be996a00f97d (patch)
tree7bd1ff7b6e29772ed8d56e11997afef9714075cf
parent6d1ae130731d00802079cde55ce9b30ca6e4ce58 (diff)
Remove fix_ARCH_ALIGN_INT64.dpatch: integrated upstream.
-rw-r--r--debian/changelog1
-rw-r--r--debian/patches/fix_ARCH_ALIGN_INT64.dpatch57
2 files changed, 1 insertions, 57 deletions
diff --git a/debian/changelog b/debian/changelog
index 2b87771..8dc2c26 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,7 @@
ocaml-bitstring (2.0.2-1) UNRELEASED; urgency=low
* New upstream release (Closes: #564222)
+ + Remove fix_ARCH_ALIGN_INT64.dpatch: integrated upstream.
* Add myself to uploaders.
* Remove DMUA flag, not needed anymore.
diff --git a/debian/patches/fix_ARCH_ALIGN_INT64.dpatch b/debian/patches/fix_ARCH_ALIGN_INT64.dpatch
deleted file mode 100644
index c081957..0000000
--- a/debian/patches/fix_ARCH_ALIGN_INT64.dpatch
+++ /dev/null
@@ -1,57 +0,0 @@
-#! /bin/sh /usr/share/dpatch/dpatch-run
-## fix_ARCH_ALIGN_INT64.dpatch by Stephane Glondu <steph@glondu.net>
-##
-## All lines beginning with `## DP:' are a description of the patch.
-## DP: Fix C bindings on ARCH_ALIGN_INT64 architectures (hppa, sparc)
-
-@DPATCH@
---- a/bitstring_c.c
-+++ b/bitstring_c.c
-@@ -86,8 +86,6 @@ fastpath1(16,be,signed,int16_t)
- fastpath1(16,le,signed,int16_t)
- fastpath1(16,ne,signed,int16_t)
-
--/* XXX This probably doesn't work on ARCH_ALIGN_INT64 platforms. */
--
- #define fastpath2(size,endian,signed,type,rval) \
- CAMLprim value \
- ocaml_bitstring_extract_fastpath_int##size##_##endian##_##signed \
-@@ -108,9 +106,32 @@ fastpath2(32,be,signed,int32_t,Int32_val)
- fastpath2(32,le,signed,int32_t,Int32_val)
- fastpath2(32,ne,signed,int32_t,Int32_val)
-
--fastpath2(64,be,unsigned,uint64_t,Int64_val)
--fastpath2(64,le,unsigned,uint64_t,Int64_val)
--fastpath2(64,ne,unsigned,uint64_t,Int64_val)
--fastpath2(64,be,signed,int64_t,Int64_val)
--fastpath2(64,le,signed,int64_t,Int64_val)
--fastpath2(64,ne,signed,int64_t,Int64_val)
-+/* Special care needs to be taken on ARCH_ALIGN_INT64 platforms
-+ (hppa and sparc in Debian). */
-+
-+#ifdef ARCH_ALIGN_INT64
-+#include <caml/memory.h>
-+#include <caml/alloc.h>
-+#define fastpath3(size,endian,signed,type,rval) \
-+ CAMLprim value \
-+ ocaml_bitstring_extract_fastpath_int##size##_##endian##_##signed \
-+ (value strv, value offv, value rv) \
-+ { \
-+ CAMLparam3(strv, offv, rv); \
-+ type *ptr = (type *) ((void *) String_val (strv) + Int_val (offv)); \
-+ type r; \
-+ r = *ptr; \
-+ swap_##endian(size,r); \
-+ CAMLreturn(caml_copy_int64(r)); \
-+ }
-+
-+#else
-+#define fastpath3 fastpath2
-+#endif
-+
-+fastpath3(64,be,unsigned,uint64_t,Int64_val)
-+fastpath3(64,le,unsigned,uint64_t,Int64_val)
-+fastpath3(64,ne,unsigned,uint64_t,Int64_val)
-+fastpath3(64,be,signed,int64_t,Int64_val)
-+fastpath3(64,le,signed,int64_t,Int64_val)
-+fastpath3(64,ne,signed,int64_t,Int64_val)