summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephane Glondu <steph@glondu.net>2013-07-24 09:54:27 +0100
committerStephane Glondu <steph@glondu.net>2013-07-24 09:54:27 +0100
commit8e2e24dd45d6827a1f00a0d2e1cf28ef6f3b7f38 (patch)
tree3f9dca7ef61f5d0c25f25a644c0050971f858aee
parent33627732bf1daaea7c5c3db48db49169351a4250 (diff)
Refresh patches
-rw-r--r--debian/patches/0001-Fix-camlp4of.opt-detection-in-configure.patch51
-rw-r--r--debian/patches/0002-Allow-byte-only-compilation.patch10
-rw-r--r--debian/patches/0003-Fix-META-file-for-bitstring.syntax.patch17
-rw-r--r--debian/patches/0004-Fix-preprocessor-options-for-the-syntax-META-file.patch27
-rw-r--r--debian/patches/series1
5 files changed, 38 insertions, 68 deletions
diff --git a/debian/patches/0001-Fix-camlp4of.opt-detection-in-configure.patch b/debian/patches/0001-Fix-camlp4of.opt-detection-in-configure.patch
index d4afd4a..f6b0fc1 100644
--- a/debian/patches/0001-Fix-camlp4of.opt-detection-in-configure.patch
+++ b/debian/patches/0001-Fix-camlp4of.opt-detection-in-configure.patch
@@ -4,15 +4,15 @@ Subject: Fix camlp4of.opt detection in configure
Signed-off-by: Sylvain Le Gall <gildor@debian.org>
---
- configure | 50 ++++++++++++++++++++++++++++++++++++++++++++++----
+ configure | 48 +++++++++++++++++++++++++++++++++++++++++++++---
configure.ac | 6 +++++-
- 2 files changed, 51 insertions(+), 5 deletions(-)
+ 2 files changed, 50 insertions(+), 4 deletions(-)
diff --git a/configure b/configure
-index 7f5fa37..9587336 100755
+index ba77b55..9fc8be6 100755
--- a/configure
+++ b/configure
-@@ -643,6 +643,7 @@ DIFF
+@@ -627,6 +627,7 @@ DIFF
TIME
OCAML_PKG_cil
OCAML_PKG_extlib
@@ -20,35 +20,35 @@ index 7f5fa37..9587336 100755
CAMLP4OF
OCAMLFIND
OCAMLBUILD
-@@ -5295,8 +5296,8 @@ $as_echo "$as_me: error: You must have ocaml and findlib installed" >&2;}
- { (exit 1); exit 1; }; }
+@@ -4858,8 +4859,8 @@ if test "x$OCAMLFIND" = "x"; then
+ as_fn_error $? "You must have ocaml and findlib installed" "$LINENO" 5
fi
-# Extract the first word of "camlp4of.opt", so it can be a program name with args.
-set dummy camlp4of.opt; ac_word=$2
+# Extract the first word of "camlp4of", so it can be a program name with args.
+set dummy camlp4of; ac_word=$2
- { $as_echo "$as_me:$LINENO: checking for $ac_word" >&5
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
$as_echo_n "checking for $ac_word... " >&6; }
- if test "${ac_cv_prog_CAMLP4OF+set}" = set; then
-@@ -5312,7 +5313,7 @@ do
+ if ${ac_cv_prog_CAMLP4OF+:} false; then :
+@@ -4875,7 +4876,7 @@ do
test -z "$as_dir" && as_dir=.
- for ac_exec_ext in '' $ac_executable_extensions; do
- if { test -f "$as_dir/$ac_word$ac_exec_ext" && $as_test_x "$as_dir/$ac_word$ac_exec_ext"; }; then
+ for ac_exec_ext in '' $ac_executable_extensions; do
+ if as_fn_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
- ac_cv_prog_CAMLP4OF="camlp4of.opt"
+ ac_cv_prog_CAMLP4OF="camlp4of"
- $as_echo "$as_me:$LINENO: found $as_dir/$ac_word$ac_exec_ext" >&5
+ $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
break 2
fi
-@@ -5333,8 +5334,49 @@ $as_echo "no" >&6; }
+@@ -4896,6 +4897,47 @@ $as_echo "no" >&6; }
fi
+# Extract the first word of "camlp4of.opt", so it can be a program name with args.
+set dummy camlp4of.opt; ac_word=$2
-+{ $as_echo "$as_me:$LINENO: checking for $ac_word" >&5
++{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
+$as_echo_n "checking for $ac_word... " >&6; }
-+if test "${ac_cv_prog_CAMLP4OFOPT+set}" = set; then
++if ${ac_cv_prog_CAMLP4OFOPT+:} false; then :
+ $as_echo_n "(cached) " >&6
+else
+ if test -n "$CAMLP4OFOPT"; then
@@ -59,14 +59,14 @@ index 7f5fa37..9587336 100755
+do
+ IFS=$as_save_IFS
+ test -z "$as_dir" && as_dir=.
-+ for ac_exec_ext in '' $ac_executable_extensions; do
-+ if { test -f "$as_dir/$ac_word$ac_exec_ext" && $as_test_x "$as_dir/$ac_word$ac_exec_ext"; }; then
++ for ac_exec_ext in '' $ac_executable_extensions; do
++ if as_fn_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
+ ac_cv_prog_CAMLP4OFOPT="camlp4of.opt"
-+ $as_echo "$as_me:$LINENO: found $as_dir/$ac_word$ac_exec_ext" >&5
++ $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
+ break 2
+ fi
+done
-+done
++ done
+IFS=$as_save_IFS
+
+ test -z "$ac_cv_prog_CAMLP4OFOPT" && ac_cv_prog_CAMLP4OFOPT="no"
@@ -74,10 +74,10 @@ index 7f5fa37..9587336 100755
+fi
+CAMLP4OFOPT=$ac_cv_prog_CAMLP4OFOPT
+if test -n "$CAMLP4OFOPT"; then
-+ { $as_echo "$as_me:$LINENO: result: $CAMLP4OFOPT" >&5
++ { $as_echo "$as_me:${as_lineno-$LINENO}: result: $CAMLP4OFOPT" >&5
+$as_echo "$CAMLP4OFOPT" >&6; }
+else
-+ { $as_echo "$as_me:$LINENO: result: no" >&5
++ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
+$as_echo "no" >&6; }
+fi
+
@@ -86,16 +86,13 @@ index 7f5fa37..9587336 100755
+ CAMLP4OF=$CAMLP4OFOPT
+fi
if test "x$CAMLP4OF" = "xno"; then
-- { { $as_echo "$as_me:$LINENO: error: You must have camlp4 installed" >&5
-+ { { $as_echo "$as_me:$LINENO: error: You must have camlp4 installed" >&5
- $as_echo "$as_me: error: You must have camlp4 installed" >&2;}
- { (exit 1); exit 1; }; }
+ as_fn_error $? "You must have camlp4 installed" "$LINENO" 5
fi
diff --git a/configure.ac b/configure.ac
-index 174ed8c..c72bdb5 100644
+index d6e8720..b4fd6e2 100644
--- a/configure.ac
+++ b/configure.ac
-@@ -59,7 +59,11 @@ if test "x$OCAMLFIND" = "x"; then
+@@ -61,7 +61,11 @@ if test "x$OCAMLFIND" = "x"; then
fi
dnl Check for camlp4
diff --git a/debian/patches/0002-Allow-byte-only-compilation.patch b/debian/patches/0002-Allow-byte-only-compilation.patch
index 916d541..42a8069 100644
--- a/debian/patches/0002-Allow-byte-only-compilation.patch
+++ b/debian/patches/0002-Allow-byte-only-compilation.patch
@@ -5,13 +5,13 @@ Subject: Allow byte only compilation
Signed-off-by: Sylvain Le Gall <gildor@debian.org>
---
Makefile.in | 10 ++++++++--
- 1 files changed, 8 insertions(+), 2 deletions(-)
+ 1 file changed, 8 insertions(+), 2 deletions(-)
diff --git a/Makefile.in b/Makefile.in
-index d64750d..aebdaa7 100644
+index 3ce8783..30c8bfa 100644
--- a/Makefile.in
+++ b/Makefile.in
-@@ -33,6 +33,8 @@ BYTESWAP_H = @BYTESWAP_H@
+@@ -34,6 +34,8 @@ BYTESWAP_H = @BYTESWAP_H@
OCAMLLIB = @OCAMLLIB@
top_srcdir = @top_srcdir@
@@ -20,7 +20,7 @@ index d64750d..aebdaa7 100644
pkg_cil = @OCAML_PKG_cil@
pkg_extlib = @OCAML_PKG_extlib@
-@@ -77,11 +79,15 @@ BENCHMARKS = $(patsubst %.ml,%,$(wildcard benchmarks/*.ml))
+@@ -78,11 +80,15 @@ BENCHMARKS = $(patsubst %.ml,%,$(wildcard benchmarks/*.ml))
all: $(BYTESWAP_H) \
bitstring.cma bitstring_persistent.cma \
@@ -37,7 +37,7 @@ index d64750d..aebdaa7 100644
bitstring.cma: bitstring_types.cmo bitstring_config.cmo \
bitstring_c.o bitstring.cmo bitmatch.cmo
$(OCAMLMKLIB) -o bitstring $^
-@@ -268,7 +274,7 @@ endif
+@@ -271,7 +277,7 @@ endif
# Install.
install:
diff --git a/debian/patches/0003-Fix-META-file-for-bitstring.syntax.patch b/debian/patches/0003-Fix-META-file-for-bitstring.syntax.patch
index f4fe152..d938e95 100644
--- a/debian/patches/0003-Fix-META-file-for-bitstring.syntax.patch
+++ b/debian/patches/0003-Fix-META-file-for-bitstring.syntax.patch
@@ -5,22 +5,23 @@ Subject: Fix META file for bitstring.syntax
Bug-Debian: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=599552
Signed-off-by: Mehdi Dogguy <mehdi@debian.org>
---
- META.in | 5 +++--
- 1 files changed, 3 insertions(+), 2 deletions(-)
+ META.in | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/META.in b/META.in
-index 6e99669..699ba44 100644
+index 6b14f17..02560d5 100644
--- a/META.in
+++ b/META.in
-@@ -16,7 +16,8 @@ package "persistent" (
+@@ -15,8 +15,8 @@ package "persistent" (
+
package "syntax" (
version = "@PACKAGE_VERSION@"
+- requires = "camlp4"
++ requires = "camlp4 bitstring.persistent"
description = "Syntax extension: bitstring operators"
-- archive(syntax,preprocessor) = "unix.cma bitstring.cma bitstring_persistent.cma pa_bitstring.cmo"
+- archive(syntax,preprocessor) = "-parser o -parser op -printer p unix.cma bitstring.cma bitstring_persistent.cma pa_bitstring.cmo"
- archive(syntax,toploop) = "unix.cma bitstring.cma bitstring_persistent.cma pa_bitstring.cmo"
-+ requires = "bitstring.persistent"
-+ archive(syntax,preprocessor) = "pa_bitstring.cmo"
++ archive(syntax,preprocessor) = "-parser o -parser op -printer p pa_bitstring.cmo"
+ archive(syntax,toploop) = "pa_bitstring.cmo"
- preprocessor = "camlp4of"
)
--
diff --git a/debian/patches/0004-Fix-preprocessor-options-for-the-syntax-META-file.patch b/debian/patches/0004-Fix-preprocessor-options-for-the-syntax-META-file.patch
deleted file mode 100644
index 349e9d2..0000000
--- a/debian/patches/0004-Fix-preprocessor-options-for-the-syntax-META-file.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From: Nicolas Dandrimont <Nicolas.Dandrimont@crans.org>
-Date: Mon, 18 Apr 2011 16:17:36 +0200
-Subject: Fix preprocessor options for the syntax META file
-
-Origin: upstream, http://code.google.com/p/bitstring/source/detail?r=185
-Bug-Debian: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=623230
-Signed-off-by: Nicolas Dandrimont <Nicolas.Dandrimont@crans.org>
-Signed-off-by: Stephane Glondu <steph@glondu.net>
----
- META.in | 3 +--
- 1 files changed, 1 insertions(+), 2 deletions(-)
-
-diff --git a/META.in b/META.in
-index 699ba44..049bbb4 100644
---- a/META.in
-+++ b/META.in
-@@ -16,8 +16,7 @@ package "persistent" (
- package "syntax" (
- version = "@PACKAGE_VERSION@"
- description = "Syntax extension: bitstring operators"
-- requires = "bitstring.persistent"
-+ requires = "bitstring.persistent, camlp4"
- archive(syntax,preprocessor) = "pa_bitstring.cmo"
- archive(syntax,toploop) = "pa_bitstring.cmo"
-- preprocessor = "camlp4of"
- )
---
diff --git a/debian/patches/series b/debian/patches/series
index eae36fe..36d495b 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,4 +1,3 @@
0001-Fix-camlp4of.opt-detection-in-configure.patch
0002-Allow-byte-only-compilation.patch
0003-Fix-META-file-for-bitstring.syntax.patch
-0004-Fix-preprocessor-options-for-the-syntax-META-file.patch