summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CHANGES6
-rwxr-xr-xconfigure18
-rw-r--r--configure.ac2
-rw-r--r--src/Makefile.in2
-rw-r--r--src/duppy.ml11
-rw-r--r--src/duppy.mli10
6 files changed, 36 insertions, 13 deletions
diff --git a/CHANGES b/CHANGES
index fdbfea6..c1cdaa1 100644
--- a/CHANGES
+++ b/CHANGES
@@ -1,3 +1,9 @@
+0.1.1 (15-04-2008)
+=====
+* Fixed Conditions usage for non-unix systems
+* Fixed typos in the documentation, added some details
+* Installs .cmx file
+
0.1.0 (07-03-2008)
=====
* Initial release
diff --git a/configure b/configure
index b2c1196..a9ff415 100755
--- a/configure
+++ b/configure
@@ -1,6 +1,6 @@
#! /bin/sh
# Guess values for system-dependent variables and create Makefiles.
-# Generated by GNU Autoconf 2.61 for ocaml-duppy 0.1.0.
+# Generated by GNU Autoconf 2.61 for ocaml-duppy 0.1.1.
#
# Report bugs to <savonet-users@lists.sourceforge.net>.
#
@@ -574,8 +574,8 @@ SHELL=${CONFIG_SHELL-/bin/sh}
# Identity of this package.
PACKAGE_NAME='ocaml-duppy'
PACKAGE_TARNAME='ocaml-duppy'
-PACKAGE_VERSION='0.1.0'
-PACKAGE_STRING='ocaml-duppy 0.1.0'
+PACKAGE_VERSION='0.1.1'
+PACKAGE_STRING='ocaml-duppy 0.1.1'
PACKAGE_BUGREPORT='savonet-users@lists.sourceforge.net'
ac_subst_vars='SHELL
@@ -1155,7 +1155,7 @@ if test "$ac_init_help" = "long"; then
# Omit some internal or obsolete options to make the list less imposing.
# This message is too long to be a string in the A/UX 3.1 sh.
cat <<_ACEOF
-\`configure' configures ocaml-duppy 0.1.0 to adapt to many kinds of systems.
+\`configure' configures ocaml-duppy 0.1.1 to adapt to many kinds of systems.
Usage: $0 [OPTION]... [VAR=VALUE]...
@@ -1216,7 +1216,7 @@ fi
if test -n "$ac_init_help"; then
case $ac_init_help in
- short | recursive ) echo "Configuration of ocaml-duppy 0.1.0:";;
+ short | recursive ) echo "Configuration of ocaml-duppy 0.1.1:";;
esac
cat <<\_ACEOF
@@ -1299,7 +1299,7 @@ fi
test -n "$ac_init_help" && exit $ac_status
if $ac_init_version; then
cat <<\_ACEOF
-ocaml-duppy configure 0.1.0
+ocaml-duppy configure 0.1.1
generated by GNU Autoconf 2.61
Copyright (C) 1992, 1993, 1994, 1995, 1996, 1998, 1999, 2000, 2001,
@@ -1313,7 +1313,7 @@ cat >config.log <<_ACEOF
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.
-It was created by ocaml-duppy $as_me 0.1.0, which was
+It was created by ocaml-duppy $as_me 0.1.1, which was
generated by GNU Autoconf 2.61. Invocation command line was
$ $0 $@
@@ -3458,7 +3458,7 @@ exec 6>&1
# report actual input values of CONFIG_FILES etc. instead of their
# values after options handling.
ac_log="
-This file was extended by ocaml-duppy $as_me 0.1.0, which was
+This file was extended by ocaml-duppy $as_me 0.1.1, which was
generated by GNU Autoconf 2.61. Invocation command line was
CONFIG_FILES = $CONFIG_FILES
@@ -3501,7 +3501,7 @@ Report bugs to <bug-autoconf@gnu.org>."
_ACEOF
cat >>$CONFIG_STATUS <<_ACEOF
ac_cs_version="\\
-ocaml-duppy config.status 0.1.0
+ocaml-duppy config.status 0.1.1
configured by $0, generated by GNU Autoconf 2.61,
with options \\"`echo "$ac_configure_args" | sed 's/^ //; s/[\\""\`\$]/\\\\&/g'`\\"
diff --git a/configure.ac b/configure.ac
index eb6e5f2..f67a51a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,6 +1,6 @@
# check for one particular file of the sources
-AC_INIT(ocaml-duppy, 0.1.0, savonet-users@lists.sourceforge.net)
+AC_INIT(ocaml-duppy, 0.1.1, savonet-users@lists.sourceforge.net)
VERSION=$PACKAGE_VERSION
AC_SUBST(VERSION)
diff --git a/src/Makefile.in b/src/Makefile.in
index c527d0e..569ad62 100644
--- a/src/Makefile.in
+++ b/src/Makefile.in
@@ -26,7 +26,7 @@ OCAMLLIBPATH = @CAMLLIBPATH@
SOURCES = duppy.ml duppy.mli
RESULT = duppy
OCAMLDOCFLAGS = -stars
-LIBINSTALL_FILES = $(wildcard *.mli *.cmi *.cma *.cmxa *.a *.so)
+LIBINSTALL_FILES = $(wildcard *.mli *.cmi *.cma *.cmxa *.cmx *.a *.so)
ACLIBS = @LIBS@
LDFLAGS = @LDFLAGS@
CLIBS = $(ACLIBS:-l%=%)
diff --git a/src/duppy.ml b/src/duppy.ml
index bdf96d0..48c8420 100644
--- a/src/duppy.ml
+++ b/src/duppy.ml
@@ -238,8 +238,15 @@ let queue ?log ?(priorities=fun _ -> true) s name =
Mutex.unlock s.select_m ;
if s.ready <> [] then
List.iter Condition.signal s.queues
- end else
- Condition.wait c m
+ end else begin
+ (* We follow the spec on the mutex,
+ * otherwise we might get issues on bsd systems
+ * or any implementation that cares more about
+ * mutex locking/unlocking than linux/glibc.. *)
+ Mutex.lock m;
+ Condition.wait c m;
+ Mutex.unlock m
+ end
end
done
diff --git a/src/duppy.mli b/src/duppy.mli
index a778cd9..8b052e7 100644
--- a/src/duppy.mli
+++ b/src/duppy.mli
@@ -142,7 +142,17 @@ sig
* With {!Duppy.Io.write}, the schdeduler will try to write recursively to the file descriptor
* the given string.*)
+ (** Type for markers.
+ *
+ * [Split s] recognizes all regexp allowed by the
+ * [Pcre] module. *)
type marker = Length of int | Split of string
+
+ (** Different types of failure.
+ *
+ * [Int d] is raised when reading or writing failed.
+ * the returned value is respectively the ammount of
+ * data read or written *)
type failure = Int of int | Unix of Unix.error*string*string
(** Wrapper to perform a read on a socket and trigger a function when