summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael Laboissière <rafael@debian.org>2022-11-16 12:30:26 -0300
committerRafael Laboissière <rafael@debian.org>2022-11-16 12:30:26 -0300
commit397e934d6ed290416ca0dfc0cdc65c699a290991 (patch)
treefa7dcde37402c5bae76e124b7a66b2e3b231b780
parent07dd68617af67233ba10770a9ac7142ac2f4edc7 (diff)
parent554c50362ea7ce3f00ff0e4cbae16e002a8fc9b5 (diff)
Merge tag 'upstream/1.1.6' into debian/latest
Upstream version 1.1.6
-rw-r--r--.hgignore38
-rw-r--r--DESCRIPTION4
-rw-r--r--NEWS6
-rw-r--r--inst/bim2a_reaction.m2
-rw-r--r--inst/bim2a_rhs.m2
5 files changed, 48 insertions, 4 deletions
diff --git a/.hgignore b/.hgignore
new file mode 100644
index 0000000..4312b8a
--- /dev/null
+++ b/.hgignore
@@ -0,0 +1,38 @@
+syntax: regexp
+# The recurrent (^|/) idiom in the regexps below should be understood
+# to mean "at any directory" while the ^ idiom means "from the
+# project's top-level directory".
+
+(^|/).*\.dvi$
+(^|/).*\.pdf$
+(^|/).*\.o$
+(^|/).*\.oct$
+(^|/).*\.octlink$
+(^|/)octave-core$
+(^|/)octave-workspace$
+(^|/).*\.tar\.gz$
+
+## Our Makefile target
+^target/
+
+## Files generated automatically by autoconf and the configure script
+^src/aclocal\.m4$
+^src/configure$
+^src/autom4te\.cache($|/)
+^src/config\.log$
+^src/config\.status$
+^src/Makefile$
+^src/.*\.m$
+
+# e.g. doc/faq/OctaveFAQ.info
+# doc/interpreter/octave.info-4
+^doc/.*\.info(-\d)?$
+^doc/\w*/stamp-vti$
+^doc/\w*/version\.texi$
+
+# Emacs tools create these
+(^|/)TAGS$
+(^|/)semantic.cache$
+
+# Other text editors often create these
+(^|/)~.*
diff --git a/DESCRIPTION b/DESCRIPTION
index c6a7e5e..e8717ca 100644
--- a/DESCRIPTION
+++ b/DESCRIPTION
@@ -1,6 +1,6 @@
Name: bim
-Version: 1.1.5
-Date: 2014-10-17
+Version: 1.1.6
+Date: 2022-07-22
Author: Carlo de Falco, Culpo Massimiliano, Matteo Porro, Emanuela Abbate
Maintainer: Carlo de Falco
Title: PDE Solver using a Finite Element/Finite Volume approach
diff --git a/NEWS b/NEWS
index 47f8fa1..00188b0 100644
--- a/NEWS
+++ b/NEWS
@@ -1,3 +1,9 @@
+Summary of important user-visible changes for bim 1.1.6:
+-------------------------------------------------------------------
+
+ ** Avoid complex conjugate when changing array shape in
+ bim2a_reaction and bim2a_rhs.
+
Summary of important user-visible changes for bim 1.1.5:
-------------------------------------------------------------------
diff --git a/inst/bim2a_reaction.m b/inst/bim2a_reaction.m
index 99376f9..3e2c801 100644
--- a/inst/bim2a_reaction.m
+++ b/inst/bim2a_reaction.m
@@ -73,7 +73,7 @@ function [C] = bim2a_reaction(mesh,delta,zeta)
## Local matrix
Blocmat = zeros(3,nelem);
for inode = 1:3
- Blocmat(inode,:) = coeffe'.*coeff(inode,:).*wjacdet(inode,:);
+ Blocmat(inode,:) = coeffe.'.*coeff(inode,:).*wjacdet(inode,:);
endfor
gnode = (mesh.t(1:3,:));
diff --git a/inst/bim2a_rhs.m b/inst/bim2a_rhs.m
index 0e3a334..99b3e49 100644
--- a/inst/bim2a_rhs.m
+++ b/inst/bim2a_rhs.m
@@ -72,7 +72,7 @@ function b = bim2a_rhs(mesh,f,g)
## Build local matrix
Blocmat=zeros(3,nelem);
for inode=1:3
- Blocmat(inode,:) = f'.*g(inode,:).*wjacdet(inode,:);
+ Blocmat(inode,:) = f.' .* g(inode,:) .* wjacdet(inode,:);
endfor
gnode=(mesh.t(1:3,:));