summaryrefslogtreecommitdiff
path: root/src/apps/ociocheck/CMakeLists.txt
diff options
context:
space:
mode:
authorMatteo F. Vescovi <mfv.debian@gmail.com>2013-08-20 09:53:19 +0100
committerMatteo F. Vescovi <mfv.debian@gmail.com>2013-08-20 09:53:19 +0100
commit66e5d9e2915733247bca47d077414ec2594aedad (patch)
treef4070a31bf015e159dadd34378cda703d8f6edea /src/apps/ociocheck/CMakeLists.txt
opencolorio (1.0.8~dfsg0-2) unstable; urgency=low
* debian/rules: get-orig-source stuff added * debian/rules: useless dh addon removed * debian/rules: License.txt duplicate removed * debian/rules: SSE optimization disabled (Closes: #719174) * debian/libopencolorio1.symbols: file removed (Closes: #719175) # imported from the archive
Diffstat (limited to 'src/apps/ociocheck/CMakeLists.txt')
-rw-r--r--src/apps/ociocheck/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/src/apps/ociocheck/CMakeLists.txt b/src/apps/ociocheck/CMakeLists.txt
new file mode 100644
index 0000000..f8902e4
--- /dev/null
+++ b/src/apps/ociocheck/CMakeLists.txt
@@ -0,0 +1,17 @@
+file(GLOB_RECURSE share_src_files "${CMAKE_SOURCE_DIR}/src/apps/share/*.cpp")
+
+include_directories(
+ ${CMAKE_SOURCE_DIR}/export/
+ ${CMAKE_BINARY_DIR}/export/
+ ${CMAKE_SOURCE_DIR}/src/apps/share/
+ )
+
+add_executable(ociocheck
+ main.cpp
+ ${share_src_files})
+
+target_link_libraries(ociocheck
+ OpenColorIO
+ )
+
+install(TARGETS ociocheck DESTINATION ${CMAKE_INSTALL_EXEC_PREFIX}/bin)