summaryrefslogtreecommitdiff
path: root/src/pyglue/DocStrings/ExponentTransform.py
diff options
context:
space:
mode:
authorMatteo F. Vescovi <mfv.debian@gmail.com>2013-08-20 09:53:19 +0100
committerMatteo F. Vescovi <mfv.debian@gmail.com>2013-08-20 09:53:19 +0100
commit66e5d9e2915733247bca47d077414ec2594aedad (patch)
treef4070a31bf015e159dadd34378cda703d8f6edea /src/pyglue/DocStrings/ExponentTransform.py
opencolorio (1.0.8~dfsg0-2) unstable; urgency=low
* debian/rules: get-orig-source stuff added * debian/rules: useless dh addon removed * debian/rules: License.txt duplicate removed * debian/rules: SSE optimization disabled (Closes: #719174) * debian/libopencolorio1.symbols: file removed (Closes: #719175) # imported from the archive
Diffstat (limited to 'src/pyglue/DocStrings/ExponentTransform.py')
-rw-r--r--src/pyglue/DocStrings/ExponentTransform.py31
1 files changed, 31 insertions, 0 deletions
diff --git a/src/pyglue/DocStrings/ExponentTransform.py b/src/pyglue/DocStrings/ExponentTransform.py
new file mode 100644
index 0000000..930bb39
--- /dev/null
+++ b/src/pyglue/DocStrings/ExponentTransform.py
@@ -0,0 +1,31 @@
+
+class ExponentTransform:
+ """
+ ExponentTransform
+ """
+ def __init__(self):
+ pass
+
+ def getValue(self):
+ """
+ getValue()
+
+ Returns the values in the exponent transform of
+ :py:class:`PyOpenColorIO.ExponentTransform`.
+
+ :return: exponent transform values
+ :rtype: list of floats
+ """
+ pass
+
+ def setValue(self, value):
+ """
+ setValue()
+
+ Sets the values in the exponent transform of
+ :py:class:`PyOpenColorIO.ExponentTransform`.
+
+ :param pyData: exponent transform values
+ :type pyData: list of 4 floats
+ """
+ pass