summaryrefslogtreecommitdiff
path: root/src/apps/ociodisplay/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/apps/ociodisplay/CMakeLists.txt')
-rw-r--r--src/apps/ociodisplay/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/src/apps/ociodisplay/CMakeLists.txt b/src/apps/ociodisplay/CMakeLists.txt
new file mode 100644
index 0000000..e80e9f9
--- /dev/null
+++ b/src/apps/ociodisplay/CMakeLists.txt
@@ -0,0 +1,11 @@
+include_directories(
+ ${CMAKE_SOURCE_DIR}/export/
+ ${CMAKE_BINARY_DIR}/export/
+ ${OPENGL_INCLUDE_DIR}
+ ${OIIO_INCLUDES}
+ ${GLEW_INCLUDES}
+)
+add_executable(ociodisplay main.cpp)
+# set_target_properties(ociodisplay PROPERTIES INSTALL_RPATH ${OIIO_LIBRARIES} )
+target_link_libraries(ociodisplay ${GLEW_LIBRARIES} ${GLUT_LIBRARY} ${OPENGL_LIBRARY} ${OIIO_LIBRARIES} OpenColorIO)
+install(TARGETS ociodisplay DESTINATION ${CMAKE_INSTALL_EXEC_PREFIX}/bin)