summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDimitri John Ledkov <xnox@ubuntu.com>2016-02-08 05:16:53 +0000
committerDimitri John Ledkov <xnox@ubuntu.com>2016-02-08 05:16:53 +0000
commitfde23a5a27b3d829d32c07ba79d56a0e6a22862a (patch)
treeeb6505acc1540e616b421e5e26a67c05c4d279b0
parent84c1e0218046f961df721ba0bb5ae5c96217b488 (diff)
Enable systemd units.
* Enable systemd units. * Drop pkcs11_startup call and opencryptoki provides from the init script, adjust PIDFILE location to /var/run/pkcsslotd.pid
-rw-r--r--debian/changelog3
-rw-r--r--debian/control3
-rw-r--r--debian/opencryptoki.init5
-rwxr-xr-xdebian/rules6
4 files changed, 10 insertions, 7 deletions
diff --git a/debian/changelog b/debian/changelog
index 1abcd59..c126e48 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -13,6 +13,9 @@ opencryptoki (3.4.1+dfsg-1ubuntu1) UNRELEASED; urgency=medium
- 07-add-manpage-for-pkcs_slot.patch
- 0009-Fix-wrong-LIB_PATH.patch
- 0010-Remove-one-hardcoded-lib64-path.patch
+ * Enable systemd units.
+ * Drop pkcs11_startup call and opencryptoki provides from the init
+ script, adjust PIDFILE location to /var/run/pkcsslotd.pid
-- Dimitri John Ledkov <xnox@ubuntu.com> Mon, 08 Feb 2016 05:00:09 +0000
diff --git a/debian/control b/debian/control
index b4ca27b..43e8668 100644
--- a/debian/control
+++ b/debian/control
@@ -7,7 +7,8 @@ Build-Depends: autoconf,
autotools-dev,
debhelper (>= 7.0.50~),
libtool,
- libtspi-dev
+ libtspi-dev,
+ dh-systemd
Standards-Version: 3.9.2
Homepage: http://opencryptoki.sourceforge.net/
diff --git a/debian/opencryptoki.init b/debian/opencryptoki.init
index fa83b97..5488067 100644
--- a/debian/opencryptoki.init
+++ b/debian/opencryptoki.init
@@ -1,7 +1,7 @@
#!/bin/sh
### BEGIN INIT INFO
-# Provides: pkcsslotd opencryptoki
+# Provides: pkcsslotd
# Required-Start: $local_fs $remote_fs
# Required-Stop: $local_fs $remote_fs
# Should-Start:
@@ -16,7 +16,7 @@ PATH=/sbin:/bin:/usr/sbin:/usr/bin
DAEMON=/usr/sbin/pkcsslotd
NAME=pkcsslotd
DESC="PKCS#11 slot daemon"
-PIDFILE=/var/lib/opencryptoki/.slotpid
+PIDFILE=/var/run/pkcsslotd.pid
test -x "$DAEMON" || exit 0
@@ -25,7 +25,6 @@ set -e
case "${1}" in
start)
echo -n "Starting $DESC: "
- /usr/sbin/pkcs11_startup
start-stop-daemon --start --quiet --pidfile "$PIDFILE" --exec "$DAEMON" -- $DAEMON_OPTS
echo "$NAME."
diff --git a/debian/rules b/debian/rules
index 8aafe99..abfd56a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,7 +3,7 @@
SHELL := sh -e
%:
- dh ${@} --with autotools_dev
+ dh ${@} --with autotools_dev,systemd
override_dh_auto_clean:
dh_auto_clean
@@ -11,7 +11,7 @@ override_dh_auto_clean:
override_dh_auto_configure:
./bootstrap.sh
- dh_auto_configure -- --enable-tpmtok
+ dh_auto_configure -- --enable-tpmtok --with-systemd=/lib/systemd/system
override_dh_auto_install:
dh_auto_install
@@ -23,7 +23,7 @@ override_dh_auto_install:
ln -s $$FILE ; \
done \
)
-
+
# Remove broken symlinks in /usr/lib/pkcs11/
cd debian/tmp/usr/lib/pkcs11 && rm -f \
libopencryptoki.so PKCS11_API.so