summaryrefslogtreecommitdiff
path: root/rpm
diff options
context:
space:
mode:
authorGuido Trotter <ultrotter@debian.org>2011-09-10 09:20:39 +0100
committerGuido Trotter <ultrotter@debian.org>2011-09-10 09:20:39 +0100
commit84e0d7d3e77d7f757be6f58198957d3c9ed0e688 (patch)
treee7d833da14479bf0ecc69f4e771c208289818a15 /rpm
opencryptoki (2.3.1+dfsg-3) unstable; urgency=low
* QA upload. * Fix pkcs11_startup module paths (Closes: #641080) # imported from the archive
Diffstat (limited to 'rpm')
-rw-r--r--rpm/opencryptoki-libs.spec80
-rw-r--r--rpm/opencryptoki-tpmtok.spec58
-rw-r--r--rpm/opencryptoki.spec121
3 files changed, 259 insertions, 0 deletions
diff --git a/rpm/opencryptoki-libs.spec b/rpm/opencryptoki-libs.spec
new file mode 100644
index 0000000..320746b
--- /dev/null
+++ b/rpm/opencryptoki-libs.spec
@@ -0,0 +1,80 @@
+%define base opencryptoki
+
+Name: opencryptoki-libs
+Version: 2.2.4
+Release: 1%{?dist}
+Summary: An Implementation of PKCS#11 (Cryptoki) v2.11
+
+Group: Applications/Productivity
+License: CPL
+URL: http://sourceforge.net/projects/opencryptoki
+Source0: %{base}-%{version}.tar.bz2
+BuildRoot: %{_tmppath}/%{base}-%{version}-%{release}-root-%(%{__id_u} -n)
+
+BuildRequires: autoconf automake libtool openssl-devel
+#Requires:
+
+%description
+The openCryptoki package implements the PKCS#11 version 2.11: Cryptographic
+Token Interface Standard (Cryptoki).
+
+
+%prep
+%setup -q -n %{base}-%{version}
+
+
+%build
+autoreconf --force --install
+%configure --disable-static --disable-daemon
+make %{?_smp_mflags}
+
+
+%install
+rm -rf $RPM_BUILD_ROOT
+make install DESTDIR=$RPM_BUILD_ROOT
+rm -f $RPM_BUILD_ROOT/%{_libdir}/%{base}/*.la
+rm -f $RPM_BUILD_ROOT/%{_libdir}/%{base}/stdll/*.la
+
+
+%postun -p /sbin/ldconfig
+
+
+%post -p /sbin/ldconfig
+
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+
+%files
+%defattr(-,root,root,-)
+%doc LICENSE
+%config(noreplace) %{_sysconfdir}/ld.so.conf.d/%{base}*.conf
+%dir %{_libdir}/%{base}
+%dir %{_libdir}/%{base}/stdll
+%{_libdir}/%{base}/libopencryptoki.so
+%{_libdir}/%{base}/libopencryptoki.so.0
+%attr(755,root,root) %{_libdir}/%{base}/libopencryptoki.so.0.0.0
+%{_libdir}/%{base}/methods
+%{_libdir}/%{base}/stdll/libpkcs11_*.so
+%{_libdir}/%{base}/stdll/libpkcs11_*.so.0
+%attr(755,root,root) %{_libdir}/%{base}/stdll/libpkcs11_*.so.0.0.0
+# symlinks for backward compatibility
+%dir %{_libdir}/pkcs11
+%dir %{_libdir}/pkcs11/stdll
+%dir %{_libdir}/pkcs11/methods
+%{_libdir}/pkcs11/PKCS11_API.so
+%{_libdir}/%{base}/PKCS11_API.so
+%{_libdir}/pkcs11/libopencryptoki.so
+%ifarch s390 s390x
+%{_libdir}/%{base}/stdll/PKCS11_ICA.so
+%else
+%{_libdir}/%{base}/stdll/PKCS11_SW.so
+%endif
+
+
+
+%changelog
+* Thu Aug 7 2006 Daniel H Jones <danjones@us.ibm.com>
+- initial file created
+
diff --git a/rpm/opencryptoki-tpmtok.spec b/rpm/opencryptoki-tpmtok.spec
new file mode 100644
index 0000000..b5ae3e6
--- /dev/null
+++ b/rpm/opencryptoki-tpmtok.spec
@@ -0,0 +1,58 @@
+%define token tpm
+%define base opencryptoki
+
+Name: opencryptoki-%{token}tok
+Version: 2.2.4
+Release: 1%{?dist}
+Summary: An opencryptoki %{token} token
+
+Group: Applications/Productivity
+License: CPL
+URL: http://sourceforge.net/projects/opencryptoki
+Source0: %{base}-%{version}.tar.bz2
+BuildRoot: %{_tmppath}/%{base}-%{version}-%{release}-root-%(%{__id_u} -n)
+
+BuildRequires: autoconf automake libtool
+Requires: opencryptoki = %{version}-%{release}
+
+
+%description
+The opencryptoki-tpmtok package provides an opencryptoki token for the
+Trusted Computing Platform (TPM) cryptographic device.
+
+
+%prep
+%setup -q -n %{base}-%{version}
+
+
+%build
+autoreconf --force --install
+%configure --disable-static --disable-daemon --disable-swtok --disable-library --enable-%{token}tok
+make %{?_smp_mflags}
+
+
+%install
+rm -rf $RPM_BUILD_ROOT
+make install DESTDIR=$RPM_BUILD_ROOT
+rm -f $RPM_BUILD_ROOT/%{_libdir}/%{base}/*.la
+rm -f $RPM_BUILD_ROOT/%{_libdir}/%{base}/stdll/*.la
+
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+
+%files
+%defattr(-,root,root,-)
+%doc LICENSE
+%dir %{_libdir}/%{base}
+%dir %{_libdir}/%{base}/stdll
+%{_libdir}/%{base}/stdll/libpkcs11_%{token}.so
+%{_libdir}/%{base}/stdll/libpkcs11_%{token}.so.0
+%attr(755,root,root) %{_libdir}/%{base}/stdll/libpkcs11_%{token}.so.0.0.0
+
+
+%changelog
+* Tue Aug 7 2006 Daniel H Jones <danjones@us.ibm.com>
+- initial file created
+
diff --git a/rpm/opencryptoki.spec b/rpm/opencryptoki.spec
new file mode 100644
index 0000000..958871d
--- /dev/null
+++ b/rpm/opencryptoki.spec
@@ -0,0 +1,121 @@
+Name: opencryptoki
+Version: 2.2.4
+Release: 1%{?dist}
+Summary: An Implementation of PKCS#11 (Cryptoki) v2.11
+
+Group: Applications/Productivity
+License: CPL
+URL: http://sourceforge.net/projects/opencryptoki
+Source0: %{name}-%{version}.tar.bz2
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+
+BuildRequires: autoconf automake libtool openssl-devel
+Requires: /sbin/chkconfig
+
+%description
+The openCryptoki package implements the PKCS#11 version 2.11: Cryptographic
+Token Interface Standard (Cryptoki).
+
+
+%package devel
+Summary: An Implementation of PKCS#11 (Cryptoki) v2.11
+Group: Applications/Productivity
+Requires: opencryptoki = %{version}-%{release}, glibc-devel
+
+%description devel
+The openCryptoki package implements the PKCS#11 version 2.11: Cryptographic
+Token Interface Standard (Cryptoki).
+
+
+%prep
+%setup -q -n %{name}-%{version}
+
+
+%build
+autoreconf --force --install
+%configure --disable-static
+make %{?_smp_mflags}
+
+
+%install
+rm -rf $RPM_BUILD_ROOT
+make install DESTDIR=$RPM_BUILD_ROOT
+rm -f $RPM_BUILD_ROOT/%{_libdir}/%{name}/*.la
+rm -f $RPM_BUILD_ROOT/%{_libdir}/%{name}/stdll/*.la
+
+
+%preun
+if [ "$1" = "0" ]; then
+ /sbin/service pkcsslotd stop /dev/null 2>&1
+ /sbin/chkconfig --del pkcsslotd
+fi
+
+%postun -p /sbin/ldconfig
+
+%post
+/sbin/chkconfig --add pkcsslotd
+/sbin/ldconfig
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%pre
+/usr/sbin/groupadd -r pkcs11 2>/dev/null || true
+/usr/sbin/usermod -G $(/usr/bin/id --groups --name root | /bin/sed -e '
+# add the pkcs group if it is missing
+/(^| )pkcs11( |$)/!s/$/ pkcs11/
+# replace spaces by commas
+y/ /,/
+'),pkcs11 root
+
+%files
+%defattr(-,root,root,-)
+%doc FAQ LICENSE README doc/*
+%config(noreplace) %{_sysconfdir}/ld.so.conf.d/%{name}*.conf
+%dir %attr(770,root,pkcs11) /var/lib/%{name}
+%attr(755,root,root) %{_sbindir}/pkcsslotd
+%attr(755,root,root) %{_sbindir}/pkcsconf
+%attr(755,root,root) %{_sbindir}/pkcs_slot
+%attr(755,root,root) %{_sbindir}/pkcs11_startup
+%dir %{_libdir}/%{name}
+%dir %{_libdir}/%{name}/stdll
+%{_libdir}/%{name}/libopencryptoki.so
+%{_libdir}/%{name}/libopencryptoki.so.0
+%attr(755,root,root) %{_libdir}/%{name}/libopencryptoki.so.0.0.0
+%{_libdir}/%{name}/methods
+%{_libdir}/%{name}/stdll/libpkcs11_*.so
+%{_libdir}/%{name}/stdll/libpkcs11_*.so.0
+%attr(755,root,root) %{_libdir}/%{name}/stdll/libpkcs11_*.so.0.0.0
+%attr(755,root,root) %{_sysconfdir}/init.d/pkcsslotd
+# symlinks for backward compatibility
+%dir %{_libdir}/pkcs11
+%dir %{_libdir}/pkcs11/stdll
+%dir %{_libdir}/pkcs11/methods
+%{_libdir}/pkcs11/PKCS11_API.so
+%{_libdir}/%{name}/PKCS11_API.so
+%{_libdir}/pkcs11/libopencryptoki.so
+%ifarch s390 s390x
+%{_libdir}/%{name}/stdll/PKCS11_ICA.so
+%else
+%{_libdir}/%{name}/stdll/PKCS11_SW.so
+%endif
+
+
+%files devel
+%defattr(-,root,root,-)
+%doc LICENSE
+%dir %{_includedir}/%{name}
+%{_includedir}/%{name}/apiclient.h
+%{_includedir}/%{name}/pkcs11.h
+%{_includedir}/%{name}/pkcs11types.h
+
+%changelog
+* Thu Aug 7 2006 Daniel H Jones <danjones@us.ibm.com>
+- spec file cleanup
+* Tue Aug 1 2006 Daniel H Jones <danjones@us.ibm.com>
+- sw token not created for s390
+* Tue Jul 25 2006 Daniel H Jones <danjones@us.ibm.com>
+- fixed post section and /var/lib/opencryptoki perms
+* Thu May 25 2006 Daniel H Jones <danjones@us.ibm.com> 2.2.4-1
+- initial file created
+