summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRuben Undheim <ruben.undheim@gmail.com>2019-02-10 09:14:12 +0000
committerRuben Undheim <ruben.undheim@gmail.com>2019-02-10 09:14:12 +0000
commit740524dde07582667abad7e1ce784354f21d62b6 (patch)
treeb17810be1d11d7e64fb79e754471886d19530c5d
parent1a2dcfd57546fec6502adbf1517f33760a0f4ce6 (diff)
Rebase patches
-rw-r--r--debian/patches/0002-Spelling-fixes.patch8
-rw-r--r--debian/patches/0003-More-things-to-fix-build.patch4
-rw-r--r--debian/patches/0004-link-more.patch8
3 files changed, 10 insertions, 10 deletions
diff --git a/debian/patches/0002-Spelling-fixes.patch b/debian/patches/0002-Spelling-fixes.patch
index 28240d6..7604059 100644
--- a/debian/patches/0002-Spelling-fixes.patch
+++ b/debian/patches/0002-Spelling-fixes.patch
@@ -20,7 +20,7 @@ Subject: Spelling fixes
14 files changed, 36 insertions(+), 36 deletions(-)
diff --git a/CSXCAD/src/CSPrimPolyhedron.cpp b/CSXCAD/src/CSPrimPolyhedron.cpp
-index 7eac505..9583b7e 100644
+index 2454f28..129d238 100644
--- a/CSXCAD/src/CSPrimPolyhedron.cpp
+++ b/CSXCAD/src/CSPrimPolyhedron.cpp
@@ -183,11 +183,11 @@ bool CSPrimPolyhedron::BuildTree()
@@ -51,7 +51,7 @@ index ed224fd..c88c67e 100644
}
return CSPrimitives::Write2XML(elem,parameterised);
diff --git a/CSXCAD/src/CSRectGrid.cpp b/CSXCAD/src/CSRectGrid.cpp
-index 50f2947..5b36dc2 100644
+index 4f90bfe..3a8dcf7 100644
--- a/CSXCAD/src/CSRectGrid.cpp
+++ b/CSXCAD/src/CSRectGrid.cpp
@@ -78,7 +78,7 @@ std::string CSRectGrid::AddDiscLines(int direct, int numLines, double* vals, std
@@ -126,10 +126,10 @@ index 4cd4a74..b9ef094 100644
break;
}
diff --git a/QCSXCAD/QVTKStructure.cpp b/QCSXCAD/QVTKStructure.cpp
-index 9482dde..8eea1e8 100644
+index 7394bd9..3239dea 100644
--- a/QCSXCAD/QVTKStructure.cpp
+++ b/QCSXCAD/QVTKStructure.cpp
-@@ -295,7 +295,7 @@ void QVTKStructure::RenderGridDir(int dir, unsigned int plane_pos)
+@@ -306,7 +306,7 @@ void QVTKStructure::RenderGridDir(int dir, unsigned int plane_pos)
uiQty[n]=CSGrid->GetQtyLines(n);
if ((int)plane_pos>=uiQty[dir])
{
diff --git a/debian/patches/0003-More-things-to-fix-build.patch b/debian/patches/0003-More-things-to-fix-build.patch
index 2e574c1..cb407be 100644
--- a/debian/patches/0003-More-things-to-fix-build.patch
+++ b/debian/patches/0003-More-things-to-fix-build.patch
@@ -8,10 +8,10 @@ Subject: More things to fix build
2 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/CSXCAD/CMakeLists.txt b/CSXCAD/CMakeLists.txt
-index 9d516d5..d7670c1 100644
+index a2b0448..840f17d 100644
--- a/CSXCAD/CMakeLists.txt
+++ b/CSXCAD/CMakeLists.txt
-@@ -90,9 +90,9 @@ INCLUDE_DIRECTORIES( ${fparser_INCLUDE_DIR} )
+@@ -92,9 +92,9 @@ INCLUDE_DIRECTORIES( ${fparser_INCLUDE_DIR} )
find_package(TinyXML REQUIRED)
ADD_DEFINITIONS( -DTIXML_USE_STL )
diff --git a/debian/patches/0004-link-more.patch b/debian/patches/0004-link-more.patch
index 6de8561..8035abf 100644
--- a/debian/patches/0004-link-more.patch
+++ b/debian/patches/0004-link-more.patch
@@ -8,13 +8,13 @@ Subject: link more
2 files changed, 2 insertions(+)
diff --git a/AppCSXCAD/CMakeLists.txt b/AppCSXCAD/CMakeLists.txt
-index d5a72c9..2d4b11b 100644
+index 3e235d1..09bba11 100644
--- a/AppCSXCAD/CMakeLists.txt
+++ b/AppCSXCAD/CMakeLists.txt
-@@ -157,6 +157,7 @@ TARGET_LINK_LIBRARIES( AppCSXCAD
+@@ -140,6 +140,7 @@ TARGET_LINK_LIBRARIES( AppCSXCAD
${HDF5_HL_LIBRARIES}
- ${QT_LIBRARIES}
- ${vtk_LIBS}
+ Qt5::Core Qt5::Widgets Qt5::Xml
+ ${VTK_LIBRARIES}
+ hdf5_serial_hl
)