summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRuben Undheim <ruben.undheim@gmail.com>2018-11-27 19:20:17 +0100
committerRuben Undheim <ruben.undheim@gmail.com>2018-11-27 19:20:17 +0100
commit2de53612db4f7c358995cdb14a353624a1f1a958 (patch)
tree324bac09033b038126697d757816b6f17dcea811
parentbc866bcf4bddadd7b1257969548886da579ca3e1 (diff)
Multi-Arch: same. Fix test such that it ignores two specific messages on stderr related to no X11
-rw-r--r--debian/control1
-rwxr-xr-xdebian/tests/octave-load6
2 files changed, 4 insertions, 3 deletions
diff --git a/debian/control b/debian/control
index b63d891..f3ceb6e 100644
--- a/debian/control
+++ b/debian/control
@@ -115,6 +115,7 @@ Description: Development files for openems
Package: octave-openems
Architecture: any
+Multi-Arch: same
Depends: ${shlibs:Depends},
${misc:Depends},
openems,
diff --git a/debian/tests/octave-load b/debian/tests/octave-load
index 637edef..89933be 100755
--- a/debian/tests/octave-load
+++ b/debian/tests/octave-load
@@ -1,10 +1,10 @@
-#!/bin/sh
+#!/bin/bash
set -e
-octave --eval "pkg load openems"
+octave -W --eval "pkg load openems" 2>&1 >/dev/stdout | grep -v X11 || true | grep -v "disabling GUI" || true ; test ${PIPESTATUS[0]} -eq 0
echo "Successfully loaded openems"
-octave --eval "pkg load csxcad"
+octave -W --eval "pkg load csxcad" 2>&1 >/dev/stdout | grep -v X11 || true | grep -v "disabling GUI" || true ; test ${PIPESTATUS[0]} -eq 0
echo "Successfully loaded csxcad"
echo "done"