summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorRuben Undheim <ruben.undheim@gmail.com>2018-07-27 09:02:37 +0000
committerRuben Undheim <ruben.undheim@gmail.com>2018-07-27 09:02:37 +0000
commit2c0e93ea411db64a4b4a899bd523137d6818de79 (patch)
treeb08d9baf058b924d4a38ac8dd871a4febe3855dd /debian
parent70ff4f45d5843b15869dc69f4076783c6dcb5353 (diff)
Replace version from debian/rules
Diffstat (limited to 'debian')
-rw-r--r--debian/control4
-rwxr-xr-xdebian/rules11
2 files changed, 9 insertions, 6 deletions
diff --git a/debian/control b/debian/control
index d7f449c..9869b69 100644
--- a/debian/control
+++ b/debian/control
@@ -97,7 +97,7 @@ Package: libfparser-dev
Architecture: any
Section: libdevel
Depends: ${misc:Depends},
- libfparser4
+ libfparser4 (= ${fparser-version-full})
Multi-Arch: same
Description: Function Parser for C++ - development files
This C++ library offers a class which can be used to parse and evaluate a
@@ -134,7 +134,7 @@ Depends: ${misc:Depends},
libcsxcad0 (= ${binary:Version}),
libqcsxcad0 (= ${binary:Version}),
libnf2ff0 (= ${binary:Version}),
- libfparser-dev
+ libfparser-dev (= ${fparser-version-full})
Multi-Arch: same
Description: Development files for openems
This package contains the development files for all
diff --git a/debian/rules b/debian/rules
index f463078..349417b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -21,6 +21,10 @@ OCTAVE_HOSTTYPE = $(shell octave-config -p CANONICAL_HOST_TYPE)
OCTAVE_API_VERSION = $(shell octave-config -p API_VERSION)
OCTAVE_FULLBPATH = $(OCTAVE_BPATH)/openEMS-0.0.34/$(OCTAVE_HOSTTYPE)-$(OCTAVE_API_VERSION)
+FPARSER_VERSION=4.5.1
+FPARSER_VERSION_FULL = $(FPARSER_VERSION)-$(DEBIAN_VERSION_SUFFIX)
+SUBSTVARS = -Vfparser-version-full="$(FPARSER_VERSION_FULL)"
+
%:
dh $@
@@ -50,12 +54,11 @@ override_dh_installman:
dh_installman
override_dh_gencontrol:
- dh_gencontrol
- dh_gencontrol -plibfparser4 -- -v4.5.1-$(DEBIAN_VERSION_SUFFIX)
- dh_gencontrol -plibfparser-dev -- -v4.5.1-$(DEBIAN_VERSION_SUFFIX)
+ dh_gencontrol -- $(SUBSTVARS)
+ dh_gencontrol -plibfparser4 -- -v$(FPARSER_VERSION_FULL) $(SUBSTVARS)
+ dh_gencontrol -plibfparser-dev -- -v$(FPARSER_VERSION_FULL) $(SUBSTVARS)
get-orig-source: $(info I: $(PKG)_$(VER))
@echo "# Downloading..."
uscan --noconf --verbose --rename --destdir=$(CURDIR) --force-download --download-version $(VER) $(PKD)
-