summaryrefslogtreecommitdiff
path: root/CSXCAD/python/doc
diff options
context:
space:
mode:
Diffstat (limited to 'CSXCAD/python/doc')
-rw-r--r--CSXCAD/python/doc/CSPrimitives.rst26
-rw-r--r--CSXCAD/python/doc/CSPrimitives/CSPrimBox.rst7
-rw-r--r--CSXCAD/python/doc/CSPrimitives/CSPrimCurve.rst7
-rw-r--r--CSXCAD/python/doc/CSPrimitives/CSPrimCylinder.rst7
-rw-r--r--CSXCAD/python/doc/CSPrimitives/CSPrimCylindricalShell.rst7
-rw-r--r--CSXCAD/python/doc/CSPrimitives/CSPrimLinPoly.rst8
-rw-r--r--CSXCAD/python/doc/CSPrimitives/CSPrimPoint.rst7
-rw-r--r--CSXCAD/python/doc/CSPrimitives/CSPrimPolygon.rst8
-rw-r--r--CSXCAD/python/doc/CSPrimitives/CSPrimPolyhedron.rst8
-rw-r--r--CSXCAD/python/doc/CSPrimitives/CSPrimPolyhedronReader.rst8
-rw-r--r--CSXCAD/python/doc/CSPrimitives/CSPrimRotPoly.rst8
-rw-r--r--CSXCAD/python/doc/CSPrimitives/CSPrimSphere.rst7
-rw-r--r--CSXCAD/python/doc/CSPrimitives/CSPrimSphericalShell.rst7
-rw-r--r--CSXCAD/python/doc/CSPrimitives/CSPrimWire.rst8
-rw-r--r--CSXCAD/python/doc/CSPrimitives/CSPrimitives.rst7
-rw-r--r--CSXCAD/python/doc/CSProperties.rst19
-rw-r--r--CSXCAD/python/doc/CSProperties/CSPropConductingSheet.rst7
-rw-r--r--CSXCAD/python/doc/CSProperties/CSPropDumpBox.rst7
-rw-r--r--CSXCAD/python/doc/CSProperties/CSPropExcitation.rst7
-rw-r--r--CSXCAD/python/doc/CSProperties/CSPropLumpedElement.rst7
-rw-r--r--CSXCAD/python/doc/CSProperties/CSPropMaterial.rst7
-rw-r--r--CSXCAD/python/doc/CSProperties/CSPropMetal.rst7
-rw-r--r--CSXCAD/python/doc/CSProperties/CSPropProbeBox.rst7
-rw-r--r--CSXCAD/python/doc/CSProperties/CSProperties.rst7
-rw-r--r--CSXCAD/python/doc/CSRectGrid.rst8
-rw-r--r--CSXCAD/python/doc/CSTransform.rst9
-rw-r--r--CSXCAD/python/doc/CSXCAD.rst8
-rw-r--r--CSXCAD/python/doc/CSXCAD_API.rst13
-rw-r--r--CSXCAD/python/doc/Makefile225
-rw-r--r--CSXCAD/python/doc/Mesh.rst12
-rw-r--r--CSXCAD/python/doc/Utilities.rst8
-rw-r--r--CSXCAD/python/doc/about.rst21
-rw-r--r--CSXCAD/python/doc/conf.py348
-rw-r--r--CSXCAD/python/doc/index.rst25
-rw-r--r--CSXCAD/python/doc/install.rst31
35 files changed, 913 insertions, 0 deletions
diff --git a/CSXCAD/python/doc/CSPrimitives.rst b/CSXCAD/python/doc/CSPrimitives.rst
new file mode 100644
index 0000000..0417de0
--- /dev/null
+++ b/CSXCAD/python/doc/CSPrimitives.rst
@@ -0,0 +1,26 @@
+.. _csprimitives:
+
+CSPrimitives
+============
+
+.. automodule:: CSXCAD.CSPrimitives
+
+**List of Primitives:**
+
+.. toctree::
+
+ CSPrimitives/CSPrimitives
+ CSPrimitives/CSPrimPoint
+ CSPrimitives/CSPrimBox
+ CSPrimitives/CSPrimCylinder
+ CSPrimitives/CSPrimCylindricalShell
+ CSPrimitives/CSPrimSphere
+ CSPrimitives/CSPrimSphericalShell
+ CSPrimitives/CSPrimPolygon
+ CSPrimitives/CSPrimLinPoly
+ CSPrimitives/CSPrimRotPoly
+ CSPrimitives/CSPrimCurve
+ CSPrimitives/CSPrimWire
+ CSPrimitives/CSPrimPolyhedron
+ CSPrimitives/CSPrimPolyhedronReader
+
diff --git a/CSXCAD/python/doc/CSPrimitives/CSPrimBox.rst b/CSXCAD/python/doc/CSPrimitives/CSPrimBox.rst
new file mode 100644
index 0000000..7122770
--- /dev/null
+++ b/CSXCAD/python/doc/CSPrimitives/CSPrimBox.rst
@@ -0,0 +1,7 @@
+.. _csprimbox:
+
+CSPrimBox
+---------
+.. autoclass:: CSXCAD.CSPrimitives.CSPrimBox
+ :members:
+ :show-inheritance:
diff --git a/CSXCAD/python/doc/CSPrimitives/CSPrimCurve.rst b/CSXCAD/python/doc/CSPrimitives/CSPrimCurve.rst
new file mode 100644
index 0000000..8125780
--- /dev/null
+++ b/CSXCAD/python/doc/CSPrimitives/CSPrimCurve.rst
@@ -0,0 +1,7 @@
+.. _csprimcurve:
+
+CSPrimCurve
+-----------
+.. autoclass:: CSXCAD.CSPrimitives.CSPrimCurve
+ :members:
+ :show-inheritance:
diff --git a/CSXCAD/python/doc/CSPrimitives/CSPrimCylinder.rst b/CSXCAD/python/doc/CSPrimitives/CSPrimCylinder.rst
new file mode 100644
index 0000000..57c312d
--- /dev/null
+++ b/CSXCAD/python/doc/CSPrimitives/CSPrimCylinder.rst
@@ -0,0 +1,7 @@
+.. _csprimcylinder:
+
+CSPrimCylinder
+--------------
+.. autoclass:: CSXCAD.CSPrimitives.CSPrimCylinder
+ :members:
+ :show-inheritance:
diff --git a/CSXCAD/python/doc/CSPrimitives/CSPrimCylindricalShell.rst b/CSXCAD/python/doc/CSPrimitives/CSPrimCylindricalShell.rst
new file mode 100644
index 0000000..31630c4
--- /dev/null
+++ b/CSXCAD/python/doc/CSPrimitives/CSPrimCylindricalShell.rst
@@ -0,0 +1,7 @@
+.. _csprimcylindricalshell:
+
+CSPrimCylindricalShell
+----------------------
+.. autoclass:: CSXCAD.CSPrimitives.CSPrimCylindricalShell
+ :members:
+ :show-inheritance:
diff --git a/CSXCAD/python/doc/CSPrimitives/CSPrimLinPoly.rst b/CSXCAD/python/doc/CSPrimitives/CSPrimLinPoly.rst
new file mode 100644
index 0000000..236a9a0
--- /dev/null
+++ b/CSXCAD/python/doc/CSPrimitives/CSPrimLinPoly.rst
@@ -0,0 +1,8 @@
+.. _csprimlinpoly:
+
+CSPrimLinPoly
+-------------
+.. autoclass:: CSXCAD.CSPrimitives.CSPrimLinPoly
+ :members:
+ :show-inheritance:
+
diff --git a/CSXCAD/python/doc/CSPrimitives/CSPrimPoint.rst b/CSXCAD/python/doc/CSPrimitives/CSPrimPoint.rst
new file mode 100644
index 0000000..ca3cbdc
--- /dev/null
+++ b/CSXCAD/python/doc/CSPrimitives/CSPrimPoint.rst
@@ -0,0 +1,7 @@
+.. _csprimpoint:
+
+CSPrimPoint
+-----------
+.. autoclass:: CSXCAD.CSPrimitives.CSPrimPoint
+ :members:
+ :show-inheritance:
diff --git a/CSXCAD/python/doc/CSPrimitives/CSPrimPolygon.rst b/CSXCAD/python/doc/CSPrimitives/CSPrimPolygon.rst
new file mode 100644
index 0000000..ffeaf22
--- /dev/null
+++ b/CSXCAD/python/doc/CSPrimitives/CSPrimPolygon.rst
@@ -0,0 +1,8 @@
+.. _csprimpolygon:
+
+CSPrimPolygon
+-------------
+.. autoclass:: CSXCAD.CSPrimitives.CSPrimPolygon
+ :members:
+ :show-inheritance:
+
diff --git a/CSXCAD/python/doc/CSPrimitives/CSPrimPolyhedron.rst b/CSXCAD/python/doc/CSPrimitives/CSPrimPolyhedron.rst
new file mode 100644
index 0000000..b7d01c9
--- /dev/null
+++ b/CSXCAD/python/doc/CSPrimitives/CSPrimPolyhedron.rst
@@ -0,0 +1,8 @@
+.. _csprimpolyhedron:
+
+CSPrimPolyhedron
+----------------
+.. autoclass:: CSXCAD.CSPrimitives.CSPrimPolyhedron
+ :members:
+ :show-inheritance:
+
diff --git a/CSXCAD/python/doc/CSPrimitives/CSPrimPolyhedronReader.rst b/CSXCAD/python/doc/CSPrimitives/CSPrimPolyhedronReader.rst
new file mode 100644
index 0000000..ed10b4a
--- /dev/null
+++ b/CSXCAD/python/doc/CSPrimitives/CSPrimPolyhedronReader.rst
@@ -0,0 +1,8 @@
+.. _csprimpolyhedronreader:
+
+CSPrimPolyhedronReader
+----------------------
+.. autoclass:: CSXCAD.CSPrimitives.CSPrimPolyhedronReader
+ :members:
+ :show-inheritance:
+
diff --git a/CSXCAD/python/doc/CSPrimitives/CSPrimRotPoly.rst b/CSXCAD/python/doc/CSPrimitives/CSPrimRotPoly.rst
new file mode 100644
index 0000000..cf1ca34
--- /dev/null
+++ b/CSXCAD/python/doc/CSPrimitives/CSPrimRotPoly.rst
@@ -0,0 +1,8 @@
+.. _csprimrotpoly:
+
+CSPrimRotPoly
+-------------
+.. autoclass:: CSXCAD.CSPrimitives.CSPrimRotPoly
+ :members:
+ :show-inheritance:
+
diff --git a/CSXCAD/python/doc/CSPrimitives/CSPrimSphere.rst b/CSXCAD/python/doc/CSPrimitives/CSPrimSphere.rst
new file mode 100644
index 0000000..245447e
--- /dev/null
+++ b/CSXCAD/python/doc/CSPrimitives/CSPrimSphere.rst
@@ -0,0 +1,7 @@
+.. _csprimsphere:
+
+CSPrimSphere
+------------
+.. autoclass:: CSXCAD.CSPrimitives.CSPrimSphere
+ :members:
+ :show-inheritance:
diff --git a/CSXCAD/python/doc/CSPrimitives/CSPrimSphericalShell.rst b/CSXCAD/python/doc/CSPrimitives/CSPrimSphericalShell.rst
new file mode 100644
index 0000000..5c86259
--- /dev/null
+++ b/CSXCAD/python/doc/CSPrimitives/CSPrimSphericalShell.rst
@@ -0,0 +1,7 @@
+.. _csprimsphericalshell:
+
+CSPrimSphericalShell
+--------------------
+.. autoclass:: CSXCAD.CSPrimitives.CSPrimSphericalShell
+ :members:
+ :show-inheritance:
diff --git a/CSXCAD/python/doc/CSPrimitives/CSPrimWire.rst b/CSXCAD/python/doc/CSPrimitives/CSPrimWire.rst
new file mode 100644
index 0000000..b0e2c56
--- /dev/null
+++ b/CSXCAD/python/doc/CSPrimitives/CSPrimWire.rst
@@ -0,0 +1,8 @@
+.. _csprimwire:
+
+CSPrimWire
+----------
+.. autoclass:: CSXCAD.CSPrimitives.CSPrimWire
+ :members:
+ :show-inheritance:
+
diff --git a/CSXCAD/python/doc/CSPrimitives/CSPrimitives.rst b/CSXCAD/python/doc/CSPrimitives/CSPrimitives.rst
new file mode 100644
index 0000000..b2406df
--- /dev/null
+++ b/CSXCAD/python/doc/CSPrimitives/CSPrimitives.rst
@@ -0,0 +1,7 @@
+.. _csprimitives_base:
+
+CSPrimitives (Base Class)
+-------------------------
+.. autoclass:: CSXCAD.CSPrimitives.CSPrimitives
+ :members:
+ :show-inheritance:
diff --git a/CSXCAD/python/doc/CSProperties.rst b/CSXCAD/python/doc/CSProperties.rst
new file mode 100644
index 0000000..57705f7
--- /dev/null
+++ b/CSXCAD/python/doc/CSProperties.rst
@@ -0,0 +1,19 @@
+.. _csproperties:
+
+CSProperties
+============
+
+.. automodule:: CSXCAD.CSProperties
+
+**List of Properties:**
+
+.. toctree::
+
+ CSProperties/CSProperties
+ CSProperties/CSPropMaterial
+ CSProperties/CSPropLumpedElement
+ CSProperties/CSPropMetal
+ CSProperties/CSPropConductingSheet
+ CSProperties/CSPropExcitation
+ CSProperties/CSPropProbeBox
+ CSProperties/CSPropDumpBox
diff --git a/CSXCAD/python/doc/CSProperties/CSPropConductingSheet.rst b/CSXCAD/python/doc/CSProperties/CSPropConductingSheet.rst
new file mode 100644
index 0000000..2d0995a
--- /dev/null
+++ b/CSXCAD/python/doc/CSProperties/CSPropConductingSheet.rst
@@ -0,0 +1,7 @@
+.. _cspropconductingsheet:
+
+CSPropConductingSheet
+---------------------
+.. autoclass:: CSXCAD.CSProperties.CSPropConductingSheet
+ :members:
+ :show-inheritance:
diff --git a/CSXCAD/python/doc/CSProperties/CSPropDumpBox.rst b/CSXCAD/python/doc/CSProperties/CSPropDumpBox.rst
new file mode 100644
index 0000000..228dc96
--- /dev/null
+++ b/CSXCAD/python/doc/CSProperties/CSPropDumpBox.rst
@@ -0,0 +1,7 @@
+.. _cspropdumpbox:
+
+CSPropDumpBox
+-------------
+.. autoclass:: CSXCAD.CSProperties.CSPropDumpBox
+ :members:
+ :show-inheritance:
diff --git a/CSXCAD/python/doc/CSProperties/CSPropExcitation.rst b/CSXCAD/python/doc/CSProperties/CSPropExcitation.rst
new file mode 100644
index 0000000..6c34e39
--- /dev/null
+++ b/CSXCAD/python/doc/CSProperties/CSPropExcitation.rst
@@ -0,0 +1,7 @@
+.. _cspropexcitation:
+
+CSPropExcitation
+----------------
+.. autoclass:: CSXCAD.CSProperties.CSPropExcitation
+ :members:
+ :show-inheritance:
diff --git a/CSXCAD/python/doc/CSProperties/CSPropLumpedElement.rst b/CSXCAD/python/doc/CSProperties/CSPropLumpedElement.rst
new file mode 100644
index 0000000..2b40907
--- /dev/null
+++ b/CSXCAD/python/doc/CSProperties/CSPropLumpedElement.rst
@@ -0,0 +1,7 @@
+.. _csproplumpedelement:
+
+CSPropLumpedElement
+-------------------
+.. autoclass:: CSXCAD.CSProperties.CSPropLumpedElement
+ :members:
+ :show-inheritance:
diff --git a/CSXCAD/python/doc/CSProperties/CSPropMaterial.rst b/CSXCAD/python/doc/CSProperties/CSPropMaterial.rst
new file mode 100644
index 0000000..f176dae
--- /dev/null
+++ b/CSXCAD/python/doc/CSProperties/CSPropMaterial.rst
@@ -0,0 +1,7 @@
+.. _cspropmaterial:
+
+CSPropMaterial
+--------------
+.. autoclass:: CSXCAD.CSProperties.CSPropMaterial
+ :members:
+ :show-inheritance:
diff --git a/CSXCAD/python/doc/CSProperties/CSPropMetal.rst b/CSXCAD/python/doc/CSProperties/CSPropMetal.rst
new file mode 100644
index 0000000..32e934f
--- /dev/null
+++ b/CSXCAD/python/doc/CSProperties/CSPropMetal.rst
@@ -0,0 +1,7 @@
+.. _cspropmetal:
+
+CSPropMetal
+-----------
+.. autoclass:: CSXCAD.CSProperties.CSPropMetal
+ :members:
+ :show-inheritance:
diff --git a/CSXCAD/python/doc/CSProperties/CSPropProbeBox.rst b/CSXCAD/python/doc/CSProperties/CSPropProbeBox.rst
new file mode 100644
index 0000000..aca9bbe
--- /dev/null
+++ b/CSXCAD/python/doc/CSProperties/CSPropProbeBox.rst
@@ -0,0 +1,7 @@
+.. _cspropprobebox:
+
+CSPropProbeBox
+--------------
+.. autoclass:: CSXCAD.CSProperties.CSPropProbeBox
+ :members:
+ :show-inheritance:
diff --git a/CSXCAD/python/doc/CSProperties/CSProperties.rst b/CSXCAD/python/doc/CSProperties/CSProperties.rst
new file mode 100644
index 0000000..76b19fd
--- /dev/null
+++ b/CSXCAD/python/doc/CSProperties/CSProperties.rst
@@ -0,0 +1,7 @@
+.. _cspropertiesbase:
+
+CSProperties (Base Class)
+-------------------------
+.. autoclass:: CSXCAD.CSProperties.CSProperties
+ :members:
+ :show-inheritance:
diff --git a/CSXCAD/python/doc/CSRectGrid.rst b/CSXCAD/python/doc/CSRectGrid.rst
new file mode 100644
index 0000000..e83cee0
--- /dev/null
+++ b/CSXCAD/python/doc/CSRectGrid.rst
@@ -0,0 +1,8 @@
+.. _csrectgrid:
+
+CSRectGrid
+----------
+
+.. automodule:: CSXCAD.CSRectGrid
+ :members:
+ :undoc-members:
diff --git a/CSXCAD/python/doc/CSTransform.rst b/CSXCAD/python/doc/CSTransform.rst
new file mode 100644
index 0000000..1879b8a
--- /dev/null
+++ b/CSXCAD/python/doc/CSTransform.rst
@@ -0,0 +1,9 @@
+.. _cstransform:
+
+CSTransform
+------------
+
+.. automodule:: CSXCAD.CSTransform
+ :members:
+ :undoc-members:
+
diff --git a/CSXCAD/python/doc/CSXCAD.rst b/CSXCAD/python/doc/CSXCAD.rst
new file mode 100644
index 0000000..0fedd2b
--- /dev/null
+++ b/CSXCAD/python/doc/CSXCAD.rst
@@ -0,0 +1,8 @@
+.. _csxcad:
+
+CSXCAD
+------
+
+.. automodule:: CSXCAD
+ :members: ContinuousStructure
+ :undoc-members:
diff --git a/CSXCAD/python/doc/CSXCAD_API.rst b/CSXCAD/python/doc/CSXCAD_API.rst
new file mode 100644
index 0000000..fea360b
--- /dev/null
+++ b/CSXCAD/python/doc/CSXCAD_API.rst
@@ -0,0 +1,13 @@
+CSXCAD Python Interface
+=======================
+
+.. toctree::
+ :maxdepth: 2
+
+ CSXCAD
+ CSProperties
+ CSPrimitives
+ CSTransform
+ CSRectGrid
+ Mesh
+ Utilities
diff --git a/CSXCAD/python/doc/Makefile b/CSXCAD/python/doc/Makefile
new file mode 100644
index 0000000..4dcdb4b
--- /dev/null
+++ b/CSXCAD/python/doc/Makefile
@@ -0,0 +1,225 @@
+# Makefile for Sphinx documentation
+#
+
+# You can set these variables from the command line.
+SPHINXOPTS =
+SPHINXBUILD = sphinx-build
+PAPER =
+BUILDDIR = _build
+
+# Internal variables.
+PAPEROPT_a4 = -D latex_paper_size=a4
+PAPEROPT_letter = -D latex_paper_size=letter
+ALLSPHINXOPTS = -d $(BUILDDIR)/doctrees $(PAPEROPT_$(PAPER)) $(SPHINXOPTS) .
+# the i18n builder cannot share the environment and doctrees with the others
+I18NSPHINXOPTS = $(PAPEROPT_$(PAPER)) $(SPHINXOPTS) .
+
+.PHONY: help
+help:
+ @echo "Please use \`make <target>' where <target> is one of"
+ @echo " html to make standalone HTML files"
+ @echo " dirhtml to make HTML files named index.html in directories"
+ @echo " singlehtml to make a single large HTML file"
+ @echo " pickle to make pickle files"
+ @echo " json to make JSON files"
+ @echo " htmlhelp to make HTML files and a HTML help project"
+ @echo " qthelp to make HTML files and a qthelp project"
+ @echo " applehelp to make an Apple Help Book"
+ @echo " devhelp to make HTML files and a Devhelp project"
+ @echo " epub to make an epub"
+ @echo " epub3 to make an epub3"
+ @echo " latex to make LaTeX files, you can set PAPER=a4 or PAPER=letter"
+ @echo " latexpdf to make LaTeX files and run them through pdflatex"
+ @echo " latexpdfja to make LaTeX files and run them through platex/dvipdfmx"
+ @echo " text to make text files"
+ @echo " man to make manual pages"
+ @echo " texinfo to make Texinfo files"
+ @echo " info to make Texinfo files and run them through makeinfo"
+ @echo " gettext to make PO message catalogs"
+ @echo " changes to make an overview of all changed/added/deprecated items"
+ @echo " xml to make Docutils-native XML files"
+ @echo " pseudoxml to make pseudoxml-XML files for display purposes"
+ @echo " linkcheck to check all external links for integrity"
+ @echo " doctest to run all doctests embedded in the documentation (if enabled)"
+ @echo " coverage to run coverage check of the documentation (if enabled)"
+ @echo " dummy to check syntax errors of document sources"
+
+.PHONY: clean
+clean:
+ rm -rf $(BUILDDIR)/*
+
+.PHONY: html
+html:
+ $(SPHINXBUILD) -b html $(ALLSPHINXOPTS) $(BUILDDIR)/html
+ @echo
+ @echo "Build finished. The HTML pages are in $(BUILDDIR)/html."
+
+.PHONY: dirhtml
+dirhtml:
+ $(SPHINXBUILD) -b dirhtml $(ALLSPHINXOPTS) $(BUILDDIR)/dirhtml
+ @echo
+ @echo "Build finished. The HTML pages are in $(BUILDDIR)/dirhtml."
+
+.PHONY: singlehtml
+singlehtml:
+ $(SPHINXBUILD) -b singlehtml $(ALLSPHINXOPTS) $(BUILDDIR)/singlehtml
+ @echo
+ @echo "Build finished. The HTML page is in $(BUILDDIR)/singlehtml."
+
+.PHONY: pickle
+pickle:
+ $(SPHINXBUILD) -b pickle $(ALLSPHINXOPTS) $(BUILDDIR)/pickle
+ @echo
+ @echo "Build finished; now you can process the pickle files."
+
+.PHONY: json
+json:
+ $(SPHINXBUILD) -b json $(ALLSPHINXOPTS) $(BUILDDIR)/json
+ @echo
+ @echo "Build finished; now you can process the JSON files."
+
+.PHONY: htmlhelp
+htmlhelp:
+ $(SPHINXBUILD) -b htmlhelp $(ALLSPHINXOPTS) $(BUILDDIR)/htmlhelp
+ @echo
+ @echo "Build finished; now you can run HTML Help Workshop with the" \
+ ".hhp project file in $(BUILDDIR)/htmlhelp."
+
+.PHONY: qthelp
+qthelp:
+ $(SPHINXBUILD) -b qthelp $(ALLSPHINXOPTS) $(BUILDDIR)/qthelp
+ @echo
+ @echo "Build finished; now you can run "qcollectiongenerator" with the" \
+ ".qhcp project file in $(BUILDDIR)/qthelp, like this:"
+ @echo "# qcollectiongenerator $(BUILDDIR)/qthelp/CSXCAD.qhcp"
+ @echo "To view the help file:"
+ @echo "# assistant -collectionFile $(BUILDDIR)/qthelp/CSXCAD.qhc"
+
+.PHONY: applehelp
+applehelp:
+ $(SPHINXBUILD) -b applehelp $(ALLSPHINXOPTS) $(BUILDDIR)/applehelp
+ @echo
+ @echo "Build finished. The help book is in $(BUILDDIR)/applehelp."
+ @echo "N.B. You won't be able to view it unless you put it in" \
+ "~/Library/Documentation/Help or install it in your application" \
+ "bundle."
+
+.PHONY: devhelp
+devhelp:
+ $(SPHINXBUILD) -b devhelp $(ALLSPHINXOPTS) $(BUILDDIR)/devhelp
+ @echo
+ @echo "Build finished."
+ @echo "To view the help file:"
+ @echo "# mkdir -p $$HOME/.local/share/devhelp/CSXCAD"
+ @echo "# ln -s $(BUILDDIR)/devhelp $$HOME/.local/share/devhelp/CSXCAD"
+ @echo "# devhelp"
+
+.PHONY: epub
+epub:
+ $(SPHINXBUILD) -b epub $(ALLSPHINXOPTS) $(BUILDDIR)/epub
+ @echo
+ @echo "Build finished. The epub file is in $(BUILDDIR)/epub."
+
+.PHONY: epub3
+epub3:
+ $(SPHINXBUILD) -b epub3 $(ALLSPHINXOPTS) $(BUILDDIR)/epub3
+ @echo
+ @echo "Build finished. The epub3 file is in $(BUILDDIR)/epub3."
+
+.PHONY: latex
+latex:
+ $(SPHINXBUILD) -b latex $(ALLSPHINXOPTS) $(BUILDDIR)/latex
+ @echo
+ @echo "Build finished; the LaTeX files are in $(BUILDDIR)/latex."
+ @echo "Run \`make' in that directory to run these through (pdf)latex" \
+ "(use \`make latexpdf' here to do that automatically)."
+
+.PHONY: latexpdf
+latexpdf:
+ $(SPHINXBUILD) -b latex $(ALLSPHINXOPTS) $(BUILDDIR)/latex
+ @echo "Running LaTeX files through pdflatex..."
+ $(MAKE) -C $(BUILDDIR)/latex all-pdf
+ @echo "pdflatex finished; the PDF files are in $(BUILDDIR)/latex."
+
+.PHONY: latexpdfja
+latexpdfja:
+ $(SPHINXBUILD) -b latex $(ALLSPHINXOPTS) $(BUILDDIR)/latex
+ @echo "Running LaTeX files through platex and dvipdfmx..."
+ $(MAKE) -C $(BUILDDIR)/latex all-pdf-ja
+ @echo "pdflatex finished; the PDF files are in $(BUILDDIR)/latex."
+
+.PHONY: text
+text:
+ $(SPHINXBUILD) -b text $(ALLSPHINXOPTS) $(BUILDDIR)/text
+ @echo
+ @echo "Build finished. The text files are in $(BUILDDIR)/text."
+
+.PHONY: man
+man:
+ $(SPHINXBUILD) -b man $(ALLSPHINXOPTS) $(BUILDDIR)/man
+ @echo
+ @echo "Build finished. The manual pages are in $(BUILDDIR)/man."
+
+.PHONY: texinfo
+texinfo:
+ $(SPHINXBUILD) -b texinfo $(ALLSPHINXOPTS) $(BUILDDIR)/texinfo
+ @echo
+ @echo "Build finished. The Texinfo files are in $(BUILDDIR)/texinfo."
+ @echo "Run \`make' in that directory to run these through makeinfo" \
+ "(use \`make info' here to do that automatically)."
+
+.PHONY: info
+info:
+ $(SPHINXBUILD) -b texinfo $(ALLSPHINXOPTS) $(BUILDDIR)/texinfo
+ @echo "Running Texinfo files through makeinfo..."
+ make -C $(BUILDDIR)/texinfo info
+ @echo "makeinfo finished; the Info files are in $(BUILDDIR)/texinfo."
+
+.PHONY: gettext
+gettext:
+ $(SPHINXBUILD) -b gettext $(I18NSPHINXOPTS) $(BUILDDIR)/locale
+ @echo
+ @echo "Build finished. The message catalogs are in $(BUILDDIR)/locale."
+
+.PHONY: changes
+changes:
+ $(SPHINXBUILD) -b changes $(ALLSPHINXOPTS) $(BUILDDIR)/changes
+ @echo
+ @echo "The overview file is in $(BUILDDIR)/changes."
+
+.PHONY: linkcheck
+linkcheck:
+ $(SPHINXBUILD) -b linkcheck $(ALLSPHINXOPTS) $(BUILDDIR)/linkcheck
+ @echo
+ @echo "Link check complete; look for any errors in the above output " \
+ "or in $(BUILDDIR)/linkcheck/output.txt."
+
+.PHONY: doctest
+doctest:
+ $(SPHINXBUILD) -b doctest $(ALLSPHINXOPTS) $(BUILDDIR)/doctest
+ @echo "Testing of doctests in the sources finished, look at the " \
+ "results in $(BUILDDIR)/doctest/output.txt."
+
+.PHONY: coverage
+coverage:
+ $(SPHINXBUILD) -b coverage $(ALLSPHINXOPTS) $(BUILDDIR)/coverage
+ @echo "Testing of coverage in the sources finished, look at the " \
+ "results in $(BUILDDIR)/coverage/python.txt."
+
+.PHONY: xml
+xml:
+ $(SPHINXBUILD) -b xml $(ALLSPHINXOPTS) $(BUILDDIR)/xml
+ @echo
+ @echo "Build finished. The XML files are in $(BUILDDIR)/xml."
+
+.PHONY: pseudoxml
+pseudoxml:
+ $(SPHINXBUILD) -b pseudoxml $(ALLSPHINXOPTS) $(BUILDDIR)/pseudoxml
+ @echo
+ @echo "Build finished. The pseudo-XML files are in $(BUILDDIR)/pseudoxml."
+
+.PHONY: dummy
+dummy:
+ $(SPHINXBUILD) -b dummy $(ALLSPHINXOPTS) $(BUILDDIR)/dummy
+ @echo
+ @echo "Build finished. Dummy builder generates no files."
diff --git a/CSXCAD/python/doc/Mesh.rst b/CSXCAD/python/doc/Mesh.rst
new file mode 100644
index 0000000..13a9978
--- /dev/null
+++ b/CSXCAD/python/doc/Mesh.rst
@@ -0,0 +1,12 @@
+.. _mesh:
+
+Mesh
+====
+
+SmoothMeshLines
+---------------
+
+.. automodule:: CSXCAD.SmoothMeshLines
+ :members:
+ :undoc-members:
+
diff --git a/CSXCAD/python/doc/Utilities.rst b/CSXCAD/python/doc/Utilities.rst
new file mode 100644
index 0000000..d192e0e
--- /dev/null
+++ b/CSXCAD/python/doc/Utilities.rst
@@ -0,0 +1,8 @@
+.. _utilities:
+
+Utilities
+---------
+
+.. automodule:: CSXCAD.Utilities
+ :members:
+ :undoc-members:
diff --git a/CSXCAD/python/doc/about.rst b/CSXCAD/python/doc/about.rst
new file mode 100644
index 0000000..9d14464
--- /dev/null
+++ b/CSXCAD/python/doc/about.rst
@@ -0,0 +1,21 @@
+.. _about:
+
+About
+=====
+
+CSXCAD (Continuous Structure XML) is a C++ library to describe geometrical objects and their physical or non-physical properties.
+
+It supports a Matlab/Octave and Python interface for high-level interaction.
+
+License
+-------
+
+CSXCAD is licensed under the terms of the LGPLv3.
+
+Further information
+-------------------
+
+:Website: http://openems.de/index.php/CSXCAD
+:Forum: http://openems.de/forum/
+:Tutorials: http://openems.de/index.php/Tutorials
+
diff --git a/CSXCAD/python/doc/conf.py b/CSXCAD/python/doc/conf.py
new file mode 100644
index 0000000..2d64e69
--- /dev/null
+++ b/CSXCAD/python/doc/conf.py
@@ -0,0 +1,348 @@
+#!/usr/bin/env python3
+# -*- coding: utf-8 -*-
+#
+# CSXCAD documentation build configuration file, created by
+# sphinx-quickstart on Sun Aug 28 22:27:13 2016.
+#
+# This file is execfile()d with the current directory set to its
+# containing dir.
+#
+# Note that not all possible configuration values are present in this
+# autogenerated file.
+#
+# All configuration values have a default; values that are commented out
+# serve to show the default.
+
+# If extensions (or modules to document with autodoc) are in another directory,
+# add these directories to sys.path here. If the directory is relative to the
+# documentation root, use os.path.abspath to make it absolute, like shown here.
+#
+import os
+import sys
+import sphinx_rtd_theme
+
+# -- General configuration ------------------------------------------------
+
+# If your documentation needs a minimal Sphinx version, state it here.
+#
+# needs_sphinx = '1.0'
+
+# Add any Sphinx extension module names here, as strings. They can be
+# extensions coming with Sphinx (named 'sphinx.ext.*') or your custom
+# ones.
+extensions = [
+ 'sphinx.ext.autodoc',
+ 'sphinx.ext.intersphinx',
+ 'sphinx.ext.todo',
+ 'sphinx.ext.mathjax',
+ 'numpydoc',
+ 'sphinx.ext.autosummary',
+]
+
+# Add any paths that contain templates here, relative to this directory.
+templates_path = ['_templates']
+
+# The suffix(es) of source filenames.
+# You can specify multiple suffix as a list of string:
+#
+# source_suffix = ['.rst', '.md']
+source_suffix = '.rst'
+
+# The encoding of source files.
+#
+# source_encoding = 'utf-8-sig'
+
+# The master toctree document.
+master_doc = 'index'
+
+# General information about the project.
+project = 'CSXCAD'
+copyright = '2016, Thorsten Liebig'
+author = 'Thorsten Liebig'
+
+# The version info for the project you're documenting, acts as replacement for
+# |version| and |release|, also used in various other places throughout the
+# built documents.
+#
+# The short X.Y version.
+version = '0.6'
+# The full version, including alpha/beta/rc tags.
+release = '0.6.1'
+
+# The language for content autogenerated by Sphinx. Refer to documentation
+# for a list of supported languages.
+#
+# This is also used if you do content translation via gettext catalogs.
+# Usually you set "language" from the command line for these cases.
+language = None
+
+# There are two options for replacing |today|: either, you set today to some
+# non-false value, then it is used:
+#
+# today = ''
+#
+# Else, today_fmt is used as the format for a strftime call.
+#
+# today_fmt = '%B %d, %Y'
+
+# List of patterns, relative to source directory, that match files and
+# directories to ignore when looking for source files.
+# This patterns also effect to html_static_path and html_extra_path
+exclude_patterns = ['_build', 'Thumbs.db', '.DS_Store']
+
+# The reST default role (used for this markup: `text`) to use for all
+# documents.
+#
+# default_role = None
+
+# If true, '()' will be appended to :func: etc. cross-reference text.
+#
+# add_function_parentheses = True
+
+# If true, the current module name will be prepended to all description
+# unit titles (such as .. function::).
+#
+# add_module_names = True
+
+# If true, sectionauthor and moduleauthor directives will be shown in the
+# output. They are ignored by default.
+#
+# show_authors = False
+
+# The name of the Pygments (syntax highlighting) style to use.
+pygments_style = 'sphinx'
+
+# A list of ignored prefixes for module index sorting.
+# modindex_common_prefix = []
+
+# If true, keep warnings as "system message" paragraphs in the built documents.
+# keep_warnings = False
+
+# If true, `todo` and `todoList` produce output, else they produce nothing.
+todo_include_todos = True
+
+
+# -- Options for HTML output ----------------------------------------------
+
+# The theme to use for HTML and HTML Help pages. See the documentation for
+# a list of builtin themes.
+#
+html_theme = 'sphinx_rtd_theme'
+
+# Theme options are theme-specific and customize the look and feel of a theme
+# further. For a list of options available for each theme, see the
+# documentation.
+#
+# html_theme_options = {}
+
+# Add any paths that contain custom themes here, relative to this directory.
+# html_theme_path = []
+
+# The name for this set of Sphinx documents.
+# "<project> v<release> documentation" by default.
+#
+# html_title = 'CSXCAD v0.6.1'
+
+# A shorter title for the navigation bar. Default is the same as html_title.
+#
+# html_short_title = None
+
+# The name of an image file (relative to this directory) to place at the top
+# of the sidebar.
+#
+# html_logo = None
+
+# The name of an image file (relative to this directory) to use as a favicon of
+# the docs. This file should be a Windows icon file (.ico) being 16x16 or 32x32
+# pixels large.
+#
+# html_favicon = None
+
+# Add any paths that contain custom static files (such as style sheets) here,
+# relative to this directory. They are copied after the builtin static files,
+# so a file named "default.css" will overwrite the builtin "default.css".
+html_static_path = ['_static']
+
+# Add any extra paths that contain custom files (such as robots.txt or
+# .htaccess) here, relative to this directory. These files are copied
+# directly to the root of the documentation.
+#
+# html_extra_path = []
+
+# If not None, a 'Last updated on:' timestamp is inserted at every page
+# bottom, using the given strftime format.
+# The empty string is equivalent to '%b %d, %Y'.
+#
+# html_last_updated_fmt = None
+
+# If true, SmartyPants will be used to convert quotes and dashes to
+# typographically correct entities.
+#
+# html_use_smartypants = True
+
+# Custom sidebar templates, maps document names to template names.
+#
+# html_sidebars = {}
+
+# Additional templates that should be rendered to pages, maps page names to
+# template names.
+#
+# html_additional_pages = {}
+
+# If false, no module index is generated.
+#
+# html_domain_indices = True
+
+# If false, no index is generated.
+#
+# html_use_index = True
+
+# If true, the index is split into individual pages for each letter.
+#
+# html_split_index = False
+
+# If true, links to the reST sources are added to the pages.
+#
+# html_show_sourcelink = True
+
+# If true, "Created using Sphinx" is shown in the HTML footer. Default is True.
+#
+# html_show_sphinx = True
+
+# If true, "(C) Copyright ..." is shown in the HTML footer. Default is True.
+#
+# html_show_copyright = True
+
+# If true, an OpenSearch description file will be output, and all pages will
+# contain a <link> tag referring to it. The value of this option must be the
+# base URL from which the finished HTML is served.
+#
+# html_use_opensearch = ''
+
+# This is the file name suffix for HTML files (e.g. ".xhtml").
+# html_file_suffix = None
+
+# Language to be used for generating the HTML full-text search index.
+# Sphinx supports the following languages:
+# 'da', 'de', 'en', 'es', 'fi', 'fr', 'h', 'it', 'ja'
+# 'nl', 'no', 'pt', 'ro', 'r', 'sv', 'tr', 'zh'
+#
+# html_search_language = 'en'
+
+# A dictionary with options for the search language support, empty by default.
+# 'ja' uses this config value.
+# 'zh' user can custom change `jieba` dictionary path.
+#
+# html_search_options = {'type': 'default'}
+
+# The name of a javascript file (relative to the configuration directory) that
+# implements a search results scorer. If empty, the default will be used.
+#
+# html_search_scorer = 'scorer.js'
+
+# Output file base name for HTML help builder.
+htmlhelp_basename = 'CSXCADdoc'
+
+# -- Options for LaTeX output ---------------------------------------------
+
+latex_elements = {
+ # The paper size ('letterpaper' or 'a4paper').
+ #
+ # 'papersize': 'letterpaper',
+
+ # The font size ('10pt', '11pt' or '12pt').
+ #
+ # 'pointsize': '10pt',
+
+ # Additional stuff for the LaTeX preamble.
+ #
+ # 'preamble': '',
+
+ # Latex figure (float) alignment
+ #
+ # 'figure_align': 'htbp',
+}
+
+# Grouping the document tree into LaTeX files. List of tuples
+# (source start file, target name, title,
+# author, documentclass [howto, manual, or own class]).
+latex_documents = [
+ (master_doc, 'CSXCAD.tex', 'CSXCAD Documentation',
+ 'Thorsten Liebig', 'manual'),
+]
+
+# The name of an image file (relative to this directory) to place at the top of
+# the title page.
+#
+# latex_logo = None
+
+# For "manual" documents, if this is true, then toplevel headings are parts,
+# not chapters.
+#
+# latex_use_parts = False
+
+# If true, show page references after internal links.
+#
+# latex_show_pagerefs = False
+
+# If true, show URL addresses after external links.
+#
+# latex_show_urls = False
+
+# Documents to append as an appendix to all manuals.
+#
+# latex_appendices = []
+
+# It false, will not define \strong, \code, itleref, \crossref ... but only
+# \sphinxstrong, ..., \sphinxtitleref, ... To help avoid clash with user added
+# packages.
+#
+# latex_keep_old_macro_names = True
+
+# If false, no module index is generated.
+#
+# latex_domain_indices = True
+
+
+# -- Options for manual page output ---------------------------------------
+
+# One entry per manual page. List of tuples
+# (source start file, name, description, authors, manual section).
+man_pages = [
+ (master_doc, 'csxcad', 'CSXCAD Documentation',
+ [author], 1)
+]
+
+# If true, show URL addresses after external links.
+#
+# man_show_urls = False
+
+
+# -- Options for Texinfo output -------------------------------------------
+
+# Grouping the document tree into Texinfo files. List of tuples
+# (source start file, target name, title, author,
+# dir menu entry, description, category)
+texinfo_documents = [
+ (master_doc, 'CSXCAD', 'CSXCAD Documentation',
+ author, 'CSXCAD', 'One line description of project.',
+ 'Miscellaneous'),
+]
+
+# Documents to append as an appendix to all manuals.
+#
+# texinfo_appendices = []
+
+# If false, no module index is generated.
+#
+# texinfo_domain_indices = True
+
+# How to display URL addresses: 'footnote', 'no', or 'inline'.
+#
+# texinfo_show_urls = 'footnote'
+
+# If true, do not generate a @detailmenu in the "Top" node's menu.
+#
+# texinfo_no_detailmenu = False
+
+numpydoc_show_class_members = False
diff --git a/CSXCAD/python/doc/index.rst b/CSXCAD/python/doc/index.rst
new file mode 100644
index 0000000..2a76ecb
--- /dev/null
+++ b/CSXCAD/python/doc/index.rst
@@ -0,0 +1,25 @@
+.. CSXCAD documentation master file, created by
+ sphinx-quickstart on Sun Aug 28 22:27:13 2016.
+ You can adapt this file completely to your liking, but it should at least
+ contain the root `toctree` directive.
+
+Welcome to CSXCAD's documentation!
+==================================
+
+Contents:
+
+.. toctree::
+ :maxdepth: 2
+
+ about
+ install
+ CSXCAD_API
+
+
+Indices and tables
+==================
+
+* :ref:`genindex`
+* :ref:`modindex`
+* :ref:`search`
+
diff --git a/CSXCAD/python/doc/install.rst b/CSXCAD/python/doc/install.rst
new file mode 100644
index 0000000..f3b57ca
--- /dev/null
+++ b/CSXCAD/python/doc/install.rst
@@ -0,0 +1,31 @@
+.. _install:
+
+Install
+=======
+
+Instructions how to install the CSXCAD python interface.
+
+Linux
+-----
+
+* Make sure CSXCAD was build and installed correctly
+
+* Simple version:
+
+.. code-block:: console
+
+ python setup.py install
+
+* Extended options, e.g. for custom install path at */opt*:
+
+.. code-block:: console
+
+ python setup.py build_ext -I/opt/include -L/opt/lib -R/opt/lib"
+ pyhton setup.py install
+
+**Note:** The install command may require root on Linux, or add ``--user`` to install to *~/.local*
+
+Windows
+-------
+
+The python interface for CSXCAD currently does not support MS Windows.