summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules7
1 files changed, 6 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 614a807..f84f290 100755
--- a/debian/rules
+++ b/debian/rules
@@ -19,11 +19,12 @@ OCTAVE_API_VERSION = $(shell octave-config -p API_VERSION)
OCTAVE_FULLBPATH = $(OCTAVE_BPATH)/openems-0.0.35/$(OCTAVE_HOSTTYPE)-$(OCTAVE_API_VERSION)
PYTHON2VERSIONS := $(shell pyversions -s -v)
+PYTHON3VERSIONS := $(shell py3versions -s -v)
export CXXFLAGS := $(CXXFLAGS) -DSSE_CORRECT_DENORMALS=0
%:
- dh $@ --with python2
+ dh $@ --with python2,python3
# Since some sub-folders depend on other sub-folders to be installed before
@@ -52,7 +53,9 @@ override_dh_auto_install:
chrpath -d debian/tmp/usr/bin/nf2ff
chrpath -d debian/tmp/usr/bin/openEMS
cd CSXCAD/python && CPPFLAGS=-I../../debian/tmp/usr/include LDFLAGS=-L../../debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH) PYBUILD_VERSIONS="$(PYTHON2VERSIONS)" pybuild --build && PYBUILD_VERSIONS="$(PYTHON2VERSIONS)" pybuild --install
+ cd CSXCAD/python && CPPFLAGS=-I../../debian/tmp/usr/include LDFLAGS=-L../../debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH) PYBUILD_VERSIONS="$(PYTHON3VERSIONS)" pybuild --build && PYBUILD_VERSIONS="$(PYTHON3VERSIONS)" pybuild --install
cd openEMS/python && CPPFLAGS=-I../../debian/tmp/usr/include LDFLAGS=-L../../debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH) PYBUILD_VERSIONS="$(PYTHON2VERSIONS)" pybuild --build && PYBUILD_VERSIONS="$(PYTHON2VERSIONS)" pybuild --install
+ cd openEMS/python && CPPFLAGS=-I../../debian/tmp/usr/include LDFLAGS=-L../../debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH) PYBUILD_VERSIONS="$(PYTHON3VERSIONS)" pybuild --build && PYBUILD_VERSIONS="$(PYTHON3VERSIONS)" pybuild --install
override_dh_auto_clean:
dh_auto_clean
@@ -63,6 +66,8 @@ override_dh_auto_clean:
$(RM) debian/man/*.1
cd CSXCAD/python && PYBUILD_VERSIONS="$(PYTHON2VERSIONS)" pybuild --clean
cd openEMS/python && PYBUILD_VERSIONS="$(PYTHON2VERSIONS)" pybuild --clean
+ cd CSXCAD/python && PYBUILD_VERSIONS="$(PYTHON3VERSIONS)" pybuild --clean
+ cd openEMS/python && PYBUILD_VERSIONS="$(PYTHON3VERSIONS)" pybuild --clean
$(RM) -r CSXCAD/python/debian
$(RM) -r openEMS/python/debian
$(RM) CSXCAD/python/CSXCAD/*.cpp