summaryrefslogtreecommitdiff
path: root/hyp2mat/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'hyp2mat/src/Makefile.am')
-rw-r--r--hyp2mat/src/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/hyp2mat/src/Makefile.am b/hyp2mat/src/Makefile.am
new file mode 100644
index 0000000..3a64431
--- /dev/null
+++ b/hyp2mat/src/Makefile.am
@@ -0,0 +1,23 @@
+# used by automake
+
+#
+# hyp2mat command line program
+#
+
+bin_PROGRAMS=hyp2mat
+
+hyp2mat_SOURCES=hyp2mat.cc cmdline.ggo cmdline.c cmdline.h
+hyp2mat_LDADD=$(top_builddir)/lib/libhyp2mat.la
+AM_CPPFLAGS= -I$(top_srcdir)/lib
+
+# command line option parsing using gengetopt.
+# create cmdline.c and cmdline.h from cmdline.ggo
+
+cmdline.c cmdline.h: cmdline.ggo
+ $(GENGETOPT) < $^
+
+BUILT_SOURCES=cmdline.c cmdline.h
+
+CLEANFILES=cmdline.c cmdline.h
+
+#not truncated