summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2019-08-03 13:25:07 +0100
committerColin Watson <cjwatson@debian.org>2019-08-03 13:25:07 +0100
commit9e0323ffdc00a48e282b4bd7f0f974665ffe35e1 (patch)
treecc359f2bc175358ab168aa0f702fe16b5a4415f0
parent5c02b384dce466dc4a4b67b7b1ec0c05f3e53639 (diff)
debian/*.apport: Avoid star imports
-rw-r--r--debian/changelog4
-rw-r--r--debian/openssh-client.apport6
-rw-r--r--debian/openssh-server.apport2
3 files changed, 9 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 955cc4f73..740b5037c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,7 +1,9 @@
openssh (1:8.0p1-4) UNRELEASED; urgency=medium
* Use debhelper-compat instead of debian/compat.
- * Remove #! lines from apport hooks.
+ * debian/*.apport:
+ - Remove #! lines.
+ - Avoid star imports.
-- Colin Watson <cjwatson@debian.org> Sat, 03 Aug 2019 12:49:17 +0100
diff --git a/debian/openssh-client.apport b/debian/openssh-client.apport
index ca27da117..8b09bb6c0 100644
--- a/debian/openssh-client.apport
+++ b/debian/openssh-client.apport
@@ -10,7 +10,11 @@ option) any later version. See http://www.gnu.org/copyleft/gpl.html for
the full text of the license.
'''
-from apport.hookutils import *
+from apport.hookutils import (
+ attach_conffiles,
+ attach_related_packages,
+ command_output,
+)
def add_info(report, ui):
response = ui.yesno("The contents of your /etc/ssh/ssh_config file "
diff --git a/debian/openssh-server.apport b/debian/openssh-server.apport
index 687daef97..58631be2d 100644
--- a/debian/openssh-server.apport
+++ b/debian/openssh-server.apport
@@ -10,7 +10,7 @@ option) any later version. See http://www.gnu.org/copyleft/gpl.html for
the full text of the license.
'''
-from apport.hookutils import *
+from apport.hookutils import root_command_output
def add_info(report, ui):
response = ui.yesno("The contents of your /etc/ssh/sshd_config file "