summaryrefslogtreecommitdiff
path: root/defines.h
diff options
context:
space:
mode:
authorDarren Tucker <dtucker@zip.com.au>2003-08-26 11:58:16 +1000
committerDarren Tucker <dtucker@zip.com.au>2003-08-26 11:58:16 +1000
commit49aaf4ad522c6b599ec13f75f8a6b7eab6942143 (patch)
treeccf3984a52b32d59e3900ae8518a796df2860b58 /defines.h
parent0efd155c3c184f0eaa2e1eb244eaaf066e6906e0 (diff)
- (dtucker) [Makefile.in acconfig.h auth-krb5.c auth-pam.c auth-pam.h
configure.ac defines.h gss-serv-krb5.c session.c ssh-gss.h sshconnect1.c sshconnect2.c] Add Portable GSSAPI support, patch by Simon Wilkinson.
Diffstat (limited to 'defines.h')
-rw-r--r--defines.h6
1 files changed, 5 insertions, 1 deletions
diff --git a/defines.h b/defines.h
index b2ea15d9f..7bff839cc 100644
--- a/defines.h
+++ b/defines.h
@@ -25,7 +25,7 @@
#ifndef _DEFINES_H
#define _DEFINES_H
-/* $Id: defines.h,v 1.101 2003/08/21 06:49:41 dtucker Exp $ */
+/* $Id: defines.h,v 1.102 2003/08/26 01:58:16 dtucker Exp $ */
/* Constants */
@@ -521,6 +521,10 @@ struct winsize {
# define __func__ ""
#endif
+#if defined(KRB5) && !defined(HEIMDAL)
+# define krb5_get_err_text(context,code) error_message(code)
+#endif
+
/*
* Define this to use pipes instead of socketpairs for communicating with the
* client program. Socketpairs do not seem to work on all systems.