summaryrefslogtreecommitdiff
path: root/entropy.c
diff options
context:
space:
mode:
authorBen Lindstrom <mouring@eviladmin.org>2001-01-22 21:06:19 +0000
committerBen Lindstrom <mouring@eviladmin.org>2001-01-22 21:06:19 +0000
commitcb577331b4c30cf33c4811a3f6065d4c076deaa7 (patch)
treec6936130eec96a2db364b87e0c2e95b47909fc8f /entropy.c
parent226cfa03781466907dd252916aeade6879e376b8 (diff)
20010123
- (bal) regexp.h typo in configure.in. Should have been regex.h - (bal) SSH_USER_DIR to _PATH_SSH_USER_DIR patch by stevesk@
Diffstat (limited to 'entropy.c')
-rw-r--r--entropy.c5
1 files changed, 3 insertions, 2 deletions
diff --git a/entropy.c b/entropy.c
index 25e83889e..36ce945fc 100644
--- a/entropy.c
+++ b/entropy.c
@@ -35,9 +35,10 @@
#include "ssh.h"
#include "xmalloc.h"
#include "atomicio.h"
+#include "pathnames.h"
#include "log.h"
-RCSID("$Id: entropy.c,v 1.24 2001/01/22 05:34:41 mouring Exp $");
+RCSID("$Id: entropy.c,v 1.25 2001/01/22 21:06:20 mouring Exp $");
#ifndef offsetof
# define offsetof(type, member) ((size_t) &((type *)0)->member)
@@ -560,7 +561,7 @@ prng_write_seedfile(void) {
/* Try to ensure that the parent directory is there */
snprintf(filename, sizeof(filename), "%.512s/%s", pw->pw_dir,
- SSH_USER_DIR);
+ _PATH_SSH_USER_DIR);
mkdir(filename, 0700);
snprintf(filename, sizeof(filename), "%.512s/%s", pw->pw_dir,