summaryrefslogtreecommitdiff
path: root/md-sha256.c
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2006-03-15 13:02:28 +1100
committerDamien Miller <djm@mindrot.org>2006-03-15 13:02:28 +1100
commitaf87af165f25b7db22e32c0b2e55606bc68c450c (patch)
treec0c8557324164e41b9b09b9db942b7193be69c02 /md-sha256.c
parenta63128d1a8a4077bc992e09d00e2683d1592e500 (diff)
- (djm) [configure.ac defines.h kex.c md-sha256.c]
[openbsd-compat/sha2.h openbsd-compat/openbsd-compat.h] [openbsd-compat/sha2.c] First stab at portability glue for SHA256 KEX support, should work with libc SHA256 support or OpenSSL EVP_sha256 if present
Diffstat (limited to 'md-sha256.c')
-rw-r--r--md-sha256.c7
1 files changed, 6 insertions, 1 deletions
diff --git a/md-sha256.c b/md-sha256.c
index 08848f841..82c526d33 100644
--- a/md-sha256.c
+++ b/md-sha256.c
@@ -17,8 +17,10 @@
/* EVP wrapper for SHA256 */
#include "includes.h"
+
+#ifndef HAVE_EVP_SHA256
+
#include <openssl/evp.h>
-#include <sha2.h>
RCSID("$OpenBSD: md-sha256.c,v 1.1 2006/03/07 09:07:40 djm Exp $");
@@ -69,3 +71,6 @@ evp_ssh_sha256(void)
return (&ssh_sha256);
}
+
+#endif /* HAVE_EVP_SHA256 */
+