summaryrefslogtreecommitdiff
path: root/regress
diff options
context:
space:
mode:
authorDarren Tucker <dtucker@zip.com.au>2003-09-04 15:37:58 +1000
committerDarren Tucker <dtucker@zip.com.au>2003-09-04 15:37:58 +1000
commitebc3c13d40f36d0772ee8d204a19a1def0190754 (patch)
treed657c8f83c43955cf96b8360dad3cf3ce0824ea0 /regress
parent6d3921f64bbdb304df9d8ef6887a46dacf3c60b9 (diff)
- [regress/Makefile] Remove BSDisms.
Diffstat (limited to 'regress')
-rw-r--r--regress/Makefile29
1 files changed, 17 insertions, 12 deletions
diff --git a/regress/Makefile b/regress/Makefile
index c3baf78a1..3e6a2483e 100644
--- a/regress/Makefile
+++ b/regress/Makefile
@@ -1,8 +1,14 @@
# $OpenBSD: Makefile,v 1.24 2003/07/03 08:24:13 markus Exp $
-REGRESS_TARGETS= t1 t2 t3 t4 t5 t6 t7
+OBJ ?= `pwd`
+
+REGRESS_TARGETS= t1 t2 t3 t4 t5 t6 t7 t-exec
+tests: $(REGRESS_TARGETS)
CLEANFILES+= t2.out t6.out1 t6.out2 t7.out t7.out.pub copy.1 copy.2
+clean:
+ @for F in $(CLEANFILES); do rm -f $(OBJ)/$${F}; done
+distclean: clean
LTESTS= connect \
proxy-connect \
@@ -36,7 +42,7 @@ CLEANFILES+= authorized_keys_${USER} known_hosts pidfile \
ssh_config ssh_proxy sshd_config sshd_proxy \
rsa.pub rsa rsa1.pub rsa1 host.rsa host.rsa1 \
rsa-agent rsa-agent.pub rsa1-agent rsa1-agent.pub \
- ls.copy
+ ls.copy remote_pid
#LTESTS+= ssh-com ssh-com-client ssh-com-keygen ssh-com-sftp
@@ -49,9 +55,9 @@ t2:
ssh-keygen -yf t2.out | diff - ${.CURDIR}/rsa_openssh.pub
t3:
- ssh-keygen -ef ${.CURDIR}/rsa_openssh.pub |\
- ssh-keygen -if /dev/stdin |\
- diff - ${.CURDIR}/rsa_openssh.pub
+ ssh-keygen -ef ${.CURDIR}/rsa_openssh.pub >$(OBJ)/rsa_secsh.pub
+ ssh-keygen -if $(OBJ)/rsa_secsh.pub | diff - ${.CURDIR}/rsa_openssh.pub
+ rm -f ${.CURDIR}/rsa_secsh.pub
t4:
ssh-keygen -lf ${.CURDIR}/rsa_openssh.pub |\
@@ -74,10 +80,9 @@ t7: t7.out
ssh-keygen -lf t7.out > /dev/null
ssh-keygen -Bf t7.out > /dev/null
-.for t in ${LTESTS}
-REGRESS_TARGETS+=t-${t}
-t-${t}:
- sh ${.CURDIR}/test-exec.sh ${.OBJDIR} ${.CURDIR}/${t}.sh
-.endfor
-
-.include "bsd.regress.mk"
+t-exec: ${LTESTS:=.sh}
+ @if [ "x$?" = "x" ]; then exit 0; fi; \
+ for TEST in ""$?; do \
+ echo "run test $${TEST}" ... 1>&2; \
+ (sh ${.CURDIR}/test-exec.sh ${.OBJDIR} ${.CURDIR}/$${TEST}) || exit $$?; \
+ done