summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--ChangeLog5
-rw-r--r--openbsd-compat/port-tun.c3
-rw-r--r--sshpty.c1
3 files changed, 7 insertions, 2 deletions
diff --git a/ChangeLog b/ChangeLog
index e2bedaad8..c0a0a4ebe 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -265,7 +265,8 @@
[openbsd-compat/readpassphrase.c] Lots of include fixes for
OpenSolaris
- (tim) [includes.h] put sys/stat.h back in to quiet some "macro redefined:"
- warnings.
+ - (tim) [openssh/sshpty.c openssh/openbsd-compat/port-tun.c] put in some
+ includes removed from includes.h
20060313
- (dtucker) [configure.ac] Bug #1171: Don't use printf("%lld", longlong)
@@ -4167,4 +4168,4 @@
- (djm) Trim deprecated options from INSTALL. Mention UsePAM
- (djm) Fix quote handling in sftp; Patch from admorten AT umich.edu
-$Id: ChangeLog,v 1.4219 2006/03/15 05:04:18 tim Exp $
+$Id: ChangeLog,v 1.4220 2006/03/15 06:09:50 tim Exp $
diff --git a/openbsd-compat/port-tun.c b/openbsd-compat/port-tun.c
index 31921615f..d09fe3d06 100644
--- a/openbsd-compat/port-tun.c
+++ b/openbsd-compat/port-tun.c
@@ -16,6 +16,9 @@
#include "includes.h"
+#include <sys/ioctl.h>
+#include <netinet/ip.h>
+
#include "log.h"
#include "misc.h"
#include "bufaux.h"
diff --git a/sshpty.c b/sshpty.c
index 7cfcf91f6..7241580a8 100644
--- a/sshpty.c
+++ b/sshpty.c
@@ -17,6 +17,7 @@ RCSID("$OpenBSD: sshpty.c,v 1.16 2006/02/20 17:19:54 stevesk Exp $");
#include <sys/ioctl.h>
#include <sys/types.h>
#include <sys/stat.h>
+#include <signal.h>
#ifdef HAVE_PATHS_H
# include <paths.h>