summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Delafond <sdelafond@gmail.com>2014-07-13 13:35:36 +0200
committerSébastien Delafond <sdelafond@gmail.com>2014-07-13 13:35:36 +0200
commit75a81babfdc3c8c643962fd77b034b42e20cbee3 (patch)
treeb06b03c3cc12e5921023054c26b6b083f008e6c3
parent361fd4da7cfa870165cb1ec175cdbea55ca40e7e (diff)
Imported Upstream version 8.2.7b
-rw-r--r--lisp/org-bibtex.el2
-rw-r--r--lisp/org-list.el2
-rw-r--r--lisp/org-loaddefs.el14
-rw-r--r--lisp/org-version.el4
-rw-r--r--lisp/org.el12
-rw-r--r--mk/version.mk4
6 files changed, 16 insertions, 22 deletions
diff --git a/lisp/org-bibtex.el b/lisp/org-bibtex.el
index b655710..75ac69b 100644
--- a/lisp/org-bibtex.el
+++ b/lisp/org-bibtex.el
@@ -203,7 +203,7 @@
(:pages . "One or more page numbers or range of numbers, such as 42-111 or 7,41,73-97 or 43+ (the ‘+’ in this last example indicates pages following that don’t form simple range). BibTEX requires double dashes for page ranges (--).")
(:publisher . "The publisher’s name.")
(:school . "The name of the school where a thesis was written.")
- (:series . "The name of a series or set of books. When citing an entire book, the the title field gives its title and an optional series field gives the name of a series or multi-volume set in which the book is published.")
+ (:series . "The name of a series or set of books. When citing an entire book, the title field gives its title and an optional series field gives the name of a series or multi-volume set in which the book is published.")
(:title . "The work’s title, typed as explained in the LaTeX book.")
(:type . "The type of a technical report for example, 'Research Note'.")
(:volume . "The volume of a journal or multi-volume book.")
diff --git a/lisp/org-list.el b/lisp/org-list.el
index 2c4d687..a00e557 100644
--- a/lisp/org-list.el
+++ b/lisp/org-list.el
@@ -1254,7 +1254,7 @@ some heuristics to guess the result."
If POS is before first character after bullet of the item, the
new item will be created before the current one.
-STRUCT is the list structure. PREVS is the the alist of previous
+STRUCT is the list structure. PREVS is the alist of previous
items, as returned by `org-list-prevs-alist'.
Insert a checkbox if CHECKBOX is non-nil, and string AFTER-BULLET
diff --git a/lisp/org-loaddefs.el b/lisp/org-loaddefs.el
index 33548dd..809ba41 100644
--- a/lisp/org-loaddefs.el
+++ b/lisp/org-loaddefs.el
@@ -292,7 +292,7 @@ used to limit the exported source code blocks by language.
;;;;;; org-search-view org-agenda-list org-batch-store-agenda-views
;;;;;; org-store-agenda-views org-batch-agenda-csv org-batch-agenda
;;;;;; org-agenda org-toggle-sticky-agenda) "org-agenda" "org-agenda.el"
-;;;;;; (21410 28899))
+;;;;;; (21415 46785))
;;; Generated autoloads from org-agenda.el
(autoload 'org-toggle-sticky-agenda "org-agenda" "\
@@ -644,8 +644,8 @@ Extract anniversaries from BBDB for display in the agenda.
;;;***
;;;### (autoloads (org-capture-import-remember-templates org-capture
-;;;;;; org-capture-string) "org-capture" "org-capture.el" (21410
-;;;;;; 28899))
+;;;;;; org-capture-string) "org-capture" "org-capture.el" (21415
+;;;;;; 46785))
;;; Generated autoloads from org-capture.el
(autoload 'org-capture-string "org-capture" "\
@@ -821,7 +821,7 @@ Otherwise, return nil.
;;;### (autoloads (org-agenda-columns org-insert-columns-dblock org-dblock-write:columnview
;;;;;; org-columns-number-to-string org-columns-compute org-columns
;;;;;; org-columns-get-format-and-top-level org-columns-remove-overlays)
-;;;;;; "org-colview" "org-colview.el" (21410 28900))
+;;;;;; "org-colview" "org-colview.el" (21415 46785))
;;; Generated autoloads from org-colview.el
(autoload 'org-columns-remove-overlays "org-colview" "\
@@ -885,7 +885,7 @@ Turn on or update column view in the agenda.
;;;***
;;;### (autoloads (org-check-version) "org-compat" "org-compat.el"
-;;;;;; (21410 28900))
+;;;;;; (21415 46785))
;;; Generated autoloads from org-compat.el
(autoload 'org-check-version "org-compat" "\
@@ -1891,7 +1891,7 @@ replace any running timer.
;;;***
;;;### (autoloads (org-git-version org-release) "org-version" "org-version.el"
-;;;;;; (21410 44951))
+;;;;;; (21416 16891))
;;; Generated autoloads from org-version.el
(autoload 'org-release "org-version" "\
@@ -1917,7 +1917,7 @@ The location of ODT styles.")
;;;;;; org-run-like-in-org-mode turn-on-orgstruct++ turn-on-orgstruct
;;;;;; orgstruct-mode org-global-cycle org-cycle org-mode org-clock-persistence-insinuate
;;;;;; turn-on-orgtbl org-version org-babel-load-file org-babel-do-load-languages)
-;;;;;; "org" "org.el" (21410 28900))
+;;;;;; "org" "org.el" (21415 46785))
;;; Generated autoloads from org.el
(autoload 'org-babel-do-load-languages "org" "\
diff --git a/lisp/org-version.el b/lisp/org-version.el
index 0562de3..c36220c 100644
--- a/lisp/org-version.el
+++ b/lisp/org-version.el
@@ -5,13 +5,13 @@
(defun org-release ()
"The release version of org-mode.
Inserted by installing org-mode or when a release is made."
- (let ((org-release "8.2.7a"))
+ (let ((org-release "8.2.7b"))
org-release))
;;;###autoload
(defun org-git-version ()
"The Git version of org-mode.
Inserted by installing org-mode or when a release is made."
- (let ((org-git-version "8.2.7a-dist"))
+ (let ((org-git-version "8.2.7b-dist"))
org-git-version))
;;;###autoload
(defvar org-odt-data-dir "/usr/share/emacs/etc/org"
diff --git a/lisp/org.el b/lisp/org.el
index 6fb0387..adfbeaa 100644
--- a/lisp/org.el
+++ b/lisp/org.el
@@ -5427,8 +5427,7 @@ The following commands are available:
(org-add-hook 'isearch-mode-end-hook 'org-isearch-end 'append 'local)
;; Emacs 22 deals with this through a special variable
(org-set-local 'outline-isearch-open-invisible-function
- (lambda (&rest ignore) (org-show-context 'isearch)))
- (org-add-hook 'isearch-mode-end-hook 'org-fix-ellipsis-at-bol 'append 'local))
+ (lambda (&rest ignore) (org-show-context 'isearch))))
;; Setup the pcomplete hooks
(set (make-local-variable 'pcomplete-command-completion-function)
@@ -5483,9 +5482,6 @@ The following commands are available:
(put 'org-mode 'flyspell-mode-predicate 'org-mode-flyspell-verify)
-(defsubst org-fix-ellipsis-at-bol ()
- (save-excursion (set-window-start (selected-window) (window-start))))
-
(defun org-find-invisible-foreground ()
(let ((candidates (remove
"unspecified-bg"
@@ -13663,8 +13659,7 @@ How much context is shown depends upon the variables
(error nil))
(not (bobp)))
(org-flag-heading nil)
- (when siblings-p (org-show-siblings)))))
- (unless (eq key 'agenda) (org-fix-ellipsis-at-bol))))
+ (when siblings-p (org-show-siblings)))))))
(defvar org-reveal-start-hook nil
"Hook run before revealing a location.")
@@ -23793,8 +23788,7 @@ Show the heading too, if it is currently invisible."
isearch-mode-end-hook-quit)
;; Only when the isearch was not quitted.
(org-add-hook 'post-command-hook 'org-isearch-post-command
- 'append 'local)))
- (org-fix-ellipsis-at-bol)))
+ 'append 'local)))))
(defun org-isearch-post-command ()
"Remove self from hook, and show context."
diff --git a/mk/version.mk b/mk/version.mk
index 3e0db0c..e1f6173 100644
--- a/mk/version.mk
+++ b/mk/version.mk
@@ -1,2 +1,2 @@
-ORGVERSION ?= 8.2.7a
-GITVERSION ?= 8.2.7a-dist
+ORGVERSION ?= 8.2.7b
+GITVERSION ?= 8.2.7b-dist