summaryrefslogtreecommitdiff
path: root/mk
diff options
context:
space:
mode:
authorSébastien Delafond <sdelafond@gmail.com>2015-08-25 12:27:35 +0200
committerSébastien Delafond <sdelafond@gmail.com>2015-08-25 12:27:35 +0200
commit1be13d57dc8357576a8285c6dadc03db9e3ed7b0 (patch)
treee35b32d4dbd60cb6cea09f3c0797cc8877352def /mk
parent4dc4918d0d667f18f3d5e3dd71e6f117ddb8af8a (diff)
Imported Upstream version 8.3.1
Diffstat (limited to 'mk')
-rw-r--r--mk/default.mk51
-rw-r--r--mk/targets.mk11
-rw-r--r--mk/version.mk4
3 files changed, 47 insertions, 19 deletions
diff --git a/mk/default.mk b/mk/default.mk
index eb7fac7..72068d1 100644
--- a/mk/default.mk
+++ b/mk/default.mk
@@ -22,6 +22,10 @@ infodir = $(prefix)/info
# Define if you only need info documentation, the default includes html and pdf
#ORG_MAKE_DOC = info # html pdf
+# Define which git branch to switch to during update. Does not switch
+# the branch when undefined.
+GIT_BRANCH =
+
# Define if you want to include some (or all) files from contrib/lisp
# just the filename please (no path prefix, no .el suffix), maybe with globbing
#ORG_ADD_CONTRIB = ox-* # e.g. the contributed exporter
@@ -39,8 +43,9 @@ BTEST_POST =
# -L <path-to>/ert # needed for Emacs23, Emacs24 has ert built in
# -L <path-to>/ess # needed for running R tests
# -L <path-to>/htmlize # need at least version 1.34 for source code formatting
-BTEST_OB_LANGUAGES = awk C fortran maxima lilypond octave python sh perl
+BTEST_OB_LANGUAGES = awk C fortran maxima lilypond octave perl python
# R # requires ESS to be installed and configured
+ # ruby # requires inf-ruby to be installed and configured
# extra packages to require for testing
BTEST_EXTRA =
# ess-site # load ESS for R tests
@@ -50,23 +55,41 @@ BTEST_EXTRA =
# How to run tests
req-ob-lang = --eval '(require '"'"'ob-$(ob-lang))'
+lst-ob-lang = ($(ob-lang) . t)
req-extra = --eval '(require '"'"'$(req))'
-BTEST = $(BATCH) \
- $(BTEST_PRE) \
- --eval '(add-to-list '"'"'load-path "./lisp")' \
- --eval '(add-to-list '"'"'load-path "./testing")' \
- $(BTEST_POST) \
+BTEST_RE ?= \\(org\\|ob\\)
+BTEST_LOAD = \
+ --eval '(add-to-list '"'"'load-path (concat default-directory "lisp"))' \
+ --eval '(add-to-list '"'"'load-path (concat default-directory "testing"))'
+BTEST_INIT = $(BTEST_PRE) $(BTEST_LOAD) $(BTEST_POST)
+
+BTEST = $(BATCH) $(BTEST_INIT) \
+ -l org-batch-test-init \
+ --eval '(setq \
+ org-batch-test t \
+ org-babel-load-languages \
+ (quote ($(foreach ob-lang,\
+ $(BTEST_OB_LANGUAGES) emacs-lisp shell org,\
+ $(lst-ob-lang)))) \
+ org-test-select-re "$(BTEST_RE)" \
+ )' \
-l org-loaddefs.el \
- -l testing/org-test.el \
- $(foreach ob-lang,$(BTEST_OB_LANGUAGES),$(req-ob-lang)) \
+ -l cl -l testing/org-test.el \
+ -l ert -l org -l ox \
$(foreach req,$(BTEST_EXTRA),$(req-extra)) \
- --eval '(setq org-confirm-babel-evaluate nil)' \
- -f org-test-run-batch-tests
+ --eval '(org-test-run-batch-tests org-test-select-re)'
+
+# Running a plain emacs with no config and this Org-mode loaded. This
+# should be useful for manual testing and verification of problems.
+NOBATCH = $(EMACSQ) $(BTEST_INIT) -l org -f org-version
+
+# start Emacs with no user and site configuration
+# EMACSQ = -vanilla # XEmacs
+EMACSQ = $(EMACS) -Q
# Using emacs in batch mode.
-# BATCH = $(EMACS) -batch -vanilla # XEmacs
-BATCH = $(EMACS) -batch -Q \
- --eval '(setq vc-handled-backends nil)'
+BATCH = $(EMACSQ) -batch \
+ --eval '(setq vc-handled-backends nil org-startup-folded nil)'
# Emacs must be started in toplevel directory
BATCHO = $(BATCH) \
@@ -103,7 +126,7 @@ ELC = $(BATCHL) \
--eval '(batch-byte-compile)'
# How to make a pdf file from a texinfo file
-TEXI2PDF = texi2pdf --batch --clean
+TEXI2PDF = texi2pdf --batch --clean --expand
# How to make a pdf file from a tex file
PDFTEX = pdftex
diff --git a/mk/targets.mk b/mk/targets.mk
index 7f26d86..d390fdb 100644
--- a/mk/targets.mk
+++ b/mk/targets.mk
@@ -31,13 +31,14 @@ endif
clean-install cleanelc cleandirs cleanaddcontrib \
cleanlisp cleandoc cleandocs cleantest \
compile compile-dirty uncompiled \
- config config-test config-exe config-all config-eol config-version
+ config config-test config-exe config-all config-eol config-version \
+ vanilla
CONF_BASE = EMACS DESTDIR ORGCM ORG_MAKE_DOC
CONF_DEST = lispdir infodir datadir testdir
-CONF_TEST = BTEST_PRE BTEST_POST BTEST_OB_LANGUAGES BTEST_EXTRA
+CONF_TEST = BTEST_PRE BTEST_POST BTEST_OB_LANGUAGES BTEST_EXTRA BTEST_RE
CONF_EXEC = CP MKDIR RM RMR FIND SUDO PDFTEX TEXI2PDF TEXI2HTML MAKEINFO INSTALL_INFO
-CONF_CALL = BATCH BATCHL ELC ELCDIR BTEST MAKE_LOCAL_MK MAKE_ORG_INSTALL MAKE_ORG_VERSION
+CONF_CALL = BATCH BATCHL ELC ELCDIR NOBATCH BTEST MAKE_LOCAL_MK MAKE_ORG_INSTALL MAKE_ORG_VERSION
config-eol:: EOL = \#
config-eol:: config-all
config config-all::
@@ -94,6 +95,9 @@ compile compile-dirty::
all clean-install::
$(foreach dir, $(SUBDIRS), $(MAKE) -C $(dir) $@;)
+vanilla:
+ -@$(NOBATCH) &
+
check test:: compile
check test test-dirty::
-$(MKDIR) $(testdir)
@@ -104,6 +108,7 @@ endif
up0:: cleanaddcontrib
up0 up1 up2::
+ git checkout $(GIT_BRANCH)
git remote update
git pull
up1 up2:: all
diff --git a/mk/version.mk b/mk/version.mk
index d33d8e4..877cfee 100644
--- a/mk/version.mk
+++ b/mk/version.mk
@@ -1,2 +1,2 @@
-ORGVERSION ?= 8.2.10
-GITVERSION ?= 8.2.10-dist
+ORGVERSION ?= 8.3.1
+GITVERSION ?= 8.3.1-dist