summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/10-shebang.patch12
-rw-r--r--debian/patches/20-links-unescaping.patch26
-rw-r--r--debian/patches/30-local-mk.patch8
-rw-r--r--debian/patches/series3
4 files changed, 49 insertions, 0 deletions
diff --git a/debian/patches/10-shebang.patch b/debian/patches/10-shebang.patch
new file mode 100644
index 0000000..fd75790
--- /dev/null
+++ b/debian/patches/10-shebang.patch
@@ -0,0 +1,12 @@
+Description: Make lintian happy
+Forwarded: not-needed
+Author: Sebastien Delafond <seb@debian.org>
+
+--- a/contrib/scripts/dir2org.zsh
++++ b/contrib/scripts/dir2org.zsh
+@@ -1,5 +1,3 @@
+-#!/usr/bin/env zsh
+-
+ # desc:
+ #
+ # Output an org compatible structure representing the filesystem from
diff --git a/debian/patches/20-links-unescaping.patch b/debian/patches/20-links-unescaping.patch
new file mode 100644
index 0000000..1a69118
--- /dev/null
+++ b/debian/patches/20-links-unescaping.patch
@@ -0,0 +1,26 @@
+Description: Proper unescaping in links
+Author: Carsten Dominik <carsten.dominik@gmail.com>
+Origin: upstream
+Bug-Debian: http://bugs.debian.org/572404
+
+Index: org-mode-6.34c/lisp/org.el
+===================================================================
+--- org-mode-6.34c.orig/lisp/org.el 2010-01-18 00:10:45.000000000 +0100
++++ org-mode-6.34c/lisp/org.el 2010-03-05 11:27:52.000000000 +0100
+@@ -7914,12 +7914,14 @@
+ (url-unhex-string text)
+ (setq table (or table org-link-escape-chars))
+ (when text
+- (let ((re (mapconcat (lambda (x) (regexp-quote (cdr x)))
++ (let ((case-fold-search t)
++ (re (mapconcat (lambda (x) (regexp-quote (downcase (cdr x))))
+ table "\\|")))
+ (while (string-match re text)
+ (setq text
+ (replace-match
+- (char-to-string (car (rassoc (match-string 0 text) table)))
++ (char-to-string (car (rassoc (upcase (match-string 0 text))
++ table)))
+ t t text)))
+ text))))
+
diff --git a/debian/patches/30-local-mk.patch b/debian/patches/30-local-mk.patch
new file mode 100644
index 0000000..087eff0
--- /dev/null
+++ b/debian/patches/30-local-mk.patch
@@ -0,0 +1,8 @@
+Description: Generate all the doc. including the refcard
+Forwarded: not-needed
+Author: Sebastien Delafond <seb@debian.org>
+
+--- /dev/null
++++ b/local.mk
+@@ -0,0 +1 @@
++ORG_MAKE_DOC = info html pdf card
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..867893a
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1,3 @@
+10-shebang.patch
+#20-links-unescaping.patch
+30-local-mk.patch