summaryrefslogtreecommitdiff
path: root/lisp/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lisp/Makefile')
-rw-r--r--lisp/Makefile37
1 files changed, 22 insertions, 15 deletions
diff --git a/lisp/Makefile b/lisp/Makefile
index 4bc86d4..89f504d 100644
--- a/lisp/Makefile
+++ b/lisp/Makefile
@@ -4,12 +4,23 @@ ifeq ($(MAKELEVEL), 0)
$(error This make needs to be started as a sub-make from the toplevel directory.)
endif
-LISPV = org-version.el
-LISPI = org-install.el
-LISPA = $(LISPV) $(LISPI)
-LISPF = $(filter-out $(LISPA),$(sort $(wildcard *.el)))
-LISPC = $(filter-out $(LISPN:%el=%elc),$(LISPF:%el=%elc))
-_ORGCM_ = dirall single source slint1 slint2
+ifneq ($(ORG_ADD_CONTRIB),)
+ _ORG_ADD_EL_ := \
+ $(notdir \
+ $(wildcard \
+ $(addsuffix .el, \
+ $(addprefix ../contrib/lisp/, \
+ $(basename \
+ $(notdir $(ORG_ADD_CONTRIB)))))))
+endif
+
+LISPV := org-version.el
+LISPI := org-loaddefs.el
+LISPA := $(LISPV) $(LISPI)
+LISPB := $(LISPA:%el=%elc) org-install.elc
+LISPF := $(filter-out $(LISPA),$(sort $(wildcard *.el) $(_ORG_ADD_EL_)))
+LISPC := $(filter-out $(LISPB) $(LISPN:%el=%elc),$(LISPF:%el=%elc))
+_ORGCM_ := dirall single source slint1 slint2
-include local.mk
.PHONY: all compile compile-dirty \
@@ -50,11 +61,7 @@ slint1:
addcontrib:
ifneq ($(ORG_ADD_CONTRIB),)
- $(CP) $(wildcard \
- $(addsuffix .el, \
- $(addprefix ../contrib/lisp/, \
- $(basename \
- $(notdir $(ORG_ADD_CONTRIB)))))) .
+ $(CP) $(addprefix ../contrib/lisp/,$(_ORG_ADD_EL_)) .
endif
autoloads: cleanauto addcontrib $(LISPI) $(LISPV)
@@ -65,22 +72,22 @@ $(LISPV): $(LISPF)
@$(MAKE_ORG_VERSION)
$(LISPI): $(LISPV) $(LISPF)
- @echo "org-install: $(ORGVERSION) ($(GITVERSION))"
+ @echo "org-loaddefs: $(ORGVERSION) ($(GITVERSION))"
@$(RM) $(@)
@$(MAKE_ORG_INSTALL)
-install: $(LISPF) compile
+install: compile $(LISPF)
if [ ! -d $(DESTDIR)$(lispdir) ] ; then \
$(MKDIR) $(DESTDIR)$(lispdir) ; \
fi ;
$(CP) $(LISPC) $(LISPF) $(LISPA) $(DESTDIR)$(lispdir)
cleanauto clean cleanall::
- $(RM) $(LISPA) $(LISPA:%el=%elc)
+ $(RM) $(LISPA) $(LISPB)
clean cleanall cleanelc::
$(RM) *.elc
clean-install:
if [ -d $(DESTDIR)$(lispdir) ] ; then \
- $(RM) $(DESTDIR)$(lispdir)/org*.el* $(DESTDIR)$(lispdir)/ob*.el* ; \
+ $(RM) $(DESTDIR)$(lispdir)/org*.el* $(DESTDIR)$(lispdir)/ob*.el* $(DESTDIR)$(lispdir)/ox*.el* ; \
fi ;