summaryrefslogtreecommitdiff
path: root/mk
diff options
context:
space:
mode:
Diffstat (limited to 'mk')
-rw-r--r--mk/default.mk4
-rw-r--r--mk/org-fixup.el6
-rw-r--r--mk/targets.mk16
-rw-r--r--mk/version.mk4
4 files changed, 20 insertions, 10 deletions
diff --git a/mk/default.mk b/mk/default.mk
index 72068d1..0e639d1 100644
--- a/mk/default.mk
+++ b/mk/default.mk
@@ -150,6 +150,10 @@ RM = rm -f
# How to remove files recursively
RMR = rm -fr
+# How to change file permissions
+# currently only needed for git-annex due to its "lockdown" feature
+CHMOD = chmod
+
# How to copy the lisp files and elc files to their destination.
# CP = cp -p # try this if you have no install
CP = install -m 644 -p
diff --git a/mk/org-fixup.el b/mk/org-fixup.el
index e57eb65..ac28963 100644
--- a/mk/org-fixup.el
+++ b/mk/org-fixup.el
@@ -41,14 +41,14 @@ the Git work tree)."
;;; Code:
;;;\#\#\#autoload
\(defun org-release ()
- \"The release version of org-mode.
- Inserted by installing org-mode or when a release is made.\"
+ \"The release version of Org.
+Inserted by installing Org mode or when a release is made.\"
(let ((org-release \"" org-release "\"))
org-release))
;;;\#\#\#autoload
\(defun org-git-version ()
\"The Git version of org-mode.
- Inserted by installing org-mode or when a release is made.\"
+Inserted by installing Org or when a release is made.\"
(let ((org-git-version \"" org-git-version "\"))
org-git-version))
;;;\#\#\#autoload
diff --git a/mk/targets.mk b/mk/targets.mk
index d390fdb..0ccb6ea 100644
--- a/mk/targets.mk
+++ b/mk/targets.mk
@@ -37,7 +37,7 @@ endif
CONF_BASE = EMACS DESTDIR ORGCM ORG_MAKE_DOC
CONF_DEST = lispdir infodir datadir testdir
CONF_TEST = BTEST_PRE BTEST_POST BTEST_OB_LANGUAGES BTEST_EXTRA BTEST_RE
-CONF_EXEC = CP MKDIR RM RMR FIND SUDO PDFTEX TEXI2PDF TEXI2HTML MAKEINFO INSTALL_INFO
+CONF_EXEC = CP MKDIR RM RMR FIND CHMOD SUDO PDFTEX TEXI2PDF TEXI2HTML MAKEINFO INSTALL_INFO
CONF_CALL = BATCH BATCHL ELC ELCDIR NOBATCH BTEST MAKE_LOCAL_MK MAKE_ORG_INSTALL MAKE_ORG_VERSION
config-eol:: EOL = \#
config-eol:: config-all
@@ -137,11 +137,11 @@ cleandirs:
clean: cleanlisp cleandoc
cleanall: cleandirs cleantest cleanaddcontrib
- -$(FIND) . \( -name \*~ -o -name \*# -o -name .#\* \) -exec $(RM) {} \;
- -$(FIND) $(CLEANDIRS) \( -name \*~ -o -name \*.elc \) -exec $(RM) {} \;
+ -$(FIND) . \( -name \*~ -o -name \*# -o -name .#\* \) -exec $(RM) {} +
+ -$(FIND) $(CLEANDIRS) \( -name \*~ -o -name \*.elc \) -exec $(RM) {} +
$(CLEANDIRS:%=clean%):
- -$(FIND) $(@:clean%=%) \( -name \*~ -o -name \*.elc \) -exec $(RM) {} \;
+ -$(FIND) $(@:clean%=%) \( -name \*~ -o -name \*.elc \) -exec $(RM) {} +
cleanelc:
$(MAKE) -C lisp $@
@@ -158,4 +158,10 @@ cleandocs:
-$(FIND) doc -name \*~ -exec $(RM) {} \;
cleantest:
- $(RMR) $(testdir)
+# git-annex creates non-writable directories so that the files within
+# them can't be removed; if rm fails, try to recover by making all
+# directories writable
+ -$(RMR) $(testdir) || { \
+ $(FIND) $(testdir) -type d -exec $(CHMOD) u+w {} + && \
+ $(RMR) $(testdir) ; \
+ }
diff --git a/mk/version.mk b/mk/version.mk
index ba98992..63d9cef 100644
--- a/mk/version.mk
+++ b/mk/version.mk
@@ -1,2 +1,2 @@
-ORGVERSION ?= 8.3.4
-GITVERSION ?= 8.3.4-dist
+ORGVERSION ?= 9.0
+GITVERSION ?= 9.0-dist