summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRuben Undheim <ruben.undheim@gmail.com>2018-09-23 17:02:23 +0200
committerRuben Undheim <ruben.undheim@gmail.com>2018-09-23 17:02:23 +0200
commit2f51c32c843653e5b5d0c6c93fd0939cfc1f7314 (patch)
treed249c8872329195792c2df4ed99cb3b39cef0bc1
parent52c94c191953207f0597f512aef6258028c3e49c (diff)
Fix git-version-gen
-rw-r--r--debian/changelog11
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules14
3 files changed, 20 insertions, 7 deletions
diff --git a/debian/changelog b/debian/changelog
index 64c8898..f9082bb 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,14 @@
+osmo-ggsn (1.2.2-2~exp1) UNRELEASED; urgency=medium
+
+ * Team upload
+ * debian/control:
+ - New standards version 4.2.1 - no changes
+ * debian/rules:
+ - Create .tarball-version such that git-version-gen works
+ - Clean up some unneeded comments
+
+ -- Ruben Undheim <ruben.undheim@gmail.com> Sun, 23 Sep 2018 17:00:40 +0200
+
osmo-ggsn (1.2.2-1) experimental; urgency=medium
* New upstream release
diff --git a/debian/control b/debian/control
index 725a30f..86aa051 100644
--- a/debian/control
+++ b/debian/control
@@ -7,7 +7,7 @@ Build-Depends: debhelper (>= 11),
pkg-config,
libdpkg-perl,
libosmocore-dev (>= 0.11.0)
-Standards-Version: 4.1.4
+Standards-Version: 4.2.1
Vcs-Browser: https://salsa.debian.org/debian-mobcom-team/osmo-ggsn
Vcs-Git: https://salsa.debian.org/debian-mobcom-team/osmo-ggsn.git
Homepage: https://projects.osmocom.org/projects/openggsn
diff --git a/debian/rules b/debian/rules
index 94a86d3..f6ee964 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,9 +3,7 @@
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
-#DEBIAN := $(shell dpkg-parsechangelog | grep ^Version: | cut -d' ' -f2)
-#DEBVERS := $(shell echo '$(DEBIAN)' | cut -d- -f1)
-#VERSION := $(shell echo '$(DEBVERS)' | sed -e 's/[+-].*//' -e 's/~//g')
+include /usr/share/dpkg/pkg-info.mk
# This has to be exported to make some magic below work.
#export DH_OPTIONS
@@ -15,9 +13,13 @@ arch = $(shell dpkg-architecture -qDEB_BUILD_ARCH)
%:
dh $@ --with autoreconf
-#override_dh_autoreconf:
-# echo $(VERSION) > .tarball-version
-# dh_autoreconf
+override_dh_clean:
+ dh_clean
+ $(RM) .tarball-version
+
+override_dh_autoreconf:
+ echo $(DEB_VERSION_UPSTREAM) > .tarball-version
+ dh_autoreconf
# Print test results in case of a failure
override_dh_auto_test: