summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules14
1 files changed, 8 insertions, 6 deletions
diff --git a/debian/rules b/debian/rules
index 94a86d3..f6ee964 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,9 +3,7 @@
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
-#DEBIAN := $(shell dpkg-parsechangelog | grep ^Version: | cut -d' ' -f2)
-#DEBVERS := $(shell echo '$(DEBIAN)' | cut -d- -f1)
-#VERSION := $(shell echo '$(DEBVERS)' | sed -e 's/[+-].*//' -e 's/~//g')
+include /usr/share/dpkg/pkg-info.mk
# This has to be exported to make some magic below work.
#export DH_OPTIONS
@@ -15,9 +13,13 @@ arch = $(shell dpkg-architecture -qDEB_BUILD_ARCH)
%:
dh $@ --with autoreconf
-#override_dh_autoreconf:
-# echo $(VERSION) > .tarball-version
-# dh_autoreconf
+override_dh_clean:
+ dh_clean
+ $(RM) .tarball-version
+
+override_dh_autoreconf:
+ echo $(DEB_VERSION_UPSTREAM) > .tarball-version
+ dh_autoreconf
# Print test results in case of a failure
override_dh_auto_test: