summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRuben Undheim <ruben.undheim@gmail.com>2018-11-06 22:06:30 +0100
committerRuben Undheim <ruben.undheim@gmail.com>2018-11-06 22:06:30 +0100
commit01c375c09e44df45c1476c9ee8ac042b7977db02 (patch)
treec41d038a93e9f11ffc2135ab1dd4c5fbe97e005f
parent282437b78f2d21293c48271f7da7cf7767f51d15 (diff)
Prepare upload to unstabledebian/0.5.1-1
-rw-r--r--debian/changelog8
-rw-r--r--debian/patches/spelling.patch133
2 files changed, 88 insertions, 53 deletions
diff --git a/debian/changelog b/debian/changelog
index e47baba..1a31dad 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+osmo-pcu (0.5.1-1) unstable; urgency=medium
+
+ * Upload to unstable
+ * debian/patches/spelling.patch
+ - Fix more spelling errors and refresh patch file with 'gbp pq'.
+
+ -- Ruben Undheim <ruben.undheim@gmail.com> Sat, 06 Oct 2018 10:49:01 +0200
+
osmo-pcu (0.5.1-1~exp1) experimental; urgency=medium
* New upstream release
diff --git a/debian/patches/spelling.patch b/debian/patches/spelling.patch
index adb9d61..4ec75f9 100644
--- a/debian/patches/spelling.patch
+++ b/debian/patches/spelling.patch
@@ -1,10 +1,37 @@
-Description: fix spelling errors detected by lintian
-Author: Thorsten Alteholz <debian@alteholz.de>
-Index: osmo-pcu-0.5.0/src/decoding.cpp
-===================================================================
---- osmo-pcu-0.5.0.orig/src/decoding.cpp 2018-05-16 20:13:32.208383044 +0200
-+++ osmo-pcu-0.5.0/src/decoding.cpp 2018-05-16 20:13:32.196383044 +0200
-@@ -77,7 +77,7 @@
+From: Thorsten Alteholz <debian@alteholz.de>
+Date: Sat, 6 Oct 2018 10:42:58 +0200
+Subject: fix spelling errors detected by lintian
+
+---
+ src/bts.cpp | 2 +-
+ src/decoding.cpp | 6 +++---
+ src/encoding.cpp | 2 +-
+ src/gsm_rlcmac.cpp | 4 ++--
+ src/gsm_rlcmac.h | 4 ++--
+ src/pcu_l1_if.cpp | 2 +-
+ src/pdch.cpp | 4 ++--
+ src/tbf.cpp | 2 +-
+ src/tbf.h | 2 +-
+ 9 files changed, 14 insertions(+), 14 deletions(-)
+
+diff --git a/src/bts.cpp b/src/bts.cpp
+index b6d0d0c..a58b1bc 100644
+--- a/src/bts.cpp
++++ b/src/bts.cpp
+@@ -595,7 +595,7 @@ uint32_t BTS::rfn_to_fn(int32_t rfn)
+ * we roll back the rounded frame number by one RFN_MODULUS */
+ if (abs(rfn - m_cur_rfn) > RFN_THRESHOLD) {
+ LOGP(DRLCMAC, LOGL_DEBUG,
+- "Race condition between rfn (%u) and m_cur_fn (%u) detected: rfn belongs to the previos modulus %u cycle, wrappng...\n",
++ "Race condition between rfn (%u) and m_cur_fn (%u) detected: rfn belongs to the previous modulus %u cycle, wrapping...\n",
+ rfn, m_cur_fn, RFN_MODULUS);
+ if (fn_rounded < RFN_MODULUS) {
+ LOGP(DRLCMAC, LOGL_DEBUG,
+diff --git a/src/decoding.cpp b/src/decoding.cpp
+index 0dbb10a..48092cd 100644
+--- a/src/decoding.cpp
++++ b/src/decoding.cpp
+@@ -77,7 +77,7 @@ static int parse_extensions_egprs(const uint8_t *data, unsigned int data_len,
/* TS 44.060, table 10.4.14a.1, row 3 & 5 */
/* only filling bytes left */
LOGP(DRLCMACUL, LOGL_DEBUG, "UL DATA LI contains "
@@ -13,7 +40,7 @@ Index: osmo-pcu-0.5.0/src/decoding.cpp
li->li, li->e, num_chunks);
break;
} else if (li->li > 0) {
-@@ -92,7 +92,7 @@
+@@ -92,7 +92,7 @@ static int parse_extensions_egprs(const uint8_t *data, unsigned int data_len,
}
LOGP(DRLCMACUL, LOGL_DEBUG, "UL DATA LI contains "
@@ -22,7 +49,7 @@ Index: osmo-pcu-0.5.0/src/decoding.cpp
li->li, li->e, num_chunks);
num_chunks += 1;
-@@ -168,7 +168,7 @@
+@@ -168,7 +168,7 @@ static int parse_extensions_gprs(const uint8_t *data, unsigned int data_len,
chunks[num_chunks].is_complete = li->li || is_last_block;
LOGP(DRLCMACUL, LOGL_DEBUG, "UL DATA LI contains "
@@ -31,11 +58,24 @@ Index: osmo-pcu-0.5.0/src/decoding.cpp
li->li, li->m, li->e, num_chunks);
num_chunks += 1;
-Index: osmo-pcu-0.5.0/src/gsm_rlcmac.cpp
-===================================================================
---- osmo-pcu-0.5.0.orig/src/gsm_rlcmac.cpp 2018-05-16 20:13:32.208383044 +0200
-+++ osmo-pcu-0.5.0/src/gsm_rlcmac.cpp 2018-05-16 20:13:32.196383044 +0200
-@@ -1363,8 +1363,8 @@
+diff --git a/src/encoding.cpp b/src/encoding.cpp
+index 1f96458..7e765da 100644
+--- a/src/encoding.cpp
++++ b/src/encoding.cpp
+@@ -413,7 +413,7 @@ int Encoding::write_immediate_assignment(
+
+ if (rc < 0) {
+ LOGP(DRLCMAC, LOGL_ERROR,
+- "Failed to create IMMEDIATE ASSIGMENT (%s) for %s\n",
++ "Failed to create IMMEDIATE ASSIGNMENT (%s) for %s\n",
+ downlink ? "downlink" : "uplink",
+ tbf ? tbf->name() : "single block allocation");
+ return rc;
+diff --git a/src/gsm_rlcmac.cpp b/src/gsm_rlcmac.cpp
+index 6323b09..ef7abcd 100644
+--- a/src/gsm_rlcmac.cpp
++++ b/src/gsm_rlcmac.cpp
+@@ -1363,8 +1363,8 @@ CSN_DESCR_END (PCCF_AdditionsR8_t)
static const
CSN_DESCR_BEGIN(PCCF_AdditionsR5_t)
@@ -46,11 +86,11 @@ Index: osmo-pcu-0.5.0/src/gsm_rlcmac.cpp
M_NEXT_EXIST_OR_NULL(PCCF_AdditionsR5_t, Exist_AdditionsR8, 1),
M_TYPE (PCCF_AdditionsR5_t, AdditionsR8, PCCF_AdditionsR8_t),
CSN_DESCR_END (PCCF_AdditionsR5_t)
-Index: osmo-pcu-0.5.0/src/gsm_rlcmac.h
-===================================================================
---- osmo-pcu-0.5.0.orig/src/gsm_rlcmac.h 2018-05-16 20:13:32.208383044 +0200
-+++ osmo-pcu-0.5.0/src/gsm_rlcmac.h 2018-05-16 20:13:32.196383044 +0200
-@@ -1602,8 +1602,8 @@
+diff --git a/src/gsm_rlcmac.h b/src/gsm_rlcmac.h
+index 2ad1937..a4750e8 100644
+--- a/src/gsm_rlcmac.h
++++ b/src/gsm_rlcmac.h
+@@ -1602,8 +1602,8 @@ typedef struct
typedef struct
{
@@ -61,11 +101,11 @@ Index: osmo-pcu-0.5.0/src/gsm_rlcmac.h
guint8 Exist_AdditionsR8;
PCCF_AdditionsR8_t AdditionsR8;
} PCCF_AdditionsR5_t;
-Index: osmo-pcu-0.5.0/src/pcu_l1_if.cpp
-===================================================================
---- osmo-pcu-0.5.0.orig/src/pcu_l1_if.cpp 2018-05-16 20:13:32.208383044 +0200
-+++ osmo-pcu-0.5.0/src/pcu_l1_if.cpp 2018-05-16 20:13:32.196383044 +0200
-@@ -631,7 +631,7 @@
+diff --git a/src/pcu_l1_if.cpp b/src/pcu_l1_if.cpp
+index 27e86dd..8e077ae 100644
+--- a/src/pcu_l1_if.cpp
++++ b/src/pcu_l1_if.cpp
+@@ -632,7 +632,7 @@ int pcu_rx(uint8_t msg_type, struct gsm_pcu_if *pcu_prim)
rc = pcu_rx_pag_req(&pcu_prim->u.pag_req);
break;
default:
@@ -74,24 +114,11 @@ Index: osmo-pcu-0.5.0/src/pcu_l1_if.cpp
msg_type);
rc = -EINVAL;
}
-Index: osmo-pcu-0.5.0/src/encoding.cpp
-===================================================================
---- osmo-pcu-0.5.0.orig/src/encoding.cpp 2018-05-16 20:13:32.208383044 +0200
-+++ osmo-pcu-0.5.0/src/encoding.cpp 2018-05-16 20:13:32.196383044 +0200
-@@ -413,7 +413,7 @@
-
- if (rc < 0) {
- LOGP(DRLCMAC, LOGL_ERROR,
-- "Failed to create IMMEDIATE ASSIGMENT (%s) for %s\n",
-+ "Failed to create IMMEDIATE ASSIGNMENT (%s) for %s\n",
- downlink ? "downlink" : "uplink",
- tbf ? tbf->name() : "single block allocation");
- return rc;
-Index: osmo-pcu-0.5.0/src/pdch.cpp
-===================================================================
---- osmo-pcu-0.5.0.orig/src/pdch.cpp 2018-05-03 16:20:01.000000000 +0200
-+++ osmo-pcu-0.5.0/src/pdch.cpp 2018-05-16 20:14:22.720382587 +0200
-@@ -631,7 +631,7 @@
+diff --git a/src/pdch.cpp b/src/pdch.cpp
+index 22a1605..81c4c54 100644
+--- a/src/pdch.cpp
++++ b/src/pdch.cpp
+@@ -631,7 +631,7 @@ void gprs_rlcmac_pdch::rcv_resource_request(Packet_Resource_Request_t *request,
int8_t tfi = request->ID.u.Global_TFI.u.DOWNLINK_TFI;
dl_tbf = bts()->dl_tbf_by_tfi(tfi, trx_no(), ts_no);
if (!dl_tbf) {
@@ -100,7 +127,7 @@ Index: osmo-pcu-0.5.0/src/pdch.cpp
return;
}
LOGPTBFDL(dl_tbf, LOGL_ERROR,
-@@ -644,7 +644,7 @@
+@@ -644,7 +644,7 @@ void gprs_rlcmac_pdch::rcv_resource_request(Packet_Resource_Request_t *request,
int8_t tfi = request->ID.u.Global_TFI.u.UPLINK_TFI;
ul_tbf = bts()->ul_tbf_by_tfi(tfi, trx_no(), ts_no);
if (!ul_tbf) {
@@ -109,11 +136,11 @@ Index: osmo-pcu-0.5.0/src/pdch.cpp
return;
}
LOGPTBFUL(ul_tbf, LOGL_ERROR,
-Index: osmo-pcu-0.5.0/src/tbf.cpp
-===================================================================
---- osmo-pcu-0.5.0.orig/src/tbf.cpp 2018-05-16 20:03:11.952388654 +0200
-+++ osmo-pcu-0.5.0/src/tbf.cpp 2018-05-16 20:13:52.224382863 +0200
-@@ -1201,7 +1201,7 @@
+diff --git a/src/tbf.cpp b/src/tbf.cpp
+index 6792d08..a753ab5 100644
+--- a/src/tbf.cpp
++++ b/src/tbf.cpp
+@@ -1210,7 +1210,7 @@ struct msgb *gprs_rlcmac_tbf::create_dl_ass(uint32_t fn, uint8_t ts)
if (direction == GPRS_RLCMAC_DL_TBF && !is_control_ts(ts)) {
LOGPTBF(this, LOGL_NOTICE,
@@ -122,11 +149,11 @@ Index: osmo-pcu-0.5.0/src/tbf.cpp
ts, first_common_ts);
poll_ass_dl = 0;
}
-Index: osmo-pcu-0.5.0/src/tbf.h
-===================================================================
---- osmo-pcu-0.5.0.orig/src/tbf.h 2018-05-16 20:03:31.624388476 +0200
-+++ osmo-pcu-0.5.0/src/tbf.h 2018-05-16 20:13:47.568382905 +0200
-@@ -43,7 +43,7 @@
+diff --git a/src/tbf.h b/src/tbf.h
+index dc0b050..c933284 100644
+--- a/src/tbf.h
++++ b/src/tbf.h
+@@ -43,7 +43,7 @@ struct gprs_rlcmac_bts;
*/
#define T_ASS_AGCH_USEC 200000 /* waiting after IMM.ASS confirm */