summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Langasek <vorlon@debian.org>2000-12-21 06:06:34 +0000
committerSteve Langasek <vorlon@debian.org>2000-12-21 06:06:34 +0000
commitb3c29ee7cffcba5b20a34ebbde38c27246f5145f (patch)
treeac5d13ea42de40290e2225e59264bf8c35bd4cd3
parent38da6ae394a4b2f18e210369562928dc0e404f54 (diff)
Relevant BUGIDs: 126440
Purpose of commit: portability bugfix Commit summary: --------------- Removed non-posix shell command from pam_filter Makefile.
-rw-r--r--CHANGELOG4
-rw-r--r--modules/pam_filter/Makefile2
2 files changed, 4 insertions, 2 deletions
diff --git a/CHANGELOG b/CHANGELOG
index 214e09f6..68ccf3a0 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -35,8 +35,10 @@ Where you should replace XXXXX with a bug-id.
0.74: please submit patches for this section with actual code/doc
patches!
+* per David Lee, fixed non-POSIX shell command in modules/pam_filter/Makefile
+ (Bug 126440 - vorlon)
* modify format of pam_unix log messages to include service name
- (Bug 126423)
+ (Bug 126423 - vorlon)
* prevent pam_unix from logging unknown usernames (Bug 126431 - vorlon)
* changed format of pam_unix 'authentication failure' log messages to make
them clearer and more consistent (Bug 126036 - vorlon)
diff --git a/modules/pam_filter/Makefile b/modules/pam_filter/Makefile
index 97181663..c1394574 100644
--- a/modules/pam_filter/Makefile
+++ b/modules/pam_filter/Makefile
@@ -51,7 +51,7 @@ endif
all: dirs $(LIBSHARED) $(LIBSTATIC) register filters
dirs:
- if [ ! -e include/security ]; then ln -sf . include/security ; fi
+ if [ ! -r include/security ]; then ln -sf . include/security ; fi
ifdef DYNAMIC
$(MKDIR) ./dynamic
endif