summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKees Cook <kees@debian.org>2009-04-17 12:25:03 -0700
committerSteve Langasek <vorlon@debian.org>2019-01-08 19:41:19 -0800
commit5dfff3b61214051bb43efe7d761c0f3a3fc06330 (patch)
treed027d68845b6b076eae8efb186f98c3188a78ba6
parent1dffe6218377aad741e8cd0172811603cead6ad0 (diff)
debian/control: add missing misc:Depends for packages that need it.
-rw-r--r--debian/changelog1
-rw-r--r--debian/control7
2 files changed, 5 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 9652eb3f..e1a9607e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -9,6 +9,7 @@ pam (1.0.1-10) UNRELEASED; urgency=low
[ Kees Cook ]
* Add debian/patches/pam_1.0.4_mindays: backport upstream 1.0.4 fixes
for MINDAYS-Field regression (closes: #514437).
+ * debian/control: add missing misc:Depends for packages that need it.
-- Steve Langasek <vorlon@debian.org> Sun, 22 Mar 2009 20:36:14 -0700
diff --git a/debian/control b/debian/control
index f3032bf6..f6297e6f 100644
--- a/debian/control
+++ b/debian/control
@@ -43,7 +43,7 @@ Package: libpam-runtime
Section: admin
Priority: required
Architecture: all
-Depends: debconf (>= 1.5.19)
+Depends: ${misc:Depends}, debconf (>= 1.5.19)
Replaces: libpam0g-util, libpam0g-dev
Conflicts: libpam0g-util, libpam0g (<< 0.66-0)
Description: Runtime support for the PAM library
@@ -55,7 +55,7 @@ Package: libpam0g-dev
Section: libdevel
Priority: optional
Architecture: any
-Depends: libpam0g (= ${binary:Version}), libc6-dev|libc-dev
+Depends: ${misc:Depends}, libpam0g (= ${binary:Version}), libc6-dev|libc-dev
Conflicts: libpam-dev, libpam-dbg
Replaces: libpam0g (<= 0.65)
Provides: libpam-dev
@@ -74,7 +74,7 @@ Section: admin
Priority: optional
Architecture: any
Replaces: libpam0g-cracklib
-Depends: ${shlibs:Depends}, libpam-runtime (>= 1.0.1-6), cracklib-runtime, wamerican | wordlist
+Depends: ${misc:Depends}, ${shlibs:Depends}, libpam-runtime (>= 1.0.1-6), cracklib-runtime, wamerican | wordlist
Description: PAM module to enable cracklib support
This package includes libpam_cracklib, a PAM module that tests
passwords to make sure they are not too weak during password change.
@@ -84,6 +84,7 @@ Provides: pam-doc
Section: doc
Priority: optional
Architecture: all
+Depends: ${misc:Depends}
Description: Documentation of PAM
Contains documentation (in HTML, ASCII, and PostScript format) for
libpam, the Pluggable Authentication Modules library, a suite of shared