summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThorsten Kukuk <kukuk@thkukuk.de>2010-10-20 13:11:30 +0000
committerThorsten Kukuk <kukuk@thkukuk.de>2010-10-20 13:11:30 +0000
commit5fc7bfece1d98f83ec1ce061508d3ecd8078eb17 (patch)
tree9f604d693f28e7f38b2d7690c58803b266ad6a5f
parentecc112f83d3c57ecb9f0b45c63b529853af7ec3f (diff)
Relevant BUGIDs:
Purpose of commit: bugfix Commit summary: --------------- 2010-10-20 Thorsten Kukuk <kukuk@thkukuk.de> * doc/man/Makefile.am: Fix build dependencys of pam_get_authtok.3. * xtests/Makefile.am: Only build xtests if we run xtests.
-rw-r--r--ChangeLog3
-rw-r--r--doc/man/.cvsignore2
-rw-r--r--doc/man/Makefile.am2
-rw-r--r--doc/man/pam_get_authtok_noverify.31
-rw-r--r--doc/man/pam_get_authtok_verify.31
-rw-r--r--xtests/Makefile.am4
6 files changed, 9 insertions, 4 deletions
diff --git a/ChangeLog b/ChangeLog
index 19a9877a..0a6e67fe 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,5 +1,8 @@
2010-10-20 Thorsten Kukuk <kukuk@thkukuk.de>
+ * doc/man/Makefile.am: Fix build dependencys of pam_get_authtok.3.
+
+ * xtests/Makefile.am: Only build xtests if we run xtests.
* configure.in: Check for libdb with symbol versions, too.
Patch from Diego Elio Pettenò.
diff --git a/doc/man/.cvsignore b/doc/man/.cvsignore
index cc2afe9b..96fa9aba 100644
--- a/doc/man/.cvsignore
+++ b/doc/man/.cvsignore
@@ -19,6 +19,8 @@ pam_get_data.3
pam_getenv.3
pam_getenvlist.3
pam_get_authtok.3
+pam_get_authtok_verify.3
+pam_get_authtok_noverify.3
pam_get_item.3
pam_get_user.3
pam_info.3
diff --git a/doc/man/Makefile.am b/doc/man/Makefile.am
index dc2cf009..7da5bd46 100644
--- a/doc/man/Makefile.am
+++ b/doc/man/Makefile.am
@@ -47,6 +47,8 @@ XMLS = pam.3.xml pam.8.xml \
if ENABLE_REGENERATE_MAN
PAM.8: pam.8
+pam_get_authtok_noverify.3: pam_get_authtok.3
+pam_get_authtok_verify.3: pam_get_authtok.3
pam.d.5: pam.conf.5
test -f $(srcdir)/pam\\.d.5 && mv $(srcdir)/pam\\.d.5 $(srcdir)/pam.d.5 ||:
diff --git a/doc/man/pam_get_authtok_noverify.3 b/doc/man/pam_get_authtok_noverify.3
deleted file mode 100644
index a990dbc4..00000000
--- a/doc/man/pam_get_authtok_noverify.3
+++ /dev/null
@@ -1 +0,0 @@
-.so man3/pam_get_authtok.3
diff --git a/doc/man/pam_get_authtok_verify.3 b/doc/man/pam_get_authtok_verify.3
deleted file mode 100644
index a990dbc4..00000000
--- a/doc/man/pam_get_authtok_verify.3
+++ /dev/null
@@ -1 +0,0 @@
-.so man3/pam_get_authtok.3
diff --git a/xtests/Makefile.am b/xtests/Makefile.am
index 4168e60e..498a9fca 100644
--- a/xtests/Makefile.am
+++ b/xtests/Makefile.am
@@ -7,7 +7,7 @@ AM_CFLAGS = -DLIBPAM_COMPILE -I$(top_srcdir)/libpam/include \
AM_LDFLAGS = -L$(top_builddir)/libpam -lpam \
-L$(top_builddir)/libpam_misc -lpam_misc
-CLEANFILES = *~
+CLEANFILES = *~ $(XTESTS)
EXTRA_DIST = run-xtests.sh tst-pam_dispatch1.pamd tst-pam_dispatch2.pamd \
tst-pam_dispatch3.pamd tst-pam_dispatch4.pamd \
@@ -47,7 +47,7 @@ NOSRCTESTS = tst-pam_substack1 tst-pam_substack2 tst-pam_substack3 \
tst-pam_substack4 tst-pam_substack5 tst-pam_assemble_line1
-noinst_PROGRAMS = $(XTESTS)
+EXTRA_PROGRAMS = $(XTESTS)
xtests: $(XTESTS) run-xtests.sh
"$(srcdir)"/run-xtests.sh "$(srcdir)" ${XTESTS} ${NOSRCTESTS}