summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Langasek <vorlon@debian.org>2010-09-02 10:25:09 -0700
committerSteve Langasek <vorlon@debian.org>2019-01-08 21:48:26 -0800
commit5fcd736d7f0b7744030245e872caf06066094c34 (patch)
tree83dfaf52abd73edd2f543ef8cb468c8b0e3f1526
parentdce501d3ac1cf5c46ef03b03d978dac4e263a0a9 (diff)
debian/patches-applied/no_PATH_MAX_on_hurd: define PATH_MAX for
compatibility when it's not already set. Closes: #552043.
-rw-r--r--debian/changelog11
-rw-r--r--debian/patches-applied/no_PATH_MAX_on_hurd22
-rw-r--r--debian/patches-applied/series1
3 files changed, 32 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 3eb1de6b..b7013d8e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,5 +1,10 @@
-pam (1.1.1-5) UNRELEASED; urgency=low
+pam (1.1.2-1) UNRELEASED; urgency=low
+ * New upstream release.
+ - Add support for NSS groups to pam_group. Closes: #589019,
+ LP: #297408.
+ - Support cross-building the package. Thanks to Neil Williams
+ <codehelp@debian.org> for the patch. Closes: #284854.
* debian/rules: pass getconf LFS_CFLAGS so that we get a 64-bit rlimit
interface. Closes: #579402.
* Drop patches conditional_module,_conditional_man and
@@ -18,8 +23,10 @@ pam (1.1.1-5) UNRELEASED; urgency=low
years ago.
* Bump Standards-Version to 3.9.1.
* Add lintian overrides for a few more spurious warnings.
+ * debian/patches-applied/no_PATH_MAX_on_hurd: define PATH_MAX for
+ compatibility when it's not already set. Closes: #552043.
- -- Steve Langasek <vorlon@debian.org> Sun, 29 Aug 2010 00:56:28 -0700
+ -- Steve Langasek <vorlon@debian.org> Thu, 02 Sep 2010 10:23:42 -0700
pam (1.1.1-4) unstable; urgency=low
diff --git a/debian/patches-applied/no_PATH_MAX_on_hurd b/debian/patches-applied/no_PATH_MAX_on_hurd
new file mode 100644
index 00000000..ab7d506c
--- /dev/null
+++ b/debian/patches-applied/no_PATH_MAX_on_hurd
@@ -0,0 +1,22 @@
+Description: define PATH_MAX for compatibility when it's not already set
+ Some platforms, such as the Hurd, don't set PATH_MAX. Set a reasonable
+ default value in this case.
+Author: Steve Langasek <vorlon@debian.org>
+Bug-Debian: http://bugs.debian.org/552043
+
+Index: pam.deb/tests/tst-dlopen.c
+===================================================================
+--- pam.deb.orig/tests/tst-dlopen.c
++++ pam.deb/tests/tst-dlopen.c
+@@ -16,6 +16,11 @@
+ #include <limits.h>
+ #include <sys/stat.h>
+
++/* Hurd compatibility */
++#ifndef PATH_MAX
++#define PATH_MAX 4096
++#endif
++
+ /* Simple program to see if dlopen() would succeed. */
+ int main(int argc, char **argv)
+ {
diff --git a/debian/patches-applied/series b/debian/patches-applied/series
index 1d1a6034..4fdb9cd8 100644
--- a/debian/patches-applied/series
+++ b/debian/patches-applied/series
@@ -20,3 +20,4 @@ autoconf.patch
update-motd
fix-man-crud
sys-types-include.patch
+no_PATH_MAX_on_hurd