summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Langasek <vorlon@debian.org>2013-04-15 12:09:43 -0700
committerSteve Langasek <vorlon@debian.org>2019-01-08 22:11:50 -0800
commit63dd8220102ac747677585b85a1414cf99253bca (patch)
tree2be3992b86ac497ff03fb717fa89657c02961542
parent30c2e92614c8ba89c3a86797675661750e9840ad (diff)
Fix pam-auth-update handling of trailing blank lines in the fields of
profiles. LP: #1160288.
-rw-r--r--debian/changelog7
-rwxr-xr-xdebian/local/pam-auth-update2
2 files changed, 8 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index c12c7512..464ee52a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+pam (1.1.3-10) UNRELEASED; urgency=low
+
+ * Fix pam-auth-update handling of trailing blank lines in the fields of
+ profiles. LP: #1160288.
+
+ -- Steve Langasek <vorlon@debian.org> Mon, 15 Apr 2013 12:09:09 -0700
+
pam (1.1.3-9) unstable; urgency=low
* Revert libaudit support for now, because libaudit isn't multiarched yet
diff --git a/debian/local/pam-auth-update b/debian/local/pam-auth-update
index 4af12339..17d3fc66 100755
--- a/debian/local/pam-auth-update
+++ b/debian/local/pam-auth-update
@@ -686,7 +686,7 @@ sub parse_pam_profile
} else {
chomp;
s/^\s+//;
- $profile{$fieldname} .= "\n$_";
+ $profile{$fieldname} .= "\n$_" if ($_);
$profile{$fieldname} =~ s/^[\n\s]+//;
}
}