summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew G. Morgan <morgan@kernel.org>2001-05-08 04:14:20 +0000
committerAndrew G. Morgan <morgan@kernel.org>2001-05-08 04:14:20 +0000
commit7626d42b8d9ae4ea90f731e79ce8a9acce1ca8c2 (patch)
tree4ec4716b97d4ceb07a0e0e035a1d3e4193643b8f
parent0373bb10920a5ea0f5b9f7a33033398132d2bd85 (diff)
Relevant BUGIDs: 422144
Purpose of commit: cleanup Commit summary: --------------- Replace 'make' with $(MAKE). This helps on systems that have gmake and need to use it to build the distribution.
-rw-r--r--CHANGELOG2
-rw-r--r--Makefile8
-rw-r--r--doc/Makefile6
3 files changed, 9 insertions, 7 deletions
diff --git a/CHANGELOG b/CHANGELOG
index 02a679b8..4379763f 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -49,6 +49,8 @@ bug report - outstanding bugs are listed here:
0.76: please submit patches for this section with actual code/doc
patches!
+* $(MAKE) instead of 'make' - from Scott T. Emery (Bug 422144 -
+ agmorgan)
* c++ header fixes for pam_misc.h and pam_client.h - from Alexandre
Sagala (Bug 420270 - agmorgan)
* pam_access fixes - looks out for trailing '.' - from Carlo Marcelo
diff --git a/Makefile b/Makefile
index 2bc02f5e..47c7bd39 100644
--- a/Makefile
+++ b/Makefile
@@ -58,20 +58,20 @@ $(THINGSTOMAKE): _pam_aconf.h prep
install: _pam_aconf.h prep
$(MKDIR) $(FAKEROOT)$(INCLUDED)
$(INSTALL) -m 444 security/_pam_aconf.h $(FAKEROOT)$(INCLUDED)
- for x in $(THINGSTOMAKE) ; do make -C $$x install ; done
+ for x in $(THINGSTOMAKE) ; do $(MAKE) -C $$x install ; done
remove:
rm -f $(FAKEROOT)$(INCLUDED)/_pam_aconf.h
- for x in $(THINGSTOMAKE) ; do make -C $$x remove ; done
+ for x in $(THINGSTOMAKE) ; do $(MAKE) -C $$x remove ; done
release:
- @if [ ! -f Make.Rules ]; then echo make Make.Rules first ; exit 1; fi
+ @if [ ! -f Make.Rules ]; then echo $(MAKE) Make.Rules first ;exit 1 ;fi
@if [ ! -L ../$(DISTNAME)-$(MAJOR_REL).$(MINOR_REL) ]; then \
echo generating ../$(DISTNAME)-$(MAJOR_REL).$(MINOR_REL) link ; \
ln -sf $(DISTNAME) ../$(DISTNAME)-$(MAJOR_REL).$(MINOR_REL) ; \
echo to ../$(DISTNAME) . ; fi
@diff ../$(DISTNAME)-$(MAJOR_REL).$(MINOR_REL)/Make.Rules Make.Rules
- make distclean
+ $(MAKE) distclean
cd .. ; tar zvfc $(DISTNAME)-$(MAJOR_REL).$(MINOR_REL).tar.gz \
--exclude CVS --exclude .cvsignore --exclude '.#*' \
$(DISTNAME)-$(MAJOR_REL).$(MINOR_REL)/*
diff --git a/doc/Makefile b/doc/Makefile
index 62702cc8..6e4ab07a 100644
--- a/doc/Makefile
+++ b/doc/Makefile
@@ -22,7 +22,7 @@ MODULES=$(shell ls modules/*.sgml)
dummy:
@echo "Making the documentation..."
- @make all
+ @$(MAKE) all
all: htmls texts postscript
@@ -127,7 +127,7 @@ endif
done
spec:
- cd specs/formatter && make
+ cd specs/formatter && $(MAKE)
specs/formatter/padout < specs/draft-morgan-pam.raw > specs/draft-morgan-pam-current.txt
releasedocs: all spec
@@ -141,5 +141,5 @@ clean:
rm -f $(PSFILES) ps/missfont.log
rm -f MODULES-SGML pam.sgml
rm -f specs/draft-morgan-pam-current.txt
- make -C specs/formatter clean
+ $(MAKE) -C specs/formatter clean