summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Langasek <vorlon@debian.org>2019-02-14 07:08:30 +0000
committerSteve Langasek <vorlon@debian.org>2019-02-14 07:08:30 +0000
commit8e5ad4dbb561a69edae31f7c97eb4a02bfdc1600 (patch)
tree5b2390c43f5b204b3502d38aaad7ddef977591ed
parent1610dc7080430fd34ecc0b1a5955a48fb7ff0925 (diff)
Correctly display the notification when a manual DM restart is needed.
-rw-r--r--debian/changelog1
-rw-r--r--debian/libpam0g.postinst4
2 files changed, 4 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 06f59cec..89e0080a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,7 @@ pam (1.3.1-5) UNRELEASED; urgency=medium
* xdm restart check was inverted in the prior upload; turn it the right
way around
+ * Correctly display the notification when a manual DM restart is needed.
-- Steve Langasek <vorlon@debian.org> Thu, 14 Feb 2019 07:04:50 +0000
diff --git a/debian/libpam0g.postinst b/debian/libpam0g.postinst
index 86d7d2de..953078a0 100644
--- a/debian/libpam0g.postinst
+++ b/debian/libpam0g.postinst
@@ -177,7 +177,9 @@ then
echo "Nothing to restart."
fi
- if who | awk '{print $2}' | grep -q ':[0-9]'; then
+ if [ -n "$(who | awk '$2 ~ /console/ && $NF ~ /:[0-9]/ { print $NF }
+ $2 ~ /:[0-9]/ { print $2 }')" ]
+ then
dms=""
for service in wdm xdm; do
case "$services" in