summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Langasek <vorlon@debian.org>2003-07-13 19:57:17 +0000
committerSteve Langasek <vorlon@debian.org>2003-07-13 19:57:17 +0000
commitd9628ff6eb4c6807123496f3a3195c5e3ea32aba (patch)
tree4322b585d2c7c1dc40064b32b9bdd732493df3cd
parentb398ec51b4df706896c00298bf89ea1295283cb6 (diff)
Relevant BUGIDs: 643357
Purpose of commit: cleanup Commit summary: --------------- bring configure up-to-date wrt configure.in.
-rwxr-xr-xconfigure6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure b/configure
index ffd26b3a..65d0fd9f 100755
--- a/configure
+++ b/configure
@@ -592,7 +592,7 @@ MKDIR="mkdir -p" ;
SHLIBMODE=755 ;
USESONAME=yes ;
-SOSWITCH=-soname ;
+SOSWITCH='-Xlinker -soname -Xlinker ' ;
NEEDSONAME=no ;
LDCONFIG=/sbin/ldconfig ;
@@ -2479,8 +2479,8 @@ if test "$GCC" = yes; then
WARNINGS="$GCC_WARNINGS"
PIC="-fPIC"
DYNTYPE=so
- LD=ld
- LD_L="$LD -x -shared"
+ LD=gcc
+ LD_L="$LD -Xlinker -x -shared"
RANLIB=ranlib
STRIP=strip
CC_STATIC="-Xlinker -export-dynamic"