summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mraz <tm@t8m.info>2008-12-02 10:57:19 +0000
committerTomas Mraz <tm@t8m.info>2008-12-02 10:57:19 +0000
commitf9cde35ec82267c2fa3012276a35a6f1b2cf131f (patch)
treecd2d4e6d2b1e7b62308e984ee702fd0cb26f74bf
parent703c640d3722f93b4e7fe14688efc15c9fb92e5f (diff)
Relevant BUGIDs:
Purpose of commit: cleanup Commit summary: --------------- 2008-12-02 Tomas Mraz <t8m@centrum.cz> * modules/pam_timestamp/Makefile.am: Add hmacfile to tests. * modules/pam_timestamp/hmacfile.c: Do not try the short key testvector.
-rw-r--r--ChangeLog6
-rw-r--r--modules/pam_timestamp/.cvsignore3
-rw-r--r--modules/pam_timestamp/Makefile.am4
-rw-r--r--modules/pam_timestamp/hmacfile.c2
4 files changed, 12 insertions, 3 deletions
diff --git a/ChangeLog b/ChangeLog
index e0ba6a23..7f12805d 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,9 @@
+2008-12-02 Tomas Mraz <t8m@centrum.cz>
+
+ * modules/pam_timestamp/Makefile.am: Add hmacfile to tests.
+ * modules/pam_timestamp/hmacfile.c: Do not try the short key
+ testvector.
+
2008-12-01 Tomas Mraz <t8m@centrum.cz>
* modules/pam_unix/support.h: Fix masks for cipher algorithm
diff --git a/modules/pam_timestamp/.cvsignore b/modules/pam_timestamp/.cvsignore
index d9a7b0d9..c084c915 100644
--- a/modules/pam_timestamp/.cvsignore
+++ b/modules/pam_timestamp/.cvsignore
@@ -9,4 +9,5 @@ Makefile.in
README
pam_timestamp.8
pam_timestamp_check.8
-
+hmacfile
+pam_timestamp_check
diff --git a/modules/pam_timestamp/Makefile.am b/modules/pam_timestamp/Makefile.am
index 51a3c215..373f483c 100644
--- a/modules/pam_timestamp/Makefile.am
+++ b/modules/pam_timestamp/Makefile.am
@@ -1,13 +1,13 @@
#
# Copyright (c) 2005 Thorsten Kukuk <kukuk@suse.de>
-# Copyright (c) 2005 Red Hat, Inc.
+# Copyright (c) 2005, 2008 Red Hat, Inc.
#
CLEANFILES = *~
XMLS = README.xml pam_timestamp.8.xml pam_timestamp_check.8.xml
man_MANS = pam_timestamp.8 pam_timestamp_check.8
-TESTS = tst-pam_timestamp
+TESTS = tst-pam_timestamp hmacfile
EXTRA_DIST = $(man_MANS) hmactest.c $(XMLS) $(TESTS)
diff --git a/modules/pam_timestamp/hmacfile.c b/modules/pam_timestamp/hmacfile.c
index 963f6f54..d2da5ff1 100644
--- a/modules/pam_timestamp/hmacfile.c
+++ b/modules/pam_timestamp/hmacfile.c
@@ -63,11 +63,13 @@ testvectors(void)
"b617318655057264e28bc0b6fb378c8ef146be00",
},
+#ifdef HMAC_ALLOW_SHORT_KEYS
{
"Jefe", 4,
"what do ya want for nothing?", 28,
"effcdf6ae5eb2fa2d27416d5f184df9c259a7c79",
},
+#endif
{
"\xaa\xaa\xaa\xaa\xaa\xaa\xaa\xaa\xaa\xaa\xaa\xaa\xaa\xaa\xaa\xaa\xaa\xaa\xaa\xaa", 20,