summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThorsten Kukuk <kukuk@thkukuk.de>2011-06-24 12:45:27 +0200
committerThorsten Kukuk <kukuk@thkukuk.de>2011-06-24 12:45:27 +0200
commit01e04364faedc820de207bd3c8ecd0becf0e9fa3 (patch)
tree0397e4b5e15bbd023489875586dfaf8805445572
parentcf65cdf3deec760c30def8d5fcc5e58f81386eae (diff)
Fix order of libraries
-rw-r--r--ChangeLog3
-rw-r--r--modules/pam_unix/Makefile.am6
2 files changed, 6 insertions, 3 deletions
diff --git a/ChangeLog b/ChangeLog
index fadefd96..07f120f1 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -7,6 +7,9 @@
* libpam/Makefile.am: Bump release number of shared library
* po/de.po: Translate new string.
+ * modules/pam_unix/Makefile.am (pam_unix_la_LIBADD): Reorder
+ Libraries.
+
2011-06-21 Thorsten Kukuk <kukuk@thkukuk.de>
* modules/pam_limits/pam_limits.c: Add set_all option,
diff --git a/modules/pam_unix/Makefile.am b/modules/pam_unix/Makefile.am
index ba77d39f..ea5a7318 100644
--- a/modules/pam_unix/Makefile.am
+++ b/modules/pam_unix/Makefile.am
@@ -1,5 +1,5 @@
#
-# Copyright (c) 2005, 2006, 2009 Thorsten Kukuk <kukuk@suse.de>
+# Copyright (c) 2005, 2006, 2009, 2011 Thorsten Kukuk <kukuk@suse.de>
#
CLEANFILES = *~
@@ -29,8 +29,8 @@ pam_unix_la_LDFLAGS = -no-undefined -avoid-version -module
if HAVE_VERSIONING
pam_unix_la_LDFLAGS += -Wl,--version-script=$(srcdir)/../modules.map
endif
-pam_unix_la_LIBADD = $(NIS_LIBS) -L$(top_builddir)/libpam -lpam \
- @LIBCRYPT@ @LIBSELINUX@
+pam_unix_la_LIBADD = -L$(top_builddir)/libpam -lpam \
+ @LIBCRYPT@ @LIBSELINUX@ $(NIS_LIBS)
securelib_LTLIBRARIES = pam_unix.la