summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Langasek <vorlon@debian.org>2010-06-07 10:57:06 -0700
committerSteve Langasek <vorlon@debian.org>2019-01-08 21:26:03 -0800
commit2757399bb70319f2d62294ab01277841ee2cf72f (patch)
treea78da45d835db58b21ee63d9dfe958b999bfa190
parentbf574a76debe2cbc8a3de6b3b826abc026fd42cd (diff)
debian/patches/conditional_module,_conditional_man: if we don't have the
libraries required for building pam_tty_audit, we shouldn't install the manpage either. LP: #588547.
-rw-r--r--debian/changelog8
-rw-r--r--debian/patches-applied/autoconf.patch40
-rw-r--r--debian/patches-applied/conditional_module,_conditional_man24
-rw-r--r--debian/patches-applied/series1
4 files changed, 73 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 7da2321a..c7314a12 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+pam (1.1.1-4) UNRELEASED; urgency=low
+
+ * debian/patches/conditional_module,_conditional_man: if we don't have the
+ libraries required for building pam_tty_audit, we shouldn't install the
+ manpage either. LP: #588547.
+
+ -- Steve Langasek <vorlon@debian.org> Mon, 07 Jun 2010 10:53:48 -0700
+
pam (1.1.1-3) unstable; urgency=low
* pam-auth-update: fix a bug in our handling of module options when the
diff --git a/debian/patches-applied/autoconf.patch b/debian/patches-applied/autoconf.patch
index 89b63723..de57de6b 100644
--- a/debian/patches-applied/autoconf.patch
+++ b/debian/patches-applied/autoconf.patch
@@ -17072,3 +17072,43 @@ Index: pam.deb/modules/pam_unix/Makefile.in
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/pam_unix_acct.Plo@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/pam_unix_auth.Plo@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/pam_unix_passwd.Plo@am__quote@
+Index: pam.deb/modules/pam_tty_audit/Makefile.in
+===================================================================
+--- pam.deb.orig/modules/pam_tty_audit/Makefile.in
++++ pam.deb/modules/pam_tty_audit/Makefile.in
+@@ -45,7 +45,6 @@
+ ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
+ am__aclocal_m4_deps = $(top_srcdir)/m4/gettext.m4 \
+ $(top_srcdir)/m4/iconv.m4 $(top_srcdir)/m4/intlmacosx.m4 \
+- $(top_srcdir)/m4/japhar_grep_cflags.m4 \
+ $(top_srcdir)/m4/jh_path_xml_catalog.m4 \
+ $(top_srcdir)/m4/ld-O1.m4 $(top_srcdir)/m4/ld-as-needed.m4 \
+ $(top_srcdir)/m4/lib-ld.m4 $(top_srcdir)/m4/lib-link.m4 \
+@@ -54,7 +53,7 @@
+ $(top_srcdir)/m4/ltsugar.m4 $(top_srcdir)/m4/ltversion.m4 \
+ $(top_srcdir)/m4/lt~obsolete.m4 $(top_srcdir)/m4/nls.m4 \
+ $(top_srcdir)/m4/po.m4 $(top_srcdir)/m4/progtest.m4 \
+- $(top_srcdir)/configure.in
++ $(top_srcdir)/acinclude.m4 $(top_srcdir)/configure.in
+ am__configure_deps = $(am__aclocal_m4_deps) $(CONFIGURE_DEPENDENCIES) \
+ $(ACLOCAL_M4)
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
+@@ -193,6 +192,7 @@
+ PACKAGE_NAME = @PACKAGE_NAME@
+ PACKAGE_STRING = @PACKAGE_STRING@
+ PACKAGE_TARNAME = @PACKAGE_TARNAME@
++PACKAGE_URL = @PACKAGE_URL@
+ PACKAGE_VERSION = @PACKAGE_VERSION@
+ PATH_SEPARATOR = @PATH_SEPARATOR@
+ PIE_CFLAGS = @PIE_CFLAGS@
+@@ -273,8 +273,8 @@
+ top_srcdir = @top_srcdir@
+ CLEANFILES = *~
+ MAINTAINERCLEANFILES = $(MANS) README
+-EXTRA_DIST = README $(MANS) $(XMLS)
+-man_MANS = pam_tty_audit.8
++EXTRA_DIST = README pam_tty_audit.8 $(XMLS)
++@HAVE_AUDIT_TTY_STATUS_TRUE@man_MANS = pam_tty_audit.8
+ XMLS = README.xml pam_tty_audit.8.xml
+ securelibdir = $(SECUREDIR)
+ AM_CFLAGS = -I$(top_srcdir)/libpam/include -I$(top_srcdir)/libpamc/include
diff --git a/debian/patches-applied/conditional_module,_conditional_man b/debian/patches-applied/conditional_module,_conditional_man
new file mode 100644
index 00000000..607aa144
--- /dev/null
+++ b/debian/patches-applied/conditional_module,_conditional_man
@@ -0,0 +1,24 @@
+Description: don't install manpage for pam_tty_audit if the module isn't built
+ If we don't have the libraries required for building pam_tty_audit, we
+ shouldn't install the manpage either.
+Author: Steve Langasek <steve.langasek@canonical.com>
+Bug-Ubuntu: https://bugs.launchpad.net/bugs/588547
+
+Index: pam.deb/modules/pam_tty_audit/Makefile.am
+===================================================================
+--- pam.deb.orig/modules/pam_tty_audit/Makefile.am
++++ pam.deb/modules/pam_tty_audit/Makefile.am
+@@ -5,9 +5,11 @@
+ CLEANFILES = *~
+ MAINTAINERCLEANFILES = $(MANS) README
+
+-EXTRA_DIST = README $(MANS) $(XMLS)
++EXTRA_DIST = README pam_tty_audit.8 $(XMLS)
+
+-man_MANS = pam_tty_audit.8
++if HAVE_AUDIT_TTY_STATUS
++ man_MANS = pam_tty_audit.8
++endif
+ XMLS = README.xml pam_tty_audit.8.xml
+
+ securelibdir = $(SECUREDIR)
diff --git a/debian/patches-applied/series b/debian/patches-applied/series
index 1d1a6034..7783ddb1 100644
--- a/debian/patches-applied/series
+++ b/debian/patches-applied/series
@@ -16,6 +16,7 @@ hurd_no_setfsuid
054_pam_security_abstract_securetty_handling
055_pam_unix_nullok_secure
PAM-manpage-section
+conditional_module,_conditional_man
autoconf.patch
update-motd
fix-man-crud