summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry V. Levin <ldv@altlinux.org>2015-01-06 22:29:11 +0000
committerDmitry V. Levin <ldv@altlinux.org>2015-01-07 00:29:06 +0000
commit58d2da7160a477a5f5654be08bb36cc475eb75d7 (patch)
tree3cb6bccff2bbad9820e30bdcb8bac898a0f08712
parent6e1fcb85760a7530ee78af09f16ef22e0bd371fc (diff)
build: raise gettext version requirement
Raise gettext requirement to the latest oldstable version 0.18.3. This fixes the following automake warning: configure.ac:581: warning: The 'AM_PROG_MKDIR_P' macro is deprecated, and its use is discouraged. configure.ac:581: You should use the Autoconf-provided 'AC_PROG_MKDIR_P' macro instead, configure.ac:581: and use '$(MKDIR_P)' instead of '$(mkdir_p)'in your Makefile.am files. * configure.ac (AM_GNU_GETTEXT_VERSION): Raise from 0.15 to 0.18.3. * po/Makevars: Update from gettext-0.18.3.
-rw-r--r--configure.ac2
-rw-r--r--po/Makevars12
2 files changed, 13 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index cbe5d712..47d254b1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -577,7 +577,7 @@ AM_CONDITIONAL(ENABLE_REGENERATE_MAN, test x$enable_docu != xno)
AM_CONDITIONAL(ENABLE_GENERATE_PDF, test ! -z "$FO2PDF")
-AM_GNU_GETTEXT_VERSION([0.15])
+AM_GNU_GETTEXT_VERSION([0.18.3])
AM_GNU_GETTEXT([external])
AC_CHECK_FUNCS(dngettext)
diff --git a/po/Makevars b/po/Makevars
index c152efd6..2e0a6ca5 100644
--- a/po/Makevars
+++ b/po/Makevars
@@ -39,3 +39,15 @@ MSGID_BUGS_ADDRESS = http://sourceforge.net/projects/pam
# This is the list of locale categories, beyond LC_MESSAGES, for which the
# message catalogs shall be used. It is usually empty.
EXTRA_LOCALE_CATEGORIES =
+
+# This tells whether the $(DOMAIN).pot file contains messages with an 'msgctxt'
+# context. Possible values are "yes" and "no". Set this to yes if the
+# package uses functions taking also a message context, like pgettext(), or
+# if in $(XGETTEXT_OPTIONS) you define keywords with a context argument.
+USE_MSGCTXT = no
+
+# These options get passed to msgmerge.
+# Useful options are in particular:
+# --previous to keep previous msgids of translated messages,
+# --quiet to reduce the verbosity.
+MSGMERGE_OPTIONS =