summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThorsten Kukuk <kukuk@thkukuk.de>2005-07-20 09:46:14 +0000
committerThorsten Kukuk <kukuk@thkukuk.de>2005-07-20 09:46:14 +0000
commit6db0f946028a72a4551c2967cbfe9c1e3a82daa8 (patch)
treed2791e149c7dc4f94b71cc48834355c0c8d73398
parent8850118bf8debd84de49f44416144da2cbbf31c4 (diff)
Relevant BUGIDs: none
Purpose of commit: cleanup Commit summary: --------------- Rename _pam_aconf.h to config.h.
-rw-r--r--CHANGELOG1
-rw-r--r--Makefile18
-rw-r--r--config.h.in (renamed from _pam_aconf.h.in)2
-rwxr-xr-xconfigure4
-rw-r--r--configure.in2
-rw-r--r--examples/xsh.c2
-rw-r--r--libpam/pam_private.h2
-rw-r--r--libpam_misc/misc_conv.c2
-rw-r--r--modules/pam_access/pam_access.c2
-rw-r--r--modules/pam_cracklib/pam_cracklib.c2
-rw-r--r--modules/pam_env/pam_env.c2
-rw-r--r--modules/pam_filter/pam_filter.c2
-rw-r--r--modules/pam_filter/upperLOWER/upperLOWER.c2
-rw-r--r--modules/pam_ftp/pam_ftp.c2
-rw-r--r--modules/pam_group/pam_group.c2
-rw-r--r--modules/pam_issue/pam_issue.c2
-rw-r--r--modules/pam_lastlog/pam_lastlog.c2
-rw-r--r--modules/pam_limits/pam_limits.c2
-rw-r--r--modules/pam_listfile/pam_listfile.c2
-rw-r--r--modules/pam_localuser/pam_localuser.c2
-rw-r--r--modules/pam_mail/pam_mail.c2
-rw-r--r--modules/pam_mkhomedir/pam_mkhomedir.c5
-rw-r--r--modules/pam_motd/pam_motd.c2
-rw-r--r--modules/pam_pwdb/pam_pwdb.c2
-rw-r--r--modules/pam_pwdb/pwdb_chkpwd.c2
-rw-r--r--modules/pam_rhosts/pam_rhosts_auth.c2
-rw-r--r--modules/pam_selinux/pam_selinux.c2
-rw-r--r--modules/pam_stress/pam_stress.c2
-rw-r--r--modules/pam_tally/pam_tally.c2
-rw-r--r--modules/pam_time/pam_time.c2
-rw-r--r--modules/pam_umask/pam_umask.c2
-rw-r--r--modules/pam_unix/pam_unix_acct.c2
-rw-r--r--modules/pam_unix/pam_unix_auth.c2
-rw-r--r--modules/pam_unix/pam_unix_passwd.c2
-rw-r--r--modules/pam_unix/pam_unix_sess.c2
-rw-r--r--modules/pam_unix/unix_chkpwd.c2
-rw-r--r--modules/pam_unix/yppasswd_xdr.c2
-rw-r--r--modules/pam_userdb/pam_userdb.c2
-rw-r--r--modules/pam_xauth/pam_xauth.c2
-rw-r--r--modules/pammodutil/pammodutil.h3
40 files changed, 55 insertions, 46 deletions
diff --git a/CHANGELOG b/CHANGELOG
index 3e80b5b2..f76af2eb 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -69,6 +69,7 @@ BerliOS Bugs are marked with (BerliOS #XXXX).
* configure.in: Fix AC_DEFINE usage for autoheader (kukuk)
* configure.in/_pam_aconf.h.in: Remove feature.h inclusion (kukuk)
* defs: Remove obsolete directory/content (kukuk)
+* Rename _pam_aconf.h.in to config.h (kukuk)
0.80: Wed Jul 13 13:23:20 CEST 2005
* pam_tally: test for NULL data before dereferencing them (t8m)
diff --git a/Makefile b/Makefile
index 1867ad3e..ad33c122 100644
--- a/Makefile
+++ b/Makefile
@@ -18,12 +18,12 @@ THINGSTOMAKE = libpam libpamc libpam_misc modules doc examples
all: $(THINGSTOMAKE)
# Let's get a dynamic libpam.so first
- bootstrap-libpam: _pam_aconf.h prep
+ bootstrap-libpam: config.h prep
$(MAKE) -C libpam bootstrap-libpam
prep:
rm -f security
- ln -sf . security
+# ln -sf . security
clean:
if [ ! -f Make.Rules ]; then touch Make.Rules ; fi
@@ -31,19 +31,19 @@ clean:
rm -f security *~ *.orig *.rej #*#
distclean: clean
- rm -f Make.Rules _pam_aconf.h
+ rm -f Make.Rules config.h
rm -f config.status config.cache config.log core
rm -rf autom4te.cache/
maintainer-clean: distclean
@echo files should be ok for packaging now.
-# NB _pam_aconf.h.in changes will remake this too
-Make.Rules: configure Make.Rules.in _pam_aconf.h.in
+# NB config.h.in changes will remake this too
+Make.Rules: configure Make.Rules.in config.h.in
./config.status --recheck
./config.status
-_pam_aconf.h: Make.Rules
+config.h: Make.Rules
configure: configure.in
@echo
@@ -53,14 +53,14 @@ configure: configure.in
@rm -f configure
@exit 1
-$(THINGSTOMAKE): _pam_aconf.h prep bootstrap-libpam
+$(THINGSTOMAKE): config.h prep bootstrap-libpam
$(MAKE) -C $@ all
-install: _pam_aconf.h prep
+install: config.h prep
for x in $(THINGSTOMAKE) ; do $(MAKE) -C $$x install ; done
remove:
- rm -f $(FAKEROOT)$(INCLUDED)/_pam_aconf.h
+ rm -f $(FAKEROOT)$(INCLUDED)/config.h
for x in $(THINGSTOMAKE) ; do $(MAKE) -C $$x remove ; done
release:
diff --git a/_pam_aconf.h.in b/config.h.in
index 0a491d15..acf6c435 100644
--- a/_pam_aconf.h.in
+++ b/config.h.in
@@ -1,4 +1,4 @@
-/* _pam_aconf.h.in. Generated from configure.in by autoheader. */
+/* config.h.in. Generated from configure.in by autoheader. */
/* lots of stuff gets written to /tmp/pam-debug.log */
#undef DEBUG
diff --git a/configure b/configure
index bcfb5475..389997c7 100755
--- a/configure
+++ b/configure
@@ -1314,7 +1314,7 @@ ac_compiler_gnu=$ac_cv_c_compiler_gnu
- ac_config_headers="$ac_config_headers _pam_aconf.h"
+ ac_config_headers="$ac_config_headers config.h"
@@ -8142,7 +8142,7 @@ do
case "$ac_config_target" in
# Handling of arguments.
"Make.Rules" ) CONFIG_FILES="$CONFIG_FILES Make.Rules" ;;
- "_pam_aconf.h" ) CONFIG_HEADERS="$CONFIG_HEADERS _pam_aconf.h" ;;
+ "config.h" ) CONFIG_HEADERS="$CONFIG_HEADERS config.h" ;;
*) { { echo "$as_me:$LINENO: error: invalid argument: $ac_config_target" >&5
echo "$as_me: error: invalid argument: $ac_config_target" >&2;}
{ (exit 1); exit 1; }; };;
diff --git a/configure.in b/configure.in
index 11968af0..59c90a98 100644
--- a/configure.in
+++ b/configure.in
@@ -2,7 +2,7 @@ dnl Process this file with autoconf to produce a configure script.
AC_INIT(conf/pam_conv1/pam_conv.y)
dnl The configuration header file
-AC_CONFIG_HEADER(_pam_aconf.h)
+AC_CONFIG_HEADER(config.h)
dnl
dnl Release specific
diff --git a/examples/xsh.c b/examples/xsh.c
index 7ec5c7a2..e25531bb 100644
--- a/examples/xsh.c
+++ b/examples/xsh.c
@@ -5,7 +5,7 @@
/* Andrew Morgan (morgan@kernel.org) -- an example application
* that invokes a shell, based on blank.c */
-#include <security/_pam_aconf.h>
+#include "config.h"
#include <stdio.h>
#include <stdlib.h>
diff --git a/libpam/pam_private.h b/libpam/pam_private.h
index b795f6f7..9d759ca9 100644
--- a/libpam/pam_private.h
+++ b/libpam/pam_private.h
@@ -16,7 +16,7 @@
#ifndef _PAM_PRIVATE_H
#define _PAM_PRIVATE_H
-#include <security/_pam_aconf.h>
+#include "config.h"
/* this is not used at the moment --- AGM */
#define LIBPAM_VERSION (LIBPAM_VERSION_MAJOR*0x100 + LIBPAM_VERSION_MINOR)
diff --git a/libpam_misc/misc_conv.c b/libpam_misc/misc_conv.c
index 9bee5884..926603bd 100644
--- a/libpam_misc/misc_conv.c
+++ b/libpam_misc/misc_conv.c
@@ -6,7 +6,7 @@
* Written by Andrew Morgan <morgan@linux.kernel.org>
*/
-#include <security/_pam_aconf.h>
+#include "config.h"
#include <signal.h>
#include <stdio.h>
diff --git a/modules/pam_access/pam_access.c b/modules/pam_access/pam_access.c
index 2533243d..d35cf043 100644
--- a/modules/pam_access/pam_access.c
+++ b/modules/pam_access/pam_access.c
@@ -25,7 +25,7 @@
*************************************************************************
*/
-#include <security/_pam_aconf.h>
+#include "config.h"
#include <stdio.h>
#include <stdlib.h>
diff --git a/modules/pam_cracklib/pam_cracklib.c b/modules/pam_cracklib/pam_cracklib.c
index 1695e841..e260b0a8 100644
--- a/modules/pam_cracklib/pam_cracklib.c
+++ b/modules/pam_cracklib/pam_cracklib.c
@@ -35,7 +35,7 @@
* S.A.G. in the section on the cracklib module.
*/
-#include <security/_pam_aconf.h>
+#include "config.h"
#include <stdio.h>
#ifdef HAVE_CRYPT_H
diff --git a/modules/pam_env/pam_env.c b/modules/pam_env/pam_env.c
index d05e33f8..5f43f07d 100644
--- a/modules/pam_env/pam_env.c
+++ b/modules/pam_env/pam_env.c
@@ -15,7 +15,7 @@
#define DEFAULT_ETC_ENVFILE "/etc/environment"
#define DEFAULT_READ_ENVFILE 0
-#include <security/_pam_aconf.h>
+#include "config.h"
#include <ctype.h>
#include <errno.h>
diff --git a/modules/pam_filter/pam_filter.c b/modules/pam_filter/pam_filter.c
index 2b7f6bf0..c03126ca 100644
--- a/modules/pam_filter/pam_filter.c
+++ b/modules/pam_filter/pam_filter.c
@@ -5,7 +5,7 @@
* Richard Stevens' UNIX Network Programming book.
*/
-#include <security/_pam_aconf.h>
+#include "config.h"
#include <stdlib.h>
#include <syslog.h>
diff --git a/modules/pam_filter/upperLOWER/upperLOWER.c b/modules/pam_filter/upperLOWER/upperLOWER.c
index 72f9dab5..5aa0e2c0 100644
--- a/modules/pam_filter/upperLOWER/upperLOWER.c
+++ b/modules/pam_filter/upperLOWER/upperLOWER.c
@@ -7,7 +7,7 @@
* it serves no purpose other than to annoy the user...
*/
-#include <security/_pam_aconf.h>
+#include "config.h"
#ifdef MEMORY_DEBUG
# undef exit
diff --git a/modules/pam_ftp/pam_ftp.c b/modules/pam_ftp/pam_ftp.c
index 482ba3a4..870266cc 100644
--- a/modules/pam_ftp/pam_ftp.c
+++ b/modules/pam_ftp/pam_ftp.c
@@ -14,7 +14,7 @@
/* the following is a password that "can't be correct" */
#define BLOCK_PASSWORD "\177BAD PASSWPRD\177"
-#include <security/_pam_aconf.h>
+#include "config.h"
#include <stdio.h>
#include <stdlib.h>
diff --git a/modules/pam_group/pam_group.c b/modules/pam_group/pam_group.c
index 379c4d51..896f1e84 100644
--- a/modules/pam_group/pam_group.c
+++ b/modules/pam_group/pam_group.c
@@ -13,6 +13,8 @@ static const char rcsid[] =
#define _BSD_SOURCE
+#include "config.h"
+
#include <sys/file.h>
#include <stdio.h>
#include <stdlib.h>
diff --git a/modules/pam_issue/pam_issue.c b/modules/pam_issue/pam_issue.c
index 5c93da88..9c52c106 100644
--- a/modules/pam_issue/pam_issue.c
+++ b/modules/pam_issue/pam_issue.c
@@ -17,6 +17,8 @@
#define _GNU_SOURCE
#define _BSD_SOURCE
+#include "config.h"
+
#include <string.h>
#include <stdio.h>
#include <stdlib.h>
diff --git a/modules/pam_lastlog/pam_lastlog.c b/modules/pam_lastlog/pam_lastlog.c
index e9c89786..78a85e78 100644
--- a/modules/pam_lastlog/pam_lastlog.c
+++ b/modules/pam_lastlog/pam_lastlog.c
@@ -10,7 +10,7 @@
* present (login) service.
*/
-#include <security/_pam_aconf.h>
+#include "config.h"
#include <fcntl.h>
#include <time.h>
diff --git a/modules/pam_limits/pam_limits.c b/modules/pam_limits/pam_limits.c
index 704832ef..0c245539 100644
--- a/modules/pam_limits/pam_limits.c
+++ b/modules/pam_limits/pam_limits.c
@@ -17,7 +17,7 @@
#error THIS CODE IS KNOWN TO WORK ONLY ON LINUX !!!
#endif
-#include <security/_pam_aconf.h>
+#include "config.h"
#include <stdio.h>
#include <unistd.h>
diff --git a/modules/pam_listfile/pam_listfile.c b/modules/pam_listfile/pam_listfile.c
index d5b462d4..a2965b77 100644
--- a/modules/pam_listfile/pam_listfile.c
+++ b/modules/pam_listfile/pam_listfile.c
@@ -10,7 +10,7 @@
* This code began life as the pam_rootok module.
*/
-#include <security/_pam_aconf.h>
+#include "config.h"
#include <stdio.h>
#include <stdlib.h>
diff --git a/modules/pam_localuser/pam_localuser.c b/modules/pam_localuser/pam_localuser.c
index e5496089..4c540376 100644
--- a/modules/pam_localuser/pam_localuser.c
+++ b/modules/pam_localuser/pam_localuser.c
@@ -33,7 +33,7 @@
* OF THE POSSIBILITY OF SUCH DAMAGE.
*/
-#include "../../_pam_aconf.h"
+#include "config.h"
#include <errno.h>
#include <limits.h>
diff --git a/modules/pam_mail/pam_mail.c b/modules/pam_mail/pam_mail.c
index dde8887f..81dedcea 100644
--- a/modules/pam_mail/pam_mail.c
+++ b/modules/pam_mail/pam_mail.c
@@ -8,7 +8,7 @@
* mailhash additions by Chris Adams <cadams@ro.com> 1998/7/11
*/
-#include <security/_pam_aconf.h>
+#include "config.h"
#include <ctype.h>
#include <pwd.h>
diff --git a/modules/pam_mkhomedir/pam_mkhomedir.c b/modules/pam_mkhomedir/pam_mkhomedir.c
index cb681b90..6f68b0aa 100644
--- a/modules/pam_mkhomedir/pam_mkhomedir.c
+++ b/modules/pam_mkhomedir/pam_mkhomedir.c
@@ -28,7 +28,10 @@
*/
/* I want snprintf dammit */
-#define _GNU_SOURCE 1
+#define _GNU_SOURCE
+
+#include "config.h"
+
#include <stdarg.h>
#include <sys/types.h>
#include <sys/stat.h>
diff --git a/modules/pam_motd/pam_motd.c b/modules/pam_motd/pam_motd.c
index 8cdb633f..a64d6a41 100644
--- a/modules/pam_motd/pam_motd.c
+++ b/modules/pam_motd/pam_motd.c
@@ -10,7 +10,7 @@
*
*/
-#include <security/_pam_aconf.h>
+#include "config.h"
#include <stdio.h>
#include <string.h>
diff --git a/modules/pam_pwdb/pam_pwdb.c b/modules/pam_pwdb/pam_pwdb.c
index d736c6a8..b118ab23 100644
--- a/modules/pam_pwdb/pam_pwdb.c
+++ b/modules/pam_pwdb/pam_pwdb.c
@@ -20,7 +20,7 @@ static const char rcsid[] =
/* #define DEBUG */
-#include <security/_pam_aconf.h>
+#include "config.h"
#include <sys/types.h>
#include <stdarg.h>
diff --git a/modules/pam_pwdb/pwdb_chkpwd.c b/modules/pam_pwdb/pwdb_chkpwd.c
index e4fe38f8..a4da0e13 100644
--- a/modules/pam_pwdb/pwdb_chkpwd.c
+++ b/modules/pam_pwdb/pwdb_chkpwd.c
@@ -13,7 +13,7 @@
*
*/
-#include <security/_pam_aconf.h>
+#include "config.h"
#ifdef MEMORY_DEBUG
# undef exit
diff --git a/modules/pam_rhosts/pam_rhosts_auth.c b/modules/pam_rhosts/pam_rhosts_auth.c
index 961d1910..816addad 100644
--- a/modules/pam_rhosts/pam_rhosts_auth.c
+++ b/modules/pam_rhosts/pam_rhosts_auth.c
@@ -38,7 +38,7 @@
* SUCH DAMAGE.
*/
-#include <security/_pam_aconf.h>
+#include "config.h"
#define USER_RHOSTS_FILE "/.rhosts" /* prefixed by user's home dir */
diff --git a/modules/pam_selinux/pam_selinux.c b/modules/pam_selinux/pam_selinux.c
index 290853d4..4f010009 100644
--- a/modules/pam_selinux/pam_selinux.c
+++ b/modules/pam_selinux/pam_selinux.c
@@ -38,7 +38,7 @@
*
*/
-#include "../../_pam_aconf.h"
+#include "config.h"
#include <errno.h>
#include <limits.h>
diff --git a/modules/pam_stress/pam_stress.c b/modules/pam_stress/pam_stress.c
index 194c044d..0365f443 100644
--- a/modules/pam_stress/pam_stress.c
+++ b/modules/pam_stress/pam_stress.c
@@ -5,7 +5,7 @@
* created by Andrew Morgan <morgan@linux.kernel.org> 1996/3/12
*/
-#include <security/_pam_aconf.h>
+#include "config.h"
#include <stdlib.h>
#include <stdio.h>
diff --git a/modules/pam_tally/pam_tally.c b/modules/pam_tally/pam_tally.c
index 075392c7..b49ef352 100644
--- a/modules/pam_tally/pam_tally.c
+++ b/modules/pam_tally/pam_tally.c
@@ -14,7 +14,7 @@
* Audit option added for Tomas patch by Sebastien Tricaud <toady@gscore.org> 13 January 2005
*/
-#include <security/_pam_aconf.h>
+#include "config.h"
#if defined(MAIN) && defined(MEMORY_DEBUG)
# undef exit
diff --git a/modules/pam_time/pam_time.c b/modules/pam_time/pam_time.c
index 5a5281a6..a7e79364 100644
--- a/modules/pam_time/pam_time.c
+++ b/modules/pam_time/pam_time.c
@@ -13,7 +13,7 @@ static const char rcsid[] =
"\t\tVersion 0.22 for Linux-PAM\n"
"Copyright (C) Andrew G. Morgan 1996 <morgan@linux.kernel.org>\n";
-#include <security/_pam_aconf.h>
+#include "config.h"
#include <sys/file.h>
#include <stdio.h>
diff --git a/modules/pam_umask/pam_umask.c b/modules/pam_umask/pam_umask.c
index 53832253..e13f55ad 100644
--- a/modules/pam_umask/pam_umask.c
+++ b/modules/pam_umask/pam_umask.c
@@ -35,7 +35,7 @@
#define _GNU_SOURCE
-#include <security/_pam_aconf.h>
+#include "config.h"
#include <pwd.h>
#include <grp.h>
diff --git a/modules/pam_unix/pam_unix_acct.c b/modules/pam_unix/pam_unix_acct.c
index 6e8ed614..b5160cde 100644
--- a/modules/pam_unix/pam_unix_acct.c
+++ b/modules/pam_unix/pam_unix_acct.c
@@ -34,7 +34,7 @@
* OF THE POSSIBILITY OF SUCH DAMAGE.
*/
-#include <security/_pam_aconf.h>
+#include "config.h"
#include <stdlib.h>
#include <stdio.h>
diff --git a/modules/pam_unix/pam_unix_auth.c b/modules/pam_unix/pam_unix_auth.c
index 2ed24127..23eba7e6 100644
--- a/modules/pam_unix/pam_unix_auth.c
+++ b/modules/pam_unix/pam_unix_auth.c
@@ -37,7 +37,7 @@
/* #define DEBUG */
-#include <security/_pam_aconf.h>
+#include "config.h"
#include <stdio.h>
#include <stdlib.h>
diff --git a/modules/pam_unix/pam_unix_passwd.c b/modules/pam_unix/pam_unix_passwd.c
index 99b127a0..f1f87a2c 100644
--- a/modules/pam_unix/pam_unix_passwd.c
+++ b/modules/pam_unix/pam_unix_passwd.c
@@ -35,7 +35,7 @@
* OF THE POSSIBILITY OF SUCH DAMAGE.
*/
-#include <security/_pam_aconf.h>
+#include "config.h"
#include <stdio.h>
#include <stdlib.h>
diff --git a/modules/pam_unix/pam_unix_sess.c b/modules/pam_unix/pam_unix_sess.c
index b888b64f..e783039e 100644
--- a/modules/pam_unix/pam_unix_sess.c
+++ b/modules/pam_unix/pam_unix_sess.c
@@ -36,7 +36,7 @@
* OF THE POSSIBILITY OF SUCH DAMAGE.
*/
-#include <security/_pam_aconf.h>
+#include "config.h"
#include <stdio.h>
#include <stdlib.h>
diff --git a/modules/pam_unix/unix_chkpwd.c b/modules/pam_unix/unix_chkpwd.c
index 2ad95362..5e4b0eae 100644
--- a/modules/pam_unix/unix_chkpwd.c
+++ b/modules/pam_unix/unix_chkpwd.c
@@ -13,7 +13,7 @@
*
*/
-#include <security/_pam_aconf.h>
+#include "config.h"
#ifdef MEMORY_DEBUG
# undef exit
diff --git a/modules/pam_unix/yppasswd_xdr.c b/modules/pam_unix/yppasswd_xdr.c
index b1a60b4c..bf3f2fc6 100644
--- a/modules/pam_unix/yppasswd_xdr.c
+++ b/modules/pam_unix/yppasswd_xdr.c
@@ -10,7 +10,7 @@
* editied manually.
*/
-#include <security/_pam_aconf.h>
+#include "config.h"
#include <rpc/rpc.h>
#include <rpcsvc/yp_prot.h>
diff --git a/modules/pam_userdb/pam_userdb.c b/modules/pam_userdb/pam_userdb.c
index 50170f84..09467877 100644
--- a/modules/pam_userdb/pam_userdb.c
+++ b/modules/pam_userdb/pam_userdb.c
@@ -6,7 +6,7 @@
* See the end of the file for Copyright Information
*/
-#include <security/_pam_aconf.h>
+#include "config.h"
#include <stdio.h>
#include <stdlib.h>
diff --git a/modules/pam_xauth/pam_xauth.c b/modules/pam_xauth/pam_xauth.c
index 47832b6b..95a6dba5 100644
--- a/modules/pam_xauth/pam_xauth.c
+++ b/modules/pam_xauth/pam_xauth.c
@@ -35,7 +35,7 @@
/* "$Id$" */
-#include "../../_pam_aconf.h"
+#include "config.h"
#include <sys/types.h>
#include <sys/fsuid.h>
#include <sys/wait.h>
diff --git a/modules/pammodutil/pammodutil.h b/modules/pammodutil/pammodutil.h
index fbe81023..d60d588a 100644
--- a/modules/pammodutil/pammodutil.h
+++ b/modules/pammodutil/pammodutil.h
@@ -7,7 +7,8 @@
* Copyright (c) 2001 Andrew Morgan <morgan@kernel.org>
*/
-#include <security/_pam_aconf.h>
+#include "config.h"
+
#include <security/_pam_macros.h>
#include <security/pam_modules.h>
#include <security/_pam_modutil.h>