summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThorsten Kukuk <kukuk@thkukuk.de>2003-11-26 10:31:10 +0000
committerThorsten Kukuk <kukuk@thkukuk.de>2003-11-26 10:31:10 +0000
commit9ab56e3be6dc9a7df2812a64c3d7acbfd385d9fc (patch)
tree3f6c18d63eda571c36e612a4a33e23aba0749f29
parent9ebb94c98ea89a15d738d02f07ab5a63220e851b (diff)
Relevant BUGIDs: 849545
Purpose of commit: bugfix/cleanup Commit summary: --------------- CFLAGS from configure run is ignored by Make.Rules. modules should build after libpam, so that we can link against libpam. In one place, "ar" instead of "$(AR)" is used.
-rw-r--r--Make.Rules.in2
-rw-r--r--Makefile2
-rw-r--r--libpam/Makefile2
3 files changed, 3 insertions, 3 deletions
diff --git a/Make.Rules.in b/Make.Rules.in
index 2aab9bf9..06c97f0a 100644
--- a/Make.Rules.in
+++ b/Make.Rules.in
@@ -92,7 +92,7 @@ CRACKLIB_DICTPATH=@CRACKLIB_DICTPATH@
# generic build setup
OS=@OS@
CC=@CC@
-CFLAGS=$(WARNINGS) -D$(OS) $(OS_CFLAGS) $(HEADER_DIRS) @CONF_CFLAGS@
+CFLAGS=@CFLAGS@ $(WARNINGS) -D$(OS) $(OS_CFLAGS) $(HEADER_DIRS) @CONF_CFLAGS@
LD=@LD@
LD_D=@LD_D@
LD_L=@LD_L@
diff --git a/Makefile b/Makefile
index d4afd221..1ab1b711 100644
--- a/Makefile
+++ b/Makefile
@@ -15,7 +15,7 @@ ifeq ($(shell test \! -f Make.Rules || echo yes),yes)
include Make.Rules
endif
-THINGSTOMAKE = modules libpam libpamc libpam_misc doc examples
+THINGSTOMAKE = libpam libpamc libpam_misc modules doc examples
all: $(THINGSTOMAKE)
diff --git a/libpam/Makefile b/libpam/Makefile
index d87cb028..e2b9649e 100644
--- a/libpam/Makefile
+++ b/libpam/Makefile
@@ -112,7 +112,7 @@ endif
$(LIBPAMSTATIC): $(SLIBOBJECTS)
ifeq ($(STATIC_LIBPAM),yes)
- ar cr $@ $(SLIBOBJECTS) $(MODULES)
+ $(AR) cr $@ $(SLIBOBJECTS) $(MODULES)
$(RANLIB) $@
endif