summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Langasek <vorlon@debian.org>2008-07-28 13:35:47 -0700
committerSteve Langasek <steve.langasek@ubuntu.com>2019-01-03 17:28:18 -0800
commita8f1136ee50388f7fc1c7936379416bbee368957 (patch)
tree681ab3ac60cad323f2b2d546b63a170502aab95f
parent066340007b21fa197dcce85fc442551a75e42290 (diff)
Fix a bug in the uid-restoring code in the hurd_no_setfsuid patch; thanks
to Tomas Mraz <tmraz@redhat.com> for indirectly bringing this to my attention
-rw-r--r--debian/changelog3
-rw-r--r--debian/patches-applied/hurd_no_setfsuid2
2 files changed, 4 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index e47407a8..08dfcebf 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -91,6 +91,9 @@ pam (1.0.1-1) UNRELEASED; urgency=low
other manpages. Closes: #470137.
* Add debian/README.source documenting that this package uses quilt.
* Bump Standards-Version to 3.8.0.
+ * Fix a bug in the uid-restoring code in the hurd_no_setfsuid patch; thanks
+ to Tomas Mraz <tmraz@redhat.com> for indirectly bringing this to my
+ attention
-- Steve Langasek <vorlon@debian.org> Tue, 22 Jul 2008 10:55:45 -0700
diff --git a/debian/patches-applied/hurd_no_setfsuid b/debian/patches-applied/hurd_no_setfsuid
index 71ae5d77..76501432 100644
--- a/debian/patches-applied/hurd_no_setfsuid
+++ b/debian/patches-applied/hurd_no_setfsuid
@@ -55,7 +55,7 @@ Index: Linux-PAM/modules/pam_xauth/pam_xauth.c
+ if (uid == pwd->pw_uid)
+ setreuid(uid, euid);
+ else {
-+ if (setreuid(-1, 0) == -1)
++ if (setreuid(-1, 0) != -1)
+ setreuid(uid, -1);
+ setreuid(-1, euid);
+ }