summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThorsten Kukuk <kukuk@thkukuk.de>2003-11-27 07:54:20 +0000
committerThorsten Kukuk <kukuk@thkukuk.de>2003-11-27 07:54:20 +0000
commitad89e8953313866982bfd5bc69eab42a2b2b666d (patch)
tree2bab066758ab6ba19bb52075b0e7bebf107ae098
parent6216e61ca2ed39128a9d29ec2d7e389addb4812e (diff)
Relevant BUGIDs: 850092
Purpose of commit: bugfix Commit summary: --------------- Using the fakeroot option as normal user does not work, since we call ldconfig, which aborts with an error message if not called as root due missing permissions. Fixed by calling ldconfig with -n library path option if FAKEROOT is set.
-rw-r--r--libpam/Makefile6
-rw-r--r--libpam_misc/Makefile4
-rw-r--r--libpamc/Makefile4
3 files changed, 14 insertions, 0 deletions
diff --git a/libpam/Makefile b/libpam/Makefile
index e2b9649e..6728d635 100644
--- a/libpam/Makefile
+++ b/libpam/Makefile
@@ -128,7 +128,11 @@ ifdef MEMORY_DEBUG
endif
ifeq ($(DYNAMIC_LIBPAM),yes)
$(INSTALL) -m $(SHLIBMODE) $(LIBPAM) $(FAKEROOT)$(libdir)/$(LIBPAMFULL)
+ifndef FAKEROOT
$(LDCONFIG)
+else
+ $(LDCONFIG) -n $(FAKEROOT)$(libdir)
+endif
ifneq ($(DYNTYPE),"sl")
( cd $(FAKEROOT)$(libdir) ; rm -f $(LIBPAM) ; \
ln -sf $(LIBPAMNAME) $(LIBPAM) )
@@ -146,7 +150,9 @@ remove:
rm -f $(FAKEROOT)$(INCLUDED)/pam_malloc.h
rm -f $(FAKEROOT)$(libdir)/$(LIBPAM).*
rm -f $(FAKEROOT)$(libdir)/$(LIBPAM)
+ifndef FAKEROOT
$(LDCONFIG)
+endif
rm -f $(FAKEROOT)$(libdir)/$(LIBPAMSTATIC)
clean:
diff --git a/libpam_misc/Makefile b/libpam_misc/Makefile
index e9b1a6c1..16ba07e6 100644
--- a/libpam_misc/Makefile
+++ b/libpam_misc/Makefile
@@ -84,7 +84,11 @@ install: all
ifeq ($(DYNAMIC_LIBPAM),yes)
$(MKDIR) $(FAKEROOT)$(libdir)
$(INSTALL) -m $(SHLIBMODE) $(LIBNAMED) $(FAKEROOT)$(libdir)/$(LIBNAMEDFULL)
+ifndef FAKEROOT
$(LDCONFIG)
+else
+ $(LDCONFIG) -n $(FAKEROOT)$(libdir)
+endif
ifneq ($(DYNTYPE),"sl")
( cd $(FAKEROOT)$(libdir) ; rm -f $(LIBNAMED) ; ln -s $(LIBNAMEDNAME) $(LIBNAMED) )
endif
diff --git a/libpamc/Makefile b/libpamc/Makefile
index 45d42051..49befe4b 100644
--- a/libpamc/Makefile
+++ b/libpamc/Makefile
@@ -83,7 +83,11 @@ install: all
ifeq ($(DYNAMIC_LIBPAM),yes)
$(MKDIR) $(FAKEROOT)$(libdir)
$(INSTALL) -m $(SHLIBMODE) $(LIBNAMED) $(FAKEROOT)$(libdir)/$(LIBNAMEDFULL)
+ifndef FAKEROOT
$(LDCONFIG)
+else
+ $(LDCONFIG) -n $(FAKEROOT)$(libdir)
+endif
ifneq ($(DYNTYPE),"sl")
( cd $(FAKEROOT)$(libdir) ; rm -f $(LIBNAMED) ; ln -s $(LIBNAMEDNAME) $(LIBNAMED) )
endif