summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Langasek <vorlon@debian.org>2009-09-07 11:48:03 -0700
committerSteve Langasek <vorlon@debian.org>2019-01-08 21:26:01 -0800
commitb3bbdebae5e1a22ef9a98e3b6eccd3dedc0f3212 (patch)
treed839c9beae6225aa1973bc404f87acace4aa849f
parentf27f8b1bd4906cd4c4050d64e53bc00ccfb6047b (diff)
guard the other libpam-modules-specific bit, and get the sense of the
dh_listpackages check right
-rwxr-xr-xdebian/rules4
1 files changed, 3 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index bb26739c..d8cc37ed 100755
--- a/debian/rules
+++ b/debian/rules
@@ -34,7 +34,9 @@ override_dh_compress:
# .install files don't have "except for" handling, so we need to exclude
# our module that doesn't match right here
override_dh_install:
+ifneq (,$(findstring libpam-modules, $(shell dh_listpackages)))
dh_install -plibpam-modules -Xpam_cracklib
+endif
dh_install -Nlibpam-modules
# again, excluding files by hand; also, build our local manpage for pam_getenv
@@ -49,7 +51,7 @@ override_dh_installman:
# dh_fixperms doesn't want
override_dh_fixperms:
dh_fixperms
-ifeq (,$(findstring libpam-modules, $(shell dh_listpackages)))
+ifneq (,$(findstring libpam-modules, $(shell dh_listpackages)))
chgrp shadow $(d)/libpam-modules/sbin/unix_chkpwd
chmod 02755 $(d)/libpam-modules/sbin/unix_chkpwd
endif